3G FDD Measurements (R&S FSW-K72/K73)
Contents
  • Welcome to the 3GPP FDD Applications
  • Measurements and Result Display
  • Measurement Basics
  • Configuration
  • Analysis
  • I/Q Data Import and Export
  • Optimizing and Troubleshooting the Measurement
  • How to Perform Measurements in 3GPP FDD Applications
  • Measurement Examples
  • Remote Commands for 3GPP FDD Measurements
  • List of Commands
Top


Welcome to the 3GPP FDD Applications

3G FDD Measurements (R&S FSW-K72/K73) > Welcome to the 3GPP FDD Applications
Welcome to the 3GPP FDD Applications

The 3GPP FDD applications add functionality to the R&S FSW to perform code domain analysis or power measurements according to the 3GPP standard (FDD mode). The application firmware is in line with the 3GPP standard (Third Generation Partnership Project) with Release 5. Signals that meet the conditions for channel configuration of test models 1 to 4 according to the 3GPP standard, e.g. W-CDMA signals using FDD, can be measured with the 3GPP FDD BTS application. In addition to the code domain measurements specified by the 3GPP standard, the application firmware offers measurements with predefined settings in the frequency domain, e.g. power and ACLR measurements.

R&S FSW-K72 performs Base Transceiver Station (BTS) measurements (for downlink signals).

R&S FSW-K73 performs User Equipment (UE) measurements (for uplink signals).

In particular, the 3GPP FDD applications feature:

  • Code domain analysis, providing results like code domain power, EVM, peak code domain error etc.
  • Time alignment error determination
  • Various power measurements
  • Spectrum Emission Mask measurements
  • Statistical (CCDF) evaluation

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage

http://www2.rohde-schwarz.com/product/FSW.html.

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the 3GPP FDD Application
  • Understanding the Display Information


Starting the 3GPP FDD Application

3G FDD Measurements (R&S FSW-K72/K73) > Welcome to the 3GPP FDD Applications > Starting the 3GPP FDD Application
Starting the 3GPP FDD Application

The 3GPP FDD measurements require a special application on the R&S FSW.

To activate the 3GPP FDD applications

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "3GPP FDD BTS" or "3GPP FDD UE" item.

    The R&S FSW opens a new measurement channel for the 3GPP FDD application.

For details see "Operating Modes" .

A Code Domain Analysis measurement is started immediately with the default settings. It can be configured in the 3GPP FDD "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (including the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

3G FDD Measurements (R&S FSW-K72/K73) > Welcome to the 3GPP FDD Applications > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during a 3GPP FDD BTS measurement. All different information areas are labeled. They are explained in more detail in the following sections.

(The basic screen elements are identical for 3GPP FDD UE measurements)

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information
6 = Instrument status bar with error messages, progress bar and date/time display
MSRA operating mode

In MSRA operating mode, additional tabs and elements are available. A colored background of the screen behind the measurement channel tabs indicates that you are in MSRA operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Channel bar information

In 3GPP FDD applications, when performing Code Domain Analysis, the R&S FSW screen display deviates from the Spectrum application. For RF measurements, the familiar settings are displayed (see the R&S FSW Getting Started manual).

Hardware settings displayed in the channel bar in 3GPP FDD applications for Code Domain Analysis

Ref Level

Reference level

Att

Mechanical and electronic RF attenuation

Freq

Center frequency for the RF signal

Channel

Channel number (code number and spreading factor)

CPICH Slot

/ Slot (UE)

Slot of the (CPICH) channel

Power

Power result mode:

  • Absolute
  • Relative to CPICH (BTS application (K72) only)
  • Relative to total power

SymbRate

Symbol rate of the current channel

Capture

(UE application (K73) only): basis for analysis (slot or frame)

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in 3GPP applications
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Detector
Diagram footer information

For most graphical evaluations the diagram footer (beneath the diagram) contains scaling information for the x-axis, where applicable:

  • Start channel/chip/frame/slot
  • Channel/chip/frame/slot per division
  • Stop channel/chip/frame/slot
For the Bitstream evaluation, the diagram footer indicates:
  • Channel format (type and modulation type (HS-PDSCH only))
  • Number of data bits
  • Number of TPC bits
  • Number of TFCI bits
  • Number of pilot bits

(The bit numbers are indicated in the order they occur.)

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


Measurements and Result Display

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display
Measurements and Result Display

The 3GPP FDD applications provide several different measurements for signals according to the 3GPP FDD standard. The main and default measurement is Code Domain Analysis. Furthermore, a Time Alignment Error measurement is provided. In addition to the code domain power measurements specified by the 3GPP standard, the 3GPP FDD options offer measurements with predefined settings in the frequency domain, e.g. RF power measurements.

Evaluation methods

The captured and processed data for each measurement can be evaluated with various different methods. All evaluation methods available for the selected 3GPP FDD measurement are displayed in the evaluation bar in SmartGrid mode.

Evaluation range

You can restrict evaluation to a specific channel, frame or slot, depending on the evaluation method. See "Evaluation Range".

Contents
  • Code Domain Analysis
  • Time Alignment Error Measurements
  • RF Measurements


Code Domain Analysis

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis
Code Domain Analysis

The Code Domain Analysis measurement provides various evaluation methods and result diagrams.

The code domain power measurements are performed as specified by the 3GPP standards. A signal section of approximately 20 ms is recorded for analysis and then searched through to find the start of a 3GPP FDD frame. If a frame start is found in the signal, the code domain power analysis is performed for a complete frame starting from slot 0. The different evaluations are calculated from the captured I/Q data set. Therefore it is not necessary to start a new measurement in order to change the evaluation.

The 3GPP FDD applications provide the peak code domain error measurement and composite EVM specified by the 3GPP standard, as well as the code domain power measurement of assigned and unassigned codes. The power can be displayed either for all channels in one slot, or for one channel in all slots. The composite constellation diagram of the entire signal can also be displayed. In addition, the symbols demodulated in a slot, their power, and the determined bits or the symbol EVM can be displayed for an active channel.

The power of a code channel is always measured in relation to its symbol rate within the code domain. It can be displayed either as absolute values or relative to the total signal or the CPICH channel. By default, the power relative to the CPICH channel is displayed. The total power may vary depending on the slot, since the power can be controlled on a per-slot-basis. The power in the CPICH channel, on the other hand, is constant in all slots.

For all measurements performed in a slot of a selected channel (bits, symbols, symbol power, EVM), the actual slot spacing of the channel is taken as a basis, rather than the CPICH slots. The time reference for the start of a slot is the CPICH slot. If code channels contain a timing offset, the start of a specific slot of the channel differs from the start of the reference channel (CPICH). Thus, the power-per-channel display may not be correct. If channels with a timing offset contain a power control circuit, the channel-power-versus-time display may provide better results.

The composite EVM, peak code domain error and composite constellation measurements are always referenced to the total signal.

Remote command:

CONF:WCDP:MEAS WCDP, see CONFigure:​WCDPower[:​BTS]:​MEASurement

Contents
  • Code Domain Parameters
  • Evaluation Methods for Code Domain Analysis
  • CDA Measurements in MSRA Operating Mode


Code Domain Parameters

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Code Domain Parameters
Code Domain Parameters

Two different types of measurement results are determined and displayed in the Result Summary: global results and channel results (for the selected channel).

The number of the CPICH slot at which the measurement is performed is indicated globally for the measurement in the channel bar.

The spreading code of the selected channel is indicated with the channel number in the channel bar and above the channel-specific results in the Result Summary.

In the Channel Table, the analysis results for all active channels are displayed.

General code domain power results for a specific frame and slot
Parameter | Description
Total Power: | The total signal power (average power of total evaluated slot).
Carrier Freq Error: | The frequency error relative to the center frequency of the analyzer. The absolute frequency error is the sum of the analyzer and DUT frequency error. The specified value is averaged for one (CPICH) slot. See also the note below this table.
Chip Rate Error: | The chip rate error in the frame to analyze in ppm. As a result of a high chip rate error, symbol errors arise and the CDP measurement is possibly not synchronized to the 3GPP FDD BTS signal. The result is valid even if synchronization of the analyzer and signal failed.
Trigger to Frame: | The time difference between the beginning of the recorded signal section to the start of the analyzed frame. In case of triggered data collection, this difference is identical with the time difference of frame trigger (+ trigger offset) – frame start. If synchronization of the analyzer and input signal fails, the value of "Trigger to Frame" is not significant.
IQ Offset: | DC offset of the signal in the selected slot in %
IQ Imbalance: | I/Q imbalance of signals in the selected slot in %
Avg Power Inact Chan | Average power of the inactive channels
Composite EVM: | The composite EVM is the difference between the test signal and the ideal reference signal in the selected slot in %. See also "Composite EVM"
Pk CDE (15 ksps): | The Peak Code Domain Error projects the difference between the test signal and the ideal reference signal onto the selected spreading factor in the selected slot (see "Peak Code Domain Error"). The spreading factor onto which projection is performed can be derived from the symbol rate indicated in brackets.
RHO | Quality parameter RHO for each slot.
No of Active Chan: | The number of active channels detected in the signal in the selected slot. Both the detected data channels and the control channels are considered active channels.
Avg. RCDE | Average Relative Code Domain Error over all channels detected with 64 QAM (UE: 4PAM) modulation in the selected frame.
Carrier Frequency Error

The maximum frequency error that can be compensated is specified in table "Maximum frequency error that can be compensated" as a function of the synchronization mode. Transmitter and receiver should be synchronized as far as possible.

Maximum frequency error that can be compensated
SYNC mode | ANTENNA DIV | Max. Freq. Offset
CPICH | X | 5.0 kHz
SCH | OFF | 1.6 kHz
SCH | ANT 1 | 330 Hz
SCH | ANT 2 | 330 Hz
Channel-specific code domain power results

Symbol Rate:

Symbol rate at which the channel is transmitted

Channel Slot No:

(BTS measurements only):

Channel slot number; determined by combining the value of the selected CPICH and the channel's timing offset

Channel Mapping

(UE measurements only):

Branch onto which the channel is mapped (I or Q, specified by the standard)

Chan Power Abs:

Channel power, absolute

Chan Power Rel:

Channel power, relative (referenced to CPICH or total signal power)

Timing Offset:

Offset between the start of the first slot in the channel and the start of the analyzed 3GPP FDD BTS frame

RCDE

Relative Code Domain Error for the complete frame of the selected channel

Symbol EVM:

Peak and average of the results of the error vector magnitude evaluation

No of Pilot Bits:

Number of pilot bits of the selected channel

Modulation Type:

BTS measurements:

Modulation type of an HSDPA channel. High speed physical data channels can be modulated with QPSK, 16 QAM or 64 QAM modulation.

UE measurements: the modulation type of the selected channel. Valid entries are:
  • BPSK I for channels on I-branch
  • BPSK Q for channels on Q-branch
  • NONE for inactive channels


Evaluation Methods for Code Domain Analysis

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis
Evaluation Methods for Code Domain Analysis

The captured I/Q data can be evaluated using various different methods without having to start a new measurement. All evaluation methods available for the selected 3GPP FDD measurement are displayed in the evaluation bar in SmartGrid mode.

To activate SmartGrid mode, do one of the following:
  • Select the "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the configuration "Overview".
  • Select the "Display Config" softkey from the MEAS CONFIG menu.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .

The selected evaluation also affects the results of the trace data query (see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>").

└ Bitstream
└ Channel Table
└ Table Configuration
└ Code Domain Power
└ Code Domain Error Power
└ Composite Constellation
└ Composite EVM
└ EVM vs Chip
└ Frequency Error vs Slot
└ Mag Error vs Chip
└ Marker Table
└ Peak Code Domain Error
└ Phase Discontinuity vs Slot
└ Phase Error vs Chip
└ Power vs Slot
└ Power vs Symbol
└ Result Summary
└ Symbol Constellation
└ Symbol EVM
└ Symbol Magnitude Error
└ Symbol Phase Error


Bitstream

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Bitstream
Bitstream

The "Bitstream" evaluation displays the demodulated bits of a selected channel for a given slot. Depending on the symbol rate the number of symbols within a slot can vary from 12 (min) to 384 (max). For QPSK modulation a symbol consists of 2 Bits (I and Q). For BPSK modulation a symbol consists of 1 Bit (only I used).

TIP: Select a specific symbol using the MKR key while the display is focused. If you enter a number, the marker jumps to the selected symbol, which is highlighted by a blue circle.

The diagram footer indicates:
  • Channel format (type and modulation type (HS-PDSCH only))
  • Number of data bits (D1 / D2)
  • Number of TPC bits (TPC)
  • Number of TFCI bits (TFCI)
  • Number of pilot bits (Pil)
Remote command:

LAY:ADD? '1',RIGH, BITS, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? ABITstream


Channel Table

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Channel Table
Channel Table

The "Channel Table" evaluation displays the detected channels and the results of the code domain power measurement. The channel table can contain a maximum of 512 entries.

In BTS measurements, this corresponds to the 512 codes that can be assigned within the class of spreading factor 512.

In UE measurements, this corresponds to the 256 codes that can be assigned within the class of spreading factor 256, with both I and Q branches.

The first entries of the table indicate the channels that must be available in the signal to be analyzed and any other control channels (see "BTS Channel Types" and "UE Channel Types").

The lower part of the table indicates the data channels that are contained in the signal.

If the type of a channel can be fully recognized, based on pilot sequences or modulation type, the type is indicated in the table. In BTS measurements, all other channels are of type CHAN.

The channels are in descending order according to symbol rates and, within a symbol rate, in ascending order according to the channel numbers. Therefore, the unassigned codes are always displayed at the end of the table.

Remote command:

LAY:ADD? '1',RIGH, CTABle, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? CTABle

TRACe<n>[:DATA]? PWCDp

TRACe<n>[:DATA]? CWCDp

└ Table Configuration


Table Configuration

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Channel Table > Table Configuration
Table Configuration

You can configure which parameters are displayed in the Channel Table by double-clicking the table header. A "Table Configuration" dialog box is displayed in which you can select the columns to be displayed.

By default, only active channels are displayed. In order to display all channels, including the inactive ones, enable the "Show Inactive Channels" option.

The following parameters of the detected channels are determined by the CDP measurement and can be displayed in the Channel Table evaluation. (For details see "Code Domain Parameters".)

Code domain power results in the channel table
Label | Description
Chan Type | Type of channel (active channels only)
Ch. SF | Number of channel spreading code (0 to [spreading factor-1])
Symbol Rate [ksps] | Symbol rate at which the channel is transmitted In BTS measurements: always
State | Active: channel is active and all pilot symbols are correct Inactive: channel is not active Pilotf: channel is active, but pilot symbols incomplete or missing
TFCI | (BTS measurements only): Data channel uses TFCI symbols
Mapping | (UE measurements only): Branch the channel is mapped to (I or Q)
PilotL [Bits] | Number of pilot bits in the channel (UE measurements: only for control channel DPCCH)
Pwr Abs [dBm]/Pwr Rel [dBm] | Absolute and relative channel power (referred to the CPICH or the total power of the signal)
T Offs [Chips] | (BTS measurements only): Timing offset


Code Domain Power

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Code Domain Power
Code Domain Power

The "Code Domain Power" evaluation shows the power of all possible code channels in the selected channel slot. The x-axis shows the possible code channels from 0 to the highest spreading factor. Due to the circumstance that the power is regulated from slot to slot, the result power may differ between different slots. Detected channels are displayed yellow. The selected code channel is highlighted red. The codes where no channel could be detected are displayed green.

Note: Effects of missing or incomplete pilot symbols. In "Autosearch" channel detection mode, the application expects specific pilot symbols for DPCH channels. If these symbols are missing or incomplete, the channel power in the Code Domain Power evaluation is displayed green at the points of the diagram the channel should appear due to its spreading code, and a message ("INCORRECT PILOT") is displayed in the status bar. In this case, check the pilot symbols for those channels using the "Power vs Slot" or the "Bitstream" evaluations.
Optionally, all QPSK-modulated channels can also be recognized without pilot symbols (see "HSDPA/UPA").

Remote command:

LAY:ADD? '1',RIGH, CDPower, see LAYout:​ADD[:​WINDow]?

CALC:MARK:FUNC:WCDP:RES? CDP, see CALCulate<n>:​MARKer<m>:​FUNCtion:​WCDPower[:​BTS]:​RESult?

CALC:MARK:FUNC:WCDP:MS:RES? CDP, see CALCulate<n>:​MARKer<m>:​FUNCtion:​WCDPower:​MS:​RESult?

TRACe<n>[:DATA]? CTABle

TRACe<n>[:DATA]? PWCDp

TRACe<n>[:DATA]? CWCDp


Code Domain Error Power

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Code Domain Error Power
Code Domain Error Power

"Code Domain Error Power" is the difference in power between the measured and the ideal signal. The unit is dB. There are no other units for the y-axis.

Remote command:

LAY:ADD? '1',RIGH, CDEPower, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Composite Constellation

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Composite Constellation
Composite Constellation

The "Composite Constellation" evaluation analyzes the entire signal for one single slot. If a large number of channels is to be analyzed, the results are superimposed. In that case the benefit of this evaluation is limited (senseless).

In "Composite Constellation" evaluation the constellation points of the 1536 chips are displayed for the specified slot. This data is determined inside the DSP even before the channel search. Thus, it is not possible to assign constellation points to channels. The constellation points are displayed normalized with respect to the total power.

Remote command:

LAY:ADD? '1',RIGH, CCONst, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Composite EVM

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Composite EVM
Composite EVM

The "Composite EVM" evaluation displays the root mean square composite EVM (modulation accuracy) according to the 3GPP specification. The square root is determined of the mean squared errors between the real and imaginary components of the received signal and an ideal reference signal (EVM referenced to the total signal). The error is averaged over all channels for individual slots. The "Composite EVM" evaluation covers the entire signal during the entire observation time.

where:

EVMRMS | root mean square of the vector error of the composite signal
sn | complex chip value of received signal
xn | complex chip value of reference signal
n | index number for mean power calculation of received and reference signal.
N | number of chips at each CPICH slot

The measurement result consists of one composite EVM measurement value per slot. In this case, the measurement interval is the slot spacing of the CPICH (timing offset of 0 chips referenced to the beginning of the frame). Only the channels recognized as active are used to generate the ideal reference signal. If an assigned channel is not recognized as active since pilot symbols are missing or incomplete, the difference between the measurement and reference signal and the composite EVM is very high.

Remote command:

LAY:ADD? '1',RIGH, CEVM, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


EVM vs Chip

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > EVM vs Chip
EVM vs Chip

EVM vs Chip activates the Error Vector Magnitude (EVM) versus chip display. The EVM is displayed for all chips of the selected slot.

Note: In UE measurements, if the measurement interval "Halfslot" is selected for evaluation, 30 slots are displayed instead of the usual 15 (see "Measurement Interval").

The EVM is calculated by the root of the square difference of received signal and reference signal. The reference signal is estimated from the channel configuration of all active channels. The EVM is related to the square root of the mean power of reference signal and given in percent.

where:

EVMk | vector error of the chip EVM of chip number k
sk | complex chip value of received signal
xk | complex chip value of reference signal
k | index number of the evaluated chip
N | number of chips at each CPICH slot
n | index number for mean power calculation of reference signal
Remote command:

LAY:ADD? '1',RIGH, EVMChip, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Frequency Error vs Slot

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Frequency Error vs Slot
Frequency Error vs Slot

For each value to be displayed, the difference between the frequency error of the corresponding slot to the frequency error of the first (zero) slot is calculated (based on CPICH slots). This helps eliminate a static frequency offset of the whole signal to achieve a better display of the actual time-dependant frequency diagram.

Remote command:

LAY:ADD? '1',RIGH, FESLot, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? ATRACE


Mag Error vs Chip

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Mag Error vs Chip
Mag Error vs Chip

Mag Error vs Chip activates the Magnitude Error versus chip display. The magnitude error is displayed for all chips of the selected slot.

Note: In UE measurements, if the measurement interval "Halfslot" is selected for evaluation, 30 slots are displayed instead of the usual 15 (see "Measurement Interval").

The magnitude error is calculated as the difference of the magnitude of the received signal to the magnitude of the reference signal. The reference signal is estimated from the channel configuration of all active channels. The magnitude error is related to the square root of the mean power of reference signal and given in percent.

where:

MAGk | magnitude error of chip number k
sk | complex chip value of received signal
xk | complex chip value of reference signal
k | index number of the evaluated chip
N | number of chips at each CPICH slot
n | index number for mean power calculation of reference signal
Remote command:

LAY:ADD? '1',RIGH, MECHip, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Marker Table

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Peak Code Domain Error

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Peak Code Domain Error
Peak Code Domain Error

In line with the 3GPP specifications, the error between the measurement signal and the ideal reference signal for a given slot and for all codes is projected onto the various spreading factors. The result consists of the peak code domain error value per slot. The measurement interval is the slot spacing of the CPICH (timing offset of 0 chips referenced to the beginning of the frame). Only the channels recognized as active are used to generate the ideal reference signal for the peak code domain error. If an assigned channel is not recognized as active since pilot symbols are missing or incomplete, the difference between the measurement and reference signal is very high. This display is a bar diagram over slots. The unit is dB. The Peak Code Domain Error evaluation covers the entire signal and the entire observation time.

Remote command:

LAY:ADD? '1',RIGH, PCDerror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Phase Discontinuity vs Slot

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Phase Discontinuity vs Slot
Phase Discontinuity vs Slot

The "Phase Discontinuity vs Slot" is calculated according to 3GPP specifications. The phase calculated for each slot is interpolated to both ends of the slot using the frequency shift of that slot. The difference between the phase interpolated for the beginning of one slot and the end of the preceding slot is displayed as the phase discontinuity of that slot.

Remote command:

LAY:ADD? '1',RIGH, PDSLot, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Phase Error vs Chip

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Phase Error vs Chip
Phase Error vs Chip

"Phase Error vs Chip" activates the phase error versus chip display. The phase error is displayed for all chips of the slected slot.

Note: In UE measurements, if the measurement interval "Halfslot" is selected for evaluation, 30 slots are displayed instead of the usual 15 (see "Measurement Interval").

The phase error is calculated by the difference of the phase of received signal and phase of reference signal. The reference signal is estimated from the channel configuration of all active channels. The phase error is given in degrees in a range of +180° to -180°.

Calculating the magnitude, phase and vector error per chip

where:

PHIk | phase error of chip number k
sk | complex chip value of received signal
xk | complex chip value of reference signal
k | index number of the evaluated chip
N | number of chips at each CPICH slot
φ(x) | phase calculation of a complex value
Remote command:

LAY:ADD? '1',RIGH, PECHip, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Power vs Slot

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Power vs Slot
Power vs Slot

The "Power vs Slot" evaluation displays the power of the selected channel for each slot. The power is displayed either absolute or relative to the total power of the signal or to the CPICH channel.

Note: In UE measurements, this evaluation is only available if the analysis mode "Frame" is selected (see "Capture Mode").
If the measurement interval "Halfslot" is selected for evaluation, 30 slots are displayed instead of the usual 15 (see "Measurement Interval").

If a timing offset of the selected channel in relation to the CPICH channel occurrs, the power is calculated and displayed per channel slot (as opposed to the Code Domain Power evaluation). However, for reference purposes, the grid in the Power vs Slot diagram indicates the CPICH slots. The first CPICH slot is always slot 0, the grid and labels of the grid lines do not change. Thus, the channel slots may be shifted in the diagram grid. The channel slot numbers are indicated within the power bars. The selected slot is highlighted in the diagram.

Remote command:

LAY:ADD? '1',RIGH, PSLot, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TPVSlot


Power vs Symbol

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Power vs Symbol
Power vs Symbol

The "Power vs. Symbol" evaluation shows the power over the symbol number for the selected channel and the selected slot. The power is not averaged here. The trace is drawn using a histogram line algorithm, i.e. only vertical and horizontal lines, no diagonal, linear Interpolation (polygon interpolation). Surfaces are NOT filled.

Remote command:

LAY:ADD? '1',RIGH, PSYMbol, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Result Summary

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Result Summary
Result Summary

The Result Summary evaluation displays a list of measurement results on the screen. For details see "Code Domain Parameters".

Remote command:

LAY:ADD? '1',RIGH, RSUMmary, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>

CALCulate<n>:​MARKer<m>:​FUNCtion:​WCDPower[:​BTS]:​RESult?


Symbol Constellation

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Constellation
Symbol Constellation

The "Symbol Constellation" evaluation shows all modulated signals of the selected channel and the selected slot. QPSK constellation points are located on the diagonals (not x and y-axis) of the constellation diagram. BPSK constellation points are always on the x-axis.

Remote command:

LAY:ADD? '1',RIGH, SCONst, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Symbol EVM

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol EVM
Symbol EVM

The "Symbol EVM" evaluation shows the error between the measured signal and the ideal reference signal in percent for the selected channel and the selected slot. A trace over all symbols of a slot is drawn. The number of symbols is in the range from 12 (min) to 384 (max). It depends on the symbol rate of the channel.

Remote command:

LAY:ADD? '1',RIGH, SEVM, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Symbol Magnitude Error

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Magnitude Error
Symbol Magnitude Error

The "Symbol Magnitude Error" is calculated analogous to symbol EVM. The result is one symbol magnitude error value for each symbol of the slot of a special channel. Positive values of symbol magnitude error indicate a symbol magnitude that is larger than the expected ideal value; negative symbol magnitude errors indicate a symbol magnitude that is less than the ideal one.The symbol magnitude error is the difference between the magnitude of the received symbol and that of the reference symbol, related to the magnitude of the reference symbol.

Remote command:

LAY:ADD? '1',RIGH, SMERror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


Symbol Phase Error

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > Evaluation Methods for Code Domain Analysis > Symbol Phase Error
Symbol Phase Error

The "Symbol Phase Error" is calculated analogous to symbol EVM. The result is one symbol phase error value for each symbol of the slot of a special channel. Positive values of symbol phase error indicate a symbol phase that is larger than the expected ideal value; negative symbol phase errors indicate a symbol phase that is less than the ideal one.

Remote command:

LAY:ADD? '1',RIGH, SPERror, see LAYout:​ADD[:​WINDow]?

TRACe<n>[:DATA]? TRACE<1...4>


CDA Measurements in MSRA Operating Mode

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Code Domain Analysis > CDA Measurements in MSRA Operating Mode
CDA Measurements in MSRA Operating Mode

The 3GPP FDD BTS application can also be used to analyze data in MSRA operating mode.

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications receive an extract of the captured data for analysis, referred to as the application data. The application data range is indicated in the MSRA Master by vertical blue lines.

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the 3GPP FDD BTS application the analysis interval is automatically determined according to the selected channel, slot or frame to analyze which is defined for the evaluation range, depending on the result display. The currently used analysis interval (in seconds, related to capture buffer start) is indicated in the window header for each result display.

For details on the MSRA operating mode see "Applications and Operating Modes" .


Time Alignment Error Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Time Alignment Error Measurements
Time Alignment Error Measurements

Time Alignment Error Measurements are a special type of Code Domain Analysis used to determine the time offset between the signals of both antennas of a base station.

They are only available in 3GPP FDD BTS measurements.

The result is displayed numerically on the screen, a graphical result is not available.

Measurement setup

The antenna signals of the two BTS transmitter branches are fed to the analyzer via a combiner. Each antenna must provide a common pilot channel, i.e. P-CPICH for antenna 1 and P-CPICH or S-CPICH for antenna 2. The figure "Time Alignment Error Measurement setup" shows the measurement setup.

Time Alignment Error Measurement setup
Synchronization check

There is a synchronization check for both antennas which must have the result "Sync OK" to ensure a proper TAE result. With the messages "No antenna 1 sync", "No antenna 2 sync" and "No sync", synchronization problems are indicated separately for each antenna, which can also be read remotely via bits 1 and 2 of the Sync status register (see "Querying the Status Registers").

Evaluation Methods

For Time Alignment Error measurements, the following evaluation methods are available:

└ Result List


Result List

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > Time Alignment Error Measurements > Result List
Result List

Indicates the time delay (in chips) of the signal at antenna 2 relative to the signal at antenna 1.

Remote command:

CONF:WCDP:MEAS TAE, see CONFigure:​WCDPower[:​BTS]:​MEASurement

CALCulate<n>:​MARKer<m>:​FUNCtion:​TAERror:​RESult?


RF Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements
RF Measurements

In addition to the Code Domain Analysis measurements, the 3GPP FDD applications also provide some RF measurements as defined in the 3GPP FDD standard. RF measurements are identical to the corresponding measurements in the base unit, but configured according to the requirements of the 3GPP FDD standard.

For details on these measurements see "Measurements" .

MSRA operating mode

RF measurements are not available in MSRA operating mode.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Contents
  • RF Measurement Types and Results
  • Evaluation Methods for RF Measurements


RF Measurement Types and Results

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > RF Measurement Types and Results
RF Measurement Types and Results

The 3GPP FDD applications provide the following RF measurements:

└ Ch Power ACLR
└ Occupied Bandwidth
└ Power
└ RF Combi
└ Spectrum Emission Mask
└ CCDF


Ch Power ACLR

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > RF Measurement Types and Results > Ch Power ACLR
Ch Power ACLR

Channel Power ACLR performs an adjacent channel power measurement in the default setting according to 3GPP specifications (adjacent channel leakage ratio).

The R&S FSW measures the channel power and the relative power of the adjacent channels and of the alternate channels. The results are displayed below the diagram.

For details see "Channel Power (ACLR) Measurements".

Remote command:

CONF:WCDP:MEAS ACLR, see CONFigure:​WCDPower[:​BTS]:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


Occupied Bandwidth

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > RF Measurement Types and Results > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth measurement determines the bandwidth that the signal occupies.

The occupied bandwidth is defined as the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

The occupied bandwidth (Occ BW) and the frequency markers are displayed in the marker table.

For details see "Occupied Bandwidth".

Remote command:

CONF:WCDP:MEAS OBAN, see CONFigure:​WCDPower[:​BTS]:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? OBW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


Power

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > RF Measurement Types and Results > Power
Power

The Output Power measurement determines the 3GPP FDD signal channel power. The R&S FSW measures the unweighted RF signal power in a bandwidth of:

The power is measured in zero span mode (time domain) using a digital channel filter of 5 MHz in bandwidth. According to the 3GPP standard, the measurement bandwidth (5 MHz) is slightly larger than the minimum required bandwidth of 4.7 MHz. The bandwidth is displayed numerically below the screen.

For details see "Output Power Measurements".

Remote command:

CONF:WCDP:MEAS POW, see CONFigure:​WCDPower[:​BTS]:​MEASurement

Querying results: CALC:MARK:FUNC:POW:RES? CPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?


RF Combi

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > RF Measurement Types and Results > RF Combi
RF Combi

This measurement combines the following measurements:

  • "Ch Power ACLR"
  • "Occupied Bandwidth"
  • "Spectrum Emission Mask"

The ACLR and OBW are measured on trace 1, from which the SEM trace 2 is derived via integration.

The advantage of the RF COMBI measurement is that all RF results are measured with a single measurement process. This measurement is faster than the three individual measurements.

For details see "RF Combi".

Remote command:

CONF:WCDP:BTS:MEAS RFC, see CONFigure:​WCDPower[:​BTS]:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? ACP CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? OBW

CALC:MARK:FUNC:POW:RES? CPOW

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? OBW

CALC:MARK:FUNC:POW:RES? CPOW

CALCulate:​LIMit<k>:​FAIL?


Spectrum Emission Mask

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > RF Measurement Types and Results > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask measurement determines the power of the 3GPP FDD signal in defined offsets from the carrier and compares the power values with a spectral mask specified by 3GPP.

For details see "Spectrum Emission Mask".

Remote command:

CONF:WCDP:MEAS ESP, see CONFigure:​WCDPower[:​BTS]:​MEASurement

Querying results:

CALC:MARK:FUNC:POW:RES? CPOW, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALCulate:​LIMit<k>:​FAIL?


CCDF

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > RF Measurement Types and Results > CCDF
CCDF

The CCDF measurement determines the distribution of the signal amplitudes (complementary cumulative distribution function). The CCDF and the Crest factor are displayed. For the purposes of this measurement, a signal section of user-definable length is recorded continuously in the zero span, and the distribution of the signal amplitudes is evaluated.

For details see "CCDF".

Remote command:

CONF:WCDP:MEAS CCDF, see CONFigure:​WCDPower[:​BTS]:​MEASurement

Querying results:

CALCulate<n>:​MARKer<m>:​Y?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALC:MARK:FUNC:POW:RES? ACP, see CALCulate:​MARKer:​FUNCtion:​POWer<sb>:​RESult?

CALCulate:​STATistics:​RESult<t>?


Evaluation Methods for RF Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > Evaluation Methods for RF Measurements
Evaluation Methods for RF Measurements

The evaluation methods for RF measurements are identical to those in the Spectrum application.

└ Diagram
└ Result Summary
└ Marker Table
└ Marker Peak List


Diagram

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > Evaluation Methods for RF Measurements > Diagram
Diagram

Displays a basic level vs. frequency or level vs. time diagram of the measured data to evaluate the results graphically. This is the default evaluation method. Which data is displayed in the diagram depends on the "Trace" settings. Scaling for the y-axis can be configured.

Remote command:

LAY:ADD? '1',RIGH, DIAG, see LAYout:​ADD[:​WINDow]?


Result Summary

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > Evaluation Methods for RF Measurements > Result Summary
Result Summary

Result summaries provide the results of specific measurement functions in a table for numerical evaluation. The contents of the result summary vary depending on the selected measurement function. See the description of the individual measurement functions for details.

Remote command:

LAY:ADD? '1',RIGH, RSUM, see LAYout:​ADD[:​WINDow]?


Marker Table

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > Evaluation Methods for RF Measurements > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Marker Peak List

3G FDD Measurements (R&S FSW-K72/K73) > Measurements and Result Display > RF Measurements > Evaluation Methods for RF Measurements > Marker Peak List
Marker Peak List

The marker peak list determines the frequencies and levels of peaks in the spectrum or time domain. How many peaks are displayed can be defined, as well as the sort order. In addition, the detected peaks can be indicated in the diagram. The peak list can also be exported to a file for analysis in an external application.

Remote command:

LAY:ADD? '1',RIGH, PEAK, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Measurement Basics

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics
Measurement Basics

Some background knowledge on basic terms and principles used in 3GPP FDD tests and measurements is provided here for a better understanding of the required configuration settings.

Basic principle

The basic principle of 3GPP FDD (frequency division duplex) is that the communication between a base station and several mobile stations is performed in the same frequency band and in the same time slots. The seperation of the data for the different mobile stations is achieved by using CDMA (Code Division Multiple Access). In this technique, channels are distinguished by using different orthogonal codes.

Scrambling codes

Each base station uses a unique scrambling code. The mobile station can only demodulate the base station signal if it knows which scrambling code was used by the base station.

Thus, in order to demodulate the data in the 3GPP FDD applications, you must either specify the scrambling code explicitely, or the application can perform an automatic search to detect the scrambling code itself.

Channels, codes and symbol rate

In signals according to the 3GPP FDD standard, the data is transmitted in channels. These channels are based on orthogonal codes and can have different data rates. The data rate depends on the used modulation type and the spreading factor of the channel.

Spreading factors

Spreading factors determine whether the transmitted data is sent in short or long sequences. The spreading factor is re-assigned dynamically in certain time intervals according to the current demand of users and data to be transmitted. The higher the spreading factor, the lower the data rate; the lower the spreading factor, the higher the data rate.

The smallest available spreading factor is 4, the largest is 512. So we can say that the code domain consists of 512 basic codes. A channel with a lower spreading factor consists of several combined codes. That means a channel can be described by its number and its spreading factor.

The following table shows the relationship between the code class, the spreading factor, the number of codes per channel, and the symbol rate.

Relationship between code class, spreading factor, codes per channel and symbol rate for 3GPP FDD signals
Code class | Spreading factor | No. codes / channel | Symbol rate
2 | 4 | 128 | 960 ksps
3 | 8 | 64 | 480 ksps
4 | 16 | 32 | 240 ksps
5 | 32 | 16 | 120 ksps
6 | 64 | 8 | 60 ksps
7 | 128 | 4 | 30 ksps
8 | 256 | 2 | 15 ksps
9 | 512 | 1 | 7.5 ksps

In the measurement settings and results, the spreading factor is often represented by the corresponding symbol rate (in kilo symbols per second, ksps). The power of a channel is always measured in relation to its symbol rate (or spreading factor).

In the 3GPP FDD applications, the channel number consists of the used spreading factor and the channel's sequential number in the code domain, assuming the code domain is divided into equal divisions:

<sequence number>.<spreading factor>

Example:

For a channel number of 5.32, for example, imagine a code domain of 512 codes with a scale of 16 codes per division. Each division represents a possible channel with spreading factor 32. Since channel numbering starts at 0, channel number 5 is the sixth division on the scale.

Selected codes and channels

In the result displays that refer to channels, the currently selected channel is highlighted in the diagram. You select a channel by entering a channel number and spreading factor in the "Evaluation Range" settings. In the example above, if you select the channel number 5.32, the sixth division on the scale with 16 codes per division is highlighted.

For the display in the 3GPP FDD applications, the scale for code-based diagrams contains 512 divisions, one for each code. The selected channel in the example (5.32) would thus correspond to codes 80-96. (The division starts at 5*16=80 and is 16 codes wide.)

If no spreading factor is given for the channel number, the default factor 512 is assumed. Channel number 5 would thus refer to the sixth division on the scale, which is the sixth code in the code domain. If the code belongs to a detected channel, the entire channel is highlighted.

If the selected channel is not active, only the first code belonging to the corresponding division is highlighted. In the example, for the inactive channel number 5.32, the first code in the sixth division on the scale with 16 codes per division is highlighted. That corresponds to code number 80 with the scale based on 512 divisions.

Special channels - PCCPCH, SCH, CPICH, DPCH

In order to control the data transmission between the sender and the receiver, specific symbol must be included in the transmitted data, for example the scrambling code of the sender or the used spreading factor, as well as synchronization data for different channels. This data is included in special data channels defined by the 3GPP standard which use fixed codes in the code domain. Thus, they can be detected easily by the receiver.

The Primary Common Control Physical Channel (PCCPCH) must always be contained in the signal. As the name implies, it is responsible for common control of the channels during transmission.

The Synchronization Channel (SCH) is a time reference and responsible for synchronizing the individual channels.

Another important channel is the Common Pilot Channel (CPICH), which continuously transmits the sender's scrambling code. This channel is used to identify the sender, but also as a reference in 3GPP FDD signal measurements.

The user data is contained in the Dedicated Physical Channel (DPCH).

More details on channel types are provided in "BTS Channel Types".

Chips, frames and slots

The user data is spread across the available bandwidth using the spreading factor before transmission. The spreaded bits are referred to as "chips".

A time span of 10 ms is also known as a "frame". A frame is a basic time unit in the transmission process. Each frame is divided into 15 time "slots". Various channel parameters are put in relation to frames or the individual slots in the 3GPP standard, as well as some measurement results for 3GPP FDD signals. A slot contains 2560 chips.

Channel slots versus CPICH slots

The time slots of the individual channels may not be absolutely synchronous. A time offset may occur, so that the slots in a data channel are slightly shifted in relation to the CPICH slots, for example. In the 3GPP FDD BTS application, the CPICH slot number is provided as a reference with the measurement settings in the channel bar. In the Result Summary, the actual slot number of the evaluated channel is indicated as the "Channel Slot No".

Pilot symbols

Some slots contain a fixed sequence of symbols, referred to as "pilot symbols". These pilot symbols allow the receiver to identify a particular channel, if the unique pilot symbols can be detected in the input signal.

Power control

While the spreading factors are adjusted for each frame, i.e. every 10 ms, the power levels for transmission must be adapted to the current requirements (such as interference) much more dynamically. Thus, power control bits are transmitted in each slot, allowing for much higher change rates. As the CPICH channel continuously transmits the same data, the power level need not be adapted. Thus, the power control bits can lead to a timing offset between the CPICH slots and other channel slots.

Contents
  • Channel Detection
  • BTS Channel Types
  • UE Channel Types
  • 3GPP FDD BTS Test Models
  • Setup for Base Station Tests
  • 3GPP FDD UE Test Models
  • Setup for User Equipment Tests
  • CDA Measurements in MSRA Operating Mode


Channel Detection

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > Channel Detection
Channel Detection

The 3GPP FDD applications provide two basic methods of detecting active channels:

  • Automatic search using pilot sequences
    The application performs an automatic search for active (DPCH) channels throughout the entire code domain. The search is based on the presence of known symbol sequences (pilot symbols) in the despread symbols of a channel. A data channel is considered to be active if the pilot symbols as specified by the 3GPP FDD standard are found at the end of each slot. In this mode, channels without or with incomplete pilot symbols are therefore not recognized as being active.
    An exception to this rule is seen in the special channels PICH and SCCPCH, which can be recognized as active in the automatic search mode although they do not contain pilot symbols. Optionally, all QPSK-modulated channels can also be recognized without pilot symbols (see "HSDPA/UPA").
    In addition, the channel must exceed a minimum power in order to be considered active (see "Inactive Channel Threshold (BTS measurements only)").
    In UE measurements, a channel is considered to be active if a minimum signal/noise ratio is maintained within the channel.
  • Comparison with predefined channel tables
    The input signal is compared to a predefined channel table. All channels that are included in the predefined channel table are considered to be active.


BTS Channel Types

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > BTS Channel Types
BTS Channel Types

The 3GPP FDD standard defines various BTS channel types. Some channels are mandatory and must be contained in the signal, as they have control or synchronization functions. Thus, these channels always occupy a specific channel number and use a specific symbol rate by which they can be identified.

Control and synchronization channels

The 3GPP FDD BTS application expects the following control and synchronization channels for the Code Domain Power measurements:

Common 3GPP FDD BTS control channels and their usage

Channel type

Description

PSCH

Primary Synchronization Channel

The Primary Synchronization Channel is used to synchronize the signal in the case of SCH synchronization. It is a non-orthogonal channel. Only the power of this channel is determined.

SSCH

Secondary Synchronization Channel

The Secondary Synchronization Channel is a non-orthogonal channel. Only the power of this channel is determined.

PCCPCH

Primary Common Control Physical Channel

The Primary Common Control Physical Channel is also used to synchronize the signal in the case of SCH synchronization. It is expected at code class 8 and code number 1.

SCCPCH

Secondary Common Control Physical Channel

The Secondary Common Control Physical Channel is a QPSK-modulated channel without any pilot symbols. In the 3GPP test models, this channel can be found in code class 8 and code number 3. However, the code class and code number need not be fixed and can vary. For this reason, the following rules are used to indicate the SCCPCH.

  • Only one QPSK-modulated channel without pilot symbols is detected and displayed as the SCCPCH. Any further QPSK-modulated channels without pilot symbols are not detected as active channels.
  • If the signal contains more than one channel without pilot symbols, the channel that is received in the highest code class and with the lowest code number is displayed as the SCCPCH. It is expected that only one channel of this type is included in the received signal. According to this assumption, this channel is probably the SCCPCH.
  • If the application is configured to recognize all QPSK-modulated channels without pilot symbols (see "HSDPA/UPA"), and one of these channels is received at code class 8 and code number 3, it is displayed as the SCCPCH.

CPICH

Common Pilot Channel

The Common Pilot Channel is used to synchronize the signal in the case of CPICH synchronization. It is expected at code class 8 and code number 0.

If it is not contained in the signal configuration, the firmware application must be configured to sychronize to the SCH channel (see "Synchronization Type").

Other channels are optional and contain the user data to be transmitted. A data channel is any channel that does not have a predefined channel number and symbol rate. The following channel types can be detected by the 3GPP FDD BTS application.

Common 3GPP FDD BTS data channels and their usage

Channel type

Description

PICH

Paging Indication Channel

The Paging Indication Channel is expected at code class 8 and code number 16.

The lower part of the table indicates the data channels contained in the signal. A data channel is any channel that does not have a predefined channel number and symbol rate. There are different types of data channels, which are indicated in the column "Chan Type".

DPCH

Dedicated Physical Channel of a standard frame

The Dedicated Physical Channel is a data channel that contains pilot symbols. The displayed channel type is DPCH.

CPRSD

Dedicated Physical Channel (DPCH) in compressed mode

Compressed mode channels usually do not transmit valid symbols in all slots. There are different lengths of the transmitting gap. One to fourteen slots can be switched off in each frame. In some cases outside the gap the symbol rate is increased by 2 to ensure a constant average symbol rate of this channel. In any case all of the transmitted slots contain a pilot sequence defined in the 3GPP specification. There are different types of compressed mode channels.

To evaluate compressed mode channels, the associated measurement mode needs to be activated (see "Compressed Mode").

CPR-TPC

DPCH in compressed mode where TPC symbols are sent in the first slot of the transmitting gap

CPR-SF/2

DPCH in compressed mode using half spreading factor (SF/2) to increase the symbol rate of the active slots by two

CPR-SF/2-TPC

DPCH in compressed mode using half spreading factor (SF/2) to increase the symbol rate of the active slots by two, where TPC symbols are sent in the first slot of the transmitting gap

HS-PDSCH

HSDPA: High Speed Physical Downlink Shared Channel

The High Speed Physical Downlink Shared Channel (HSDPA) does not contain any pilot symbols. It is a channel type that is expected in code classes lower than 7. The modulation type of these channels can vary depending on the selected slot.

HSPDSCH-QPSK_: QPSK-modulated slot of an HS PDSCH channel

HSPDSCH-16QAM_: 16QAM-modulated slot of an HS PDSCH channel

HSPDSCH-NONE_: slot without power of an HS PDSCH channel

HS-SCCH

HSDPA: High Speed Shared Control Channel

The High Speed Shared Control Channel (HSDPA) does not contain any pilot symbols. It is a channel type that is expected in code classes equal to or higher than 7. The modulation type should always be QPSK. The channel does not contain any pilot symbols.

If the application is configured to recognize all QPSK-modulated channels without pilot symbols (see "HSDPA/UPA"), the channels of HSDPA will be found among the data channels. If the type of a channel can be fully recognized, as for example with a DPCH (based on pilot sequences) or HS-PDSCH (based on modulation type), the type is entered in the field TYPE. All other channels without pilot symbols are of type CHAN. The channels are in descending order according to symbol rates and, within a symbol rate, in ascending order according to the channel numbers. There-fore, the unassigned codes are always to be found at the end of the table.

If the modulation type for a channel can vary, the measured value of the modulation type will be appended to the type of the channel.

EHICH-ERGCH

HSUPA:

Enhanced HARQ Hybrid Acknowledgement Indicator Channel

Enhanced Relative Grant Channel

EAGCH

Enhanced Absolute Grant Channel

SCPICH

Secondary Common Pilot Channel

CHAN

If the application is configured to recognize all QPSK-modulated channels without pilot symbols (see "HSDPA/UPA"), all QPSK-modulated channels without pilot symbols and a code class higher than or equal to 7 are marked with the channel type CHAN.

MIMO channel types

Optionally, single antenna MIMO measurement channels can also be detected. In this case, HS-PDSCH channels with exclusively QPSK or exclusively 16 QAM on both transport streams are automatically detected and demodulated. The corresponding channel types are denoted as "HS-MIMO-QPSK" and "HS-MIMO-16QAM".

The MIMO constellations resulting on a single antenna consist of three amplitudes per dimension (-1, 0, 1) in the case of QPSK x QPSK, and seven amplitudes per dimension (-3, -2, -1, 0, 1, 2, 3) in the case of 16 QAM x 16 QAM. The symbol decisions of these constellations can be retrieved via the bitstream output. The mapping between bits and constellation points is given by the following table.

Mapping between bits and constellation points for MIMO-QPSK
Constellation point (normalized) | Bit sequence
0,0 | 0,1,0,1
1,0 | 0,1,0,0
-1,0 | 0,1,1,1
0,1 | 0,0,0,1
1,1 | 0,0,0,0
-1,1 | 0,0,1,1
0,-1 | 1,1,0,1
1,-1 | 1,1,0,0
-1,-1 | 1,1,1,1

For MIMO-16QAM, the bit sequence is the same in both I and Q. Only one dimension is given here.

Mapping between bits and constellation points for MIMO-16QAM
Constellation point (normalized) | Bit sequence
-3 | 1,1,1
-2 | 1,1,0
-1 | 1,0,0
0 | 1,0,1
1 | 0,0,1
2 | 0,0,0
3 | 0,1,0


UE Channel Types

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > UE Channel Types
UE Channel Types

The following channel types can be detected in 3GPP FDD uplink signals by the 3GPP FDD UE application.

Control channels

The 3GPP FDD UE application expects the following control channels for the Code Domain Power measurements:

Common 3GPP FDD UE control channels and their usage
Channel type | Description
DPCCH | The Dedicated Physical Control Channel is used to synchronize the signal. It carries pilot symbols and is expected in the Q branch at code class 8 with code number 0. This channel must be contained in every channel table.
HSDPCCH | The High Speed Dedicated Physical Control Channel (for HS-DCH) is used to carry control information (CQI/ACK/NACK) for downlink high speed data channels (HS-DCH). It is used in HSDPA signal setup. The symbol rate is fixed to 15ksps. The code allocation depends on the number of active DPCH. The HS-DPCCH can be switched on or off after the duration of 1/5 frame or 3 slots or 2ms. Power control is applicable too.
EDPCCH | The Enhanced Dedicated Physical Control Channel is used to carry control information for uplink high speed data channels (EDPDCH). It is used in HSUPA signal setup. The symbol rate is fixed to 15ksps.

Other channels are optional and contain the user data to be transmitted. A data channel is any channel that does not have a predefined channel number and symbol rate.

The following channel types can be detected by the 3GPP FDD UE application:

Common 3GPP FDD UE data channels and their usage
Channel type | Description
DPDCH | The Dedicated Physical Data Channel is used to carry UPLINK data from the UE to the BS. The code allocation depends on the total required symbol rate.
EDPDCH | The Enhanced Dedicated Physical Data Channel is used to carry UPLINK data for high speed channels (EDPDCH). It is used in HSUPA signal setup. The symbol rate and code allocation depends on the number of DPDCH and HS-DPCCH.

As specified in 3GPP, the channel table can contain up to 6 DPDCHs or up to 4 E-DPDCHs.


3GPP FDD BTS Test Models

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > 3GPP FDD BTS Test Models
3GPP FDD BTS Test Models

For measurements on base-station signals in line with 3GPP, test models with different channel configurations are specified in the document "Base station conformance testing (FDD)" (3GPP TS 25.141 V5.7.0). An overview of the test models is provided here.

Test model 1
Channel type | Number of channels | Power (%) | Level (dB) | Spreading code | Timing offset (×256Tchip)
PCCPCH+SCH | 1 | 10 | -10 | 1 | 0
Primary CPICH | 1 | 10 | -10 | 0 | 0
PICH | 1 | 1.6 | -18 | 16 | 120
SCCPCH (SF=256) | 1 | 1.6 | -18 | 3 | 0
DPCH (SF=128) | 16/32/64 | 76.8 total | see TS 25.141 | see TS 25.141 | see TS 25.141
Test model 2
Channel type | Number of channels | Power (%) | Level (dB) | Spreading code | Timing offset (x256Tchip)
PCCPCH+SCH | 1 | 10 | -10 | 1 | 0
Primary CPICH | 1 | 10 | -10 | 0 | 0
PICH | 1 | 5 | -13 | 16 | 120
SCCPCH (SF=256) | 1 | 5 | -13 | 3 | 0
DPCH (SF=128) | 3 | 2 × 10, 1 × 50 | 2 × -10, 1 × -3 | 24, 72, 120 | 1, 7, 2
Test model 3
Channel type | Number of channels | Power (%) 16/32 | Level (dB) 16/32 | Spreading code | Timing offset (×256Tchip)
PCCPCH+SCH | 1 | 12.6/7.9 | -9/-11 | 1 | 0
Primary CPICH | 1 | 12.6/7.9 | -9/-11 | 0 | 0
PICH | 1 | 5/1.6 | -13/-18 | 16 | 120
SCCPCH (SF=256) | 1 | 5/1.6 | -13/-18 | 3 | 0
DPCH (SF=256) | 16/32 | 63,7/80,4 total | see TS 25.141 | see TS 25.141 | see TS 25.141
Test model 4
Channel type | Number of channels | Power (%) 16/32 | Level (dB) 16/32 | Spreading code | Timing offset (×256Tchip)
PCCPCH+SCH | 1 | 50 to 1.6 | -3 to -18 | 1 | 0
Primary CPICH* | 1 | 10 | -10 | 0 | 0
Test model 5
Channel type | Number of channels | Power (%) | Level (dB) | Spreading code | Timing offset (×256Tchip)
PCCPCH+SCH | 1 | 7.9 | -11 | 1 | 0
Primary CPICH | 1 | 7.9 | -11 | 0 | 0
PICH | 1 | 1.3 | -19 | 16 | 120
SCCPCH (SF=256) | 1 | 1.3 | -19 | 3 | 0
DPCH (SF=256) | 30/14/6 | 14/14.2/14.4 total | see TS 25.141 | see TS 25.141 | see TS 25.141
HS_SCCH | 2 | 4 total | see TS 25.141 | see TS 25.141 | see TS 25.141
HS_PDSCH (16QAM) | 8/4/2 | 63.6/63.4/63.2 total | see TS 25.141 | see TS 25.141 | see TS 25.141


Setup for Base Station Tests

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > Setup for Base Station Tests
Setup for Base Station Tests

This section describes how to set up the analyzer for 3GPP FDD BTS tests. As a prerequisite for starting the test, the instrument must be correctly set up and connected to the AC power supply as described in the R&S FSW Getting Started manual. Furthermore, the 3GPP FDD BTS application must be available.

Standard Test Setup
  • Connect the antenna output (or Tx output) of the BTS to the RF input of the analyzer via a power attenuator of suitable attenuation.
    The following values are recommended for the external attenuator to ensure that the RF input of the analyzer is protected and the sensitivity of the analyzer is not reduced too much.
Max. power | Recommended ext. attenuation
≥55 to 60 dBm | 35 to 40 dB
≥50 to 55 dBm | 30 to 35 dB
≥45 to 50 dBm | 25 to 30 dB
≥40 to 45 dBm | 20 to 25 dB
≥35 to 40 dBm | 15 to 20 dB
≥30 to 35 dBm | 10 to 15 dB
≥25 to 30 dBm | 5 to 10 dB
≥20 to 25 dBm | 0 to 5 dB
<20 dBm | 0 dB
  • For signal measurements at the output of two-port networks, connect the reference frequency of the signal source to the rear reference input of the analyzer (EXT REF IN/OUT).
  • To ensure that the error limits specified by the 3GPP standard are met, the analyzer should use an external reference frequency for frequency measurements on base stations. For instance, a rubidium frequency standard may be used as a reference source.
  • If the base station is provided with a trigger output, connect this output to the trigger input of the analyzer.
Presetting

Configure the R&S FSW as follows:

  • Set the external attenuation (Reference level offset).
  • Set the reference level.
  • Set the center frequency.
  • Set the trigger.
  • Select the BTS standard and measurement.


3GPP FDD UE Test Models

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > 3GPP FDD UE Test Models
3GPP FDD UE Test Models

The possible channel configurations for the mobile station signal are limited by 3GPP. Only two different configurations for data channels DPDCH are permissible according to the specification. In addition to these two channel configurations, the HS-DPCCH channel can be transmitted to operate the mobile station in HSDPA mode. Thus, the 3GPP FDD UE application checks for these channel configurations only during the automatic channel search. Therefore, channels whose parameters do not correspond to one of these configurations are not automatically detected as active channels.

The two possible channel configurations are summarized below:

Channel configuration 1: DPCCH and 1 DPDCH
Channel type | Number of channels | Symbol rate | Spreading code(s) | Mapping
DPCCH | 1 | 15 ksps | 0 | Q
DPDCH | 1 | 15 ksps – 960 ksps | [spreading-factor/4] | I
Channel configuration 2: DPCCH and up to 6 DPDCH
Channel type | Number of channels | Symbol rate | Spreading code(s) | Mapping
DPCCH | 1 | 15 ksps | 0 | Q
DPDCH | 1 | 960 ksps | 1 | I
DPDCH | 1 | 960 ksps | 1 | Q
DPDCH | 1 | 960 ksps | 3 | I
DPDCH | 1 | 960 ksps | 3 | Q
DPDCH | 1 | 960 ksps | 2 | I
DPDCH | 1 | 960 ksps | 2 | Q
Channel configuration 3: DPCCH, up to 6 DPDCH and 1 HS-DPCCH The channel configuration is as above in table 4-2. On HS-DPCCH is added to each channel table.
Number of DPDCH | Symbol rate all DPDCH | Symbol rate HS-DPCCH | Spreading code HS-DPCCH | Mapping (HS-DPCCH)
1 | 15 – 960 ksps | 15 ksps | 64 | Q
2 | 1920 ksps | 15 ksps | 1 | I
3 | 2880 ksps | 15 ksps | 32 | Q
4 | 3840 ksps | 15 ksps | 1 | I
5 | 4800 ksps | 15 ksps | 32 | Q
6 | 5760 ksps | 15 ksps | 1 | I
Channelization code of HS-DPCCH
Nmax-dpdch (as defined in subclause 4.2.1) | Channelization code Cch
1 | Cch,256,64
2,4,6 | Cch,256,1
3,5 | Cch,256,32


Setup for User Equipment Tests

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > Setup for User Equipment Tests
Setup for User Equipment Tests

This section describes how to set up the analyzer for 3GPP FDD UE user equipment tests. As a prerequisite for starting the test, the instrument must be correctly set up and connected to the AC power supply as described in the R&S FSW Getting Started manual. Furthermore, the 3GPP FDD UE application must be properly installed following the instructions provided in the operating manual for the analyzer.

Standard Test Setup
  • Connect antenna output (or Tx output) of UE to RF input of the analyzer via a power attenuator of suitable attenuation.
    The following values are recommended for the external attenuator to ensure that the RF input of the analyzer is protected and the sensitivity of the analyzer is not reduced too much.
Max. power | Recommended ext. attenuation
≥55 to 60 dBm | 35 to 40 dB
≥50 to 55 dBm | 30 to 35 dB
≥45 to 50 dBm | 25 to 30 dB
≥40 to 45 dBm | 20 to 25 dB
≥35 to 40 dBm | 15 to 20 dB
≥30 to 35 dBm | 10 to 15 dB
≥25 to 30 dBm | 5 to 10 dB
≥20 to 25 dBm | 0 to 5 dB
<20 dBm | 0 dB
  • For signal measurements at the output of two-port networks, connect the reference frequency of the signal source to the external reference input connector of the R&S FSW (REF INPUT).
  • To ensure that the error limits specified by the 3GPP standard are met, the R&S FSW should use an external reference frequency for frequency measurements on user equipment. For instance, a rubidium frequency standard may be used as a reference source.
  • If the user equipment is provided with a trigger output, connect this output to one of the TRIGGER INPUT connectors of the R&S FSW.
Presetting

Configure the R&S FSW as follows:

  • Set the external attenuation (Reference level offset).
  • Set the reference level.
  • Set the center frequency.
  • Set the trigger.
  • Select the UE standard and measurement.


CDA Measurements in MSRA Operating Mode

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Basics > CDA Measurements in MSRA Operating Mode
CDA Measurements in MSRA Operating Mode

The 3GPP FDD BTS application can also be used to analyze data in MSRA operating mode.

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications receive an extract of the captured data for analysis, referred to as the application data. For the 3GPP FDD BTS application in MSRA operating mode, the application data range is defined by the same settings used to define the signal capture in Signal and Spectrum Analyzer mode. In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the 3GPP FDD BTS measurement.

Data coverage for each active application

Generally, if a signal contains multiple data channels for multiple standards, separate applications are used to analyze each data channel. Thus, it is of interest to know which application is analyzing which data channel. The MSRA Master display indicates the data covered by each application, restricted to the channel bandwidth used by the corresponding standard (for 3GPP FDD: 5 MHz), by vertical blue lines labeled with the application name.

Analysis interval

However, the individual result displays of the application need not analyze the complete data range. The data range that is actually analyzed by the individual result display is referred to as the analysis interval.

In the 3GPP FDD BTS application the analysis interval is automatically determined according to the selected channel, slot or frame to analyze which is defined for the evaluation range, depending on the result display. The analysis interval can not be edited directly in the 3GPP FDD BTS application, but is changed automatically when you change the evaluation range.

Analysis line

A frequent question when analyzing multi-standard signals is how each data channel is correlated (in time) to others. Thus, an analysis line has been introduced. The analysis line is a common time marker for all MSRA applications. It can be positioned in any MSRA application or the MSRA Master and is then adjusted in all other applications. Thus, you can easily analyze the results at a specific time in the measurement in all applications and determine correlations.

If the marked point in time is contained in the analysis interval of the application, the line is indicated in all time-based result displays, such as time, symbol, slot or bit diagrams. By default, the analysis line is displayed, however, it can be hidden from view manually. In all result displays, the "AL" label in the window title bar indicates whether or not the analysis line lies within the analysis interval or not:

  • orange "AL": the line lies within the interval
  • white "AL": the line lies within the interval, but is not displayed (hidden)
  • no "AL": the line lies outside the interval

For details on the MSRA operating mode see "Applications and Operating Modes" .


Configuration

3G FDD Measurements (R&S FSW-K72/K73) > Configuration
Configuration

The 3GPP FDD applications provide several different measurements for signals according to the 3GPP FDD application. The main and default measurement is Code Domain Analysis. Furthermore, a Time Alignment Error measurement is provided. In addition to the code domain power measurements specified by the 3GPP standard, the 3GPP FDD options offer measurements with predefined settings in the frequency domain, e.g. RF power measurements.

Only one measurement type can be configured per channel; however, several channels with 3GPP FDD applications can be configured in parallel on the R&S FSW. Thus, you can configure one channel for a Code Domain Analysis, for example, and another for a Time Alignment Error or Power measurement for the same input signal. Then you can use the Sequencer to perform all measurements consecutively and either switch through the results easily or monitor all results at the same time in the "MultiView" tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .

Selecting the measurement type

When you activate an 3GPP FDD application, Code Domain Analysis of the input signal is started automatically. However, the 3GPP FDD applications also provide other measurement types.

►

To select a different measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.
Contents
  • Result Display
  • Code Domain Analysis and Time Alignment Error Measurements
  • RF Measurements


Result Display

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Result Display
Result Display

The captured signal can be displayed using various evaluation methods. All evaluation methods available for 3GPP FDD applications are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in any 3GPP FDD menu.

Up to 16 evaluation methods can be displayed simultaneously in separate windows. The 3GPP FDD evaluation methods are described in "Evaluation Methods for Code Domain Analysis".

To close the SmartGrid mode and restore the previous softkey menu select the [image] "Close" icon in the righthand corner of the toolbar, or press any key on the front panel.

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Code Domain Analysis and Time Alignment Error Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements
Code Domain Analysis and Time Alignment Error Measurements

3GPP FDD measurements require special applications on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a 3GPP FDD application the first time, a set of parameters is passed on from the currently active application:
  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate a 3GPP FDD application, Code Domain Analysis of the input signal is started automatically with the default configuration. The "Code Domain Analyzer" menu is displayed and provides access to the most important configuration functions.

For a description see
  • "Signal Description"
  • "BTS Scrambling Code"
  • "Signal Capture (Data Acquisition)"
  • "Synchronization (BTS Measurements Only)"
  • "Channel Detection"
  • "Code Domain Analysis Settings (BTS Measurements)"
  • "Evaluation Range"
  • "Result Display"

The "Span", "Bandwidth", "Lines", and "Marker Functions" menus are not available in 3GPP FDD applications.

Code Domain Analysis can be configured easily in the "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu.

Time Alignment Error measurement

Time Alignment Error measurements are only available in the 3GPP FDD BTS application.

To perform a Time Alignment Error measurement, you must change the measurement type. Do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the Time Alignment Error measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the Time Alignment Error measurement.
Importing and Exporting I/Q Data

The I/Q data to be evaluated for 3GPP FDD can not only be measured by the 3GPP FDD applications themselves, it can also be imported to the applications, provided it has the correct format. Furthermore, the evaluated I/Q data from the 3GPP FDD applications can be exported for further analysis in external applications.

The import and export functions are available in the "Save/Recall" menu which is displayed when you select the [image] "Save" or [image] "Open" icon in the toolbar.

For details on importing and exporting I/Q data see "I/Q Data Import and Export".

Contents
  • Default Settings for Code Domain Analysis
  • Configuration Overview
  • Signal Description
  • Data Input and Output Settings
  • Frontend Settings
  • Trigger Settings
  • Signal Capture (Data Acquisition)
  • Application Data (MSRA)
  • Synchronization (BTS Measurements Only)
  • Channel Detection
  • Sweep Settings
  • Automatic Settings
  • BW, Span, Lines and Marker Function Menus
  • Zoom Functions


Default Settings for Code Domain Analysis

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Default Settings for Code Domain Analysis
Default Settings for Code Domain Analysis

When you activate a 3GPP FDD application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and frequency offset
  • reference level and reference level offset
  • attenuation
  • signal source and digital I/Q input settings
  • input coupling
  • YIG filter state

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a 3GPP FDD application is activated, or after a "Preset Channel":

The following default settings of the Code Domain Analysis are activated:

Default settings for 3GPP FDD channels
Parameter | Value
Digital standard | W-CDMA 3GPP FWD (BTS measurements) W-CDMA 3GPP REV (UE measurements)
Sweep | CONTINUOUS
Channel detection mode | AUTOSEARCH
Trigger settings | FREE RUN
Trigger offset | 0
Scrambling code | 0
Threshold value | -60 dB
Symbol rate | 15 ksps
Code number | 0
Slot number | 0
Evaluations | Window 1: Code Domain Power Relative Window 2: Result Summary


Configuration Overview

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. Thus, you can easily configure an entire measurement channel from input over processing to evaluation by stepping through the dialog boxes as indicated in the "Overview".

The available settings and functions in the "Overview" vary depending on the currently selected measurement. For RF measurements see "RF Measurements".

For Code Domain Analysis and Time Alignment Error measurements, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. "Select Measurement"

    See "Measurements and Result Display"

  2. "Signal Description"

    See "Signal Description"

  3. "Input/ Frontend"

    See "Data Input and Output Settings"

  4. (Optionally:) "Trigger/Gate"

    See "Trigger Settings"

  5. "Signal Capture"

    See "Signal Capture (Data Acquisition)"

  6. (BTS measurements only):"Synchronization"

    See "Synchronization (BTS Measurements Only)"

  7. "Channel Detection"

    See "Channel Detection"

  8. "Analysis"

    See "Analysis"

  9. "Display Configuration"

    See "Evaluation Methods for Code Domain Analysis" and "Evaluation Methods"

To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

└ Preset Channel
└ Select Measurement
└ Specifics for


Preset Channel

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

See "Default Settings for Code Domain Analysis" for details.

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Select Measurement

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Configuration Overview > Select Measurement
Select Measurement

Selects a different measurement to be performed.

See "Measurements and Result Display".


Specifics for

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Signal Description

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description
Signal Description

The signal description provides information on the expected input signal.

Contents
  • BTS Signal Description
  • BTS Scrambling Code
  • UE Signal Description (UE Measurements)


BTS Signal Description

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description
BTS Signal Description

The settings available to describe the input signal in BTS measurements are described here.

└ HSDPA/UPA
└ Compressed Mode
└ MIMO
└ Antenna Diversity
└ Antenna Number


HSDPA/UPA

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > HSDPA/UPA
HSDPA/UPA

If enabled, the application detects all QPSK-modulated channels without pilot symbols (HSDPA channels) and displays them in the channel table. If the type of a channel can be fully recognized, as for example with a HS-PDSCH (based on modulation type), the type is indicated in the table. All other channels without pilot symbols are of type "CHAN".

Remote command:

[SENSe:​]CDPower:​HSDPamode


Compressed Mode

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > Compressed Mode
Compressed Mode

If compressed mode is switched on, some slots of a channel are suppressed. To keep the overall data rate, the slots just before or just behind a compressed gap can be sent with half spreading factor (SF/2). This mode must be enabled to detect compressed mode channels (see "BTS Channel Types").

Remote command:

[SENSe:​]CDPower:​PCONtrol


MIMO

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > MIMO
MIMO

Activates or deactivates single antenna MIMO measurement mode.

If activated, HS-PDSCH channels with exclusively QPSK or exclusively 16 QAM on both transport streams are automatically detected and demodulated. The corresponding channel types are denoted as "HS-MIMO-QPSK" and "HS-MIMO-16QAM", respectively.

For details see "MIMO channel types".

Remote command:

[SENSe:​]CDPower:​MIMO


Antenna Diversity

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > Antenna Diversity
Antenna Diversity

This option switches the antenna diversity mode on and off.

Remote command:

[SENSe:​]CDPower:​ANTenna


Antenna Number

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > Antenna Number
Antenna Number

This option switches between diversity antennas 1 and 2. Depending on the selected setting, the 3GPP FDD application synchronizes to the CPICH of antenna 1 or antenna 2.

Remote command:

[SENSe:​]CDPower:​ANTenna


BTS Scrambling Code

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code
BTS Scrambling Code

The scrambling code identifies the base station transmitting the signal. You can either define the used scrambling code manually, or perform a search on the input signal to detect a list of possible scrambling codes automatically.

└ Scrambling Code
└ Format Hex/Dec
└ Scrambling Codes
└ Autosearch for Scrambling Code
└ Export


Scrambling Code

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code > Scrambling Code
Scrambling Code

Defines the scrambling code. The scrambling codes are used to distinguish between different base stations. Each base station has its own scrambling code.

Remote command:

[SENSe:​]CDPower:​LCODe:​DVALue


Format Hex/Dec

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code > Format Hex/Dec
Format Hex/Dec

Switch the display format of the scrambling codes between hexadecimal and decimal.

Remote command:

[SENSe:​]CDPower:​LCODe:​DVALue

[SENSe:​]CDPower:​LCODe[:​VALue]


Scrambling Codes

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code > Scrambling Codes
Scrambling Codes

This table includes all found scrambling codes from the last autosearch sequence. In the first column each detected scrambling code can be selected for export.

Remote command:

[SENSe:​]CDPower:​LCODe:​SEARch:​LIST?


Autosearch for Scrambling Code

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code > Autosearch for Scrambling Code
Autosearch for Scrambling Code

Starts a search on the measured signal for all scrambling codes. The scrambling code that leads to the highest signal power is chosen as the new scrambling code.

Searching requires that the correct center frequency and level are set. The scrambling code search can automatically determine the primary scrambling code number. The secondary scrambling code number is expected as 0. Alternative scrambling codes can not be detected. Therefore the range for detection is 0x0000 – 0x1FF0h, where the last digit is always 0.

Remote command:

[SENSe:​]CDPower:​LCODe:​SEARch[:​IMMediate]?


Export

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code > Export
Export

Writes the detected scrambling codes together with their powers into a text file in the R&S user directory (C:\R_S\Instr\User\ScrCodes.txt)


UE Signal Description (UE Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description (UE Measurements)
UE Signal Description (UE Measurements)

The settings available to describe the input signal in UE measurements are described here.

└ Scrambling Code
└ Format
└ Type
└ HSDPA/UPA
└ QPSK Modulation Only


Scrambling Code

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description (UE Measurements) > Scrambling Code
Scrambling Code

Defines the scrambling code used to transmit the signal in the specified format.

The scrambling code identifies the user equipment transmitting the signal. If an incorrect scrambling code is defined, a CDP measurement of the signal is not possible.

Remote command:

[SENSe:​]CDPower:​LCODe[:​VALue]


Format

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description (UE Measurements) > Format
Format

Switches the display format of the scrambling codes between hexadecimal and decimal.

Remote command:

SENS:CDP:LCOD:DVAL <numeric value> (see [SENSe:​]CDPower:​LCODe:​DVALue)


Type

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description (UE Measurements) > Type
Type

Defines whether the entered scrambling code is to be handled as a long or short scrambling code.

Remote command:

[SENSe:​]CDPower:​LCODe:​TYPE


HSDPA/UPA

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description (UE Measurements) > HSDPA/UPA
HSDPA/UPA

If enabled, the application detects all QPSK-modulated channels without pilot symbols (HSDPA channels) and displays them in the channel table. If the type of a channel can be fully recognized, as for example with a HS-PDSCH (based on modulation type), the type is indicated in the table. All other channels without pilot symbols are of type "CHAN".

Remote command:

[SENSe:​]CDPower:​HSDPamode


QPSK Modulation Only

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description (UE Measurements) > QPSK Modulation Only
QPSK Modulation Only

If enabled, it is assumed that the signal uses QPSK modulation only. Thus, a special QPSK-based synchronization can be performed and the measurement therefore runs with optimized speed.

Do not enable this mode for signals that do not use QPSK modulation.

Remote command:

[SENSe:​]CDPower:​QPSK


Data Input and Output Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings
Data Input and Output Settings

The R&S FSW can analyze signals from different input sources and provide various types of output (such as noise or trigger signals).

Frontend settings are described in "Frontend Settings".

Contents
  • Input Source Settings
  • Output Settings
  • Digital I/Q Output Settings


Input Source Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

Since the Digital I/Q input and the Analog Baseband input use the same digital signal path, both cannot be used simultaneously. When one is activated, established connections for the other are disconnected. When the second input is deactivated, connections to the first are re-established. This may cause a short delay in data transfer after switching the input source.

Contents
  • Radio Frequency Input
  • Digital I/Q Input Settings
  • Analog Baseband Input Settings
  • Probe Settings


Radio Frequency Input

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Radio Frequency State
└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector
└ Input Connector


Radio Frequency State

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Radio Frequency State
Radio Frequency State

Activates input from the RF INPUT connector.

Remote command:

INPut:​SELect


Input Coupling

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

This value also affects the unit conversion (see "Reference Level").

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17) or from the Analog Baseband Interface (R&S FSW-B71). For analog baseband input, an impedance of 50 Ω is always used.

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Input Connector

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Radio Frequency Input > Input Connector
Input Connector

Determines whether the RF input data is taken from the RF INPUT connector (default) or the optional BASEBAND INPUT I connector. This setting is only available if the Analog Baseband Interface (R&S FSW-B71) is installed and active for input. It is not available for the R&S FSW67.

For more information see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​CONNector


Digital I/Q Input Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings
Digital I/Q Input Settings

The following settings and functions are available to provide input via the Digital Baseband Interface (R&S FSW-B17) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see " Processing Data from the Digital Baseband Interface (-B17)" .

└ Digital I/Q Input State
└ Input Sample Rate
└ Full Scale Level
└ Adjust Reference Level to Full Scale Level
└ Connected Instrument
└ DigIConf


Digital I/Q Input State

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Digital I/Q Input State
Digital I/Q Input State

Enables or disable the use of the "Digital IQ" input source for measurements. "Digital IQ" is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

Remote command:

INPut:​SELect


Input Sample Rate

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Input Sample Rate
Input Sample Rate

Defines the sample rate of the digital I/Q signal source. This sample rate must correspond with the sample rate provided by the connected device, e.g. a generator.

If "Auto" is selected, the sample rate is adjusted automatically by the connected device.

The allowed range is from 100 Hz to 10 GHz.

Remote command:

INPut:​DIQ:​SRATe

INPut:​DIQ:​SRATe:​AUTO


Full Scale Level

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Full Scale Level
Full Scale Level

The "Full Scale Level" defines the level and unit that should correspond to an I/Q sample with the magnitude "1".

If "Auto" is selected, the level is automatically set to the value provided by the connected device.

Remote command:

INPut:​DIQ:​RANGe[:​UPPer]

INPut:​DIQ:​RANGe[:​UPPer]:​UNIT

INPut:​DIQ:​RANGe[:​UPPer]:​AUTO


Adjust Reference Level to Full Scale Level

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Adjust Reference Level to Full Scale Level
Adjust Reference Level to Full Scale Level

If enabled, the reference level is adjusted to the full scale level automatically if any change occurs.

Remote command:

INPut:​DIQ:​RANGe:​COUPling


Connected Instrument

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > Connected Instrument
Connected Instrument

Displays the status of the Digital Baseband Interface connection.

This function is only available if the Digital Baseband Interface (R&S FSW-B17) is installed.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
  • Sample rate of the data currently being transferred via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level"), if provided by connected instrument
Remote command:

INPut:​DIQ:​CDEVice


DigIConf

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Digital I/Q Input Settings > DigIConf
DigIConf

Starts the optional R&S DigIConf application. This softkey is available in the In-/Output menu, but only if the optional software is installed.

Note that R&S DigIConf requires a USB connection (not LAN!) from the R&S FSW to the R&S EX-IQ-BOX in addition to the Digital Baseband Interface (R&S FSW-B17) connection. R&S DigIConf version 2.20.360.86 Build 170 or higher is required.

To return to the R&S FSW application, press any key on the front panel. The R&S FSW application is displayed with the "Input/Output" menu, regardless of which key was pressed.

For details on the R&S DigIConf application, see the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Note: If you close the R&S DigIConf window using the "Close" icon, the window is minimized, not closed.
If you select the "File > Exit" menu item in the R&S DigIConf window, the application is closed. Note that in this case the settings are lost and the EX-IQ-BOX functionality is no longer available until you restart the application using the "DigIConf" softkey in the R&S FSW once again.


Analog Baseband Input Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings
Analog Baseband Input Settings

The following settings and functions are available to provide input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the INPUT/OUTPUT key, in the "Input" dialog box.

For more information see "Processing Data From the Analog Baseband Interface" .

If Analog Baseband input is used, measurements in the frequency and time domain are not available.

└ Analog Baseband Input State
└ I/Q Mode
└ Input configuration
└ Center Frequency


Analog Baseband Input State

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Analog Baseband Input State
Analog Baseband Input State

Enables or disable the use of the "Analog Baseband" input source for measurements. "Analog Baseband" is only available if the Analog Baseband Interface (R&S FSW-B71) is installed.

Remote command:

INPut:​SELect


I/Q Mode

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > I/Q Mode
I/Q Mode

Defines the format of the input signal.

For more information see "I/Q Processing Modes" .

"I + jQ"

The input signal is filtered and resampled to the sample rate of the application.

Two inputs are required for a complex signal, one for the in-phase component, and one for the quadrature component.

"I Only / Low IF I"

The input signal at the BASEBAND INPUT I connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband I).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF I).

"Q Only / Low IF Q"

The input signal at the BASEBAND INPUT Q connector is filtered and resampled to the sample rate of the application.

If the center frequency is set to 0 Hz, the real baseband signal is displayed without down-conversion (Real Baseband Q).

If a center frequency greater than 0 Hz is set, the input signal is down-converted with the center frequency (Low IF Q).

Remote command:

INPut:​IQ:​TYPE


Input configuration

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Input configuration
Input configuration

Defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Note: Both single-ended and differential probes are supported as input; however, since only one connector is occupied by a probe, the "Single-ended" setting must be used for all probes.
For details on probes see "Using Probes" .

"Differential" | I, Q and inverse I,Q data
"Single Ended" | I, Q data only
Remote command:

INPut:​IQ:​BALanced[:​STATe]


Center Frequency

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Analog Baseband Input Settings > Center Frequency
Center Frequency

Defines the center frequency for analog baseband input.

For real-type baseband input (I or Q only), the center frequency is always 0 Hz.

Note: If the analysis bandwidth to either side of the defined center frequency exceeds the minimum frequency (0 Hz) or the maximum frequency (40 MHz/80 MHz), an error is displayed. In this case, adjust the center frequency or the analysis bandwidth.

Remote command:

[SENSe:​]FREQuency:​CENTer


Probe Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Probe Settings
Probe Settings

Probes are configured in a separate tab on the "Input" dialog box which is displayed when you select the INPUT/OUTPUT key and then "Input Source Config".

For each possible probe connector (Baseband Input I, Baseband Input Q), the detected type of probe, if any, is displayed. The following information is provided for each connected probe:

  • Probe name
  • Serial number
  • R&S part number
  • Type of probe ("Differential", "Single Ended")

For more information on using probes with an R&S FSW, see "Using Probes" .

For general information on the R&S®RTO probes, see the device manuals.

└ Microbutton Action


Microbutton Action

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Input Source Settings > Probe Settings > Microbutton Action
Microbutton Action

Active R&S probes (except for RT-ZS10E) have a configurable microbutton on the probe head. By pressing this button, you can perform an action on the instrument directly from the probe.

Select the action that you want to start from the probe:

"Run single" | Starts one data acquisition.
"No action" | Prevents unwanted actions due to unintended usage of the microbutton.
Remote command:

[SENSe:​]PROBe<p>:​SETup:​MODE


Output Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Trigger 2/3

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Output Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Output Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Digital I/Q Output Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Digital I/Q Output Settings
Digital I/Q Output Settings

The optional Digital Baseband Interface (R&S FSW-B17) allows you to output I/Q data from any R&S FSW application that processes I/Q data to an external device. The configuration settings for digital I/Q output can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

Digital output is not available if the bandwidth extension option R&S FSW-B500 is active.

For details on digital I/Q output see "Digital Output" .

└ Digital Baseband Output
└ Output Settings Information
└ Connected Instrument


Digital Baseband Output

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Digital I/Q Output Settings > Digital Baseband Output
Digital Baseband Output

Enables or disables a digital output stream to the optional Digital Baseband Interface (R&S FSW-B17), if available.

Note: If digital baseband output is active, the sample rate is restricted to 200 MHz (max. 160 MHz bandwidth).
The only data source that can be used for digital baseband output is RF input.

For details on digital I/Q output see "Digital Output" .

Remote command:

OUTPut:​DIQ


Output Settings Information

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Digital I/Q Output Settings > Output Settings Information
Output Settings Information

Displays information on the settings for output via the Digital Baseband Interface (R&S FSW-B17).

The following information is displayed:

  • Maximum sample rate that can be used to transfer data via the Digital Baseband Interface (i.e. the maximum input sample rate that can be processed by the connected instrument)
  • Sample rate currently used to transfer data via the Digital Baseband Interface
  • Level and unit that corresponds to an I/Q sample with the magnitude "1" ("Full Scale Level")
Remote command:

OUTPut:​DIQ:​CDEVice


Connected Instrument

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Data Input and Output Settings > Digital I/Q Output Settings > Connected Instrument
Connected Instrument

Displays information on the instrument connected to the Digital Baseband Interface (R&S FSW-B17), if available.

If an instrument is connected, the following information is displayed:

  • Name and serial number of the instrument connected to the Digital Baseband Interface
  • Used port
Remote command:

OUTPut:​DIQ:​CDEVice


Frontend Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings
Frontend Settings

Frequency, amplitude and y-axis scaling settings represent the "frontend" of the measurement setup.

Contents
  • Amplitude Settings
  • Amplitude Settings for Analog Baseband Input
  • Y-Axis Scaling
  • Frequency Settings


Amplitude Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

The scaling settings are described in "Y-Axis Scaling".

Amplitude settings for input from the Analog Baseband interface (R&S FSW-B71) are described in "Amplitude Settings for Analog Baseband Input".

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Reference Level

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display ("OVLD" for analog baseband or digitial baseband input).

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)


Shifting the Display (Offset)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


Unit

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > Reference Level > Unit
Unit

For CDA measurements the unit should not be changed, as this would lead to useless results.


Setting the Reference Level Automatically (Auto Level)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > Reference Level > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

This function is only available for the MSRA/MSRT Master, not for the applications.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


RF Attenuation

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

└ Attenuation Mode / Value


Attenuation Mode / Value

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance


Preamplifier (option B24)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Amplitude Settings for Analog Baseband Input

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings for Analog Baseband Input
Amplitude Settings for Analog Baseband Input

The following settings and functions are available to define amplitude settings for input via the Analog Baseband Interface (R&S FSW-B71) in the applications that support it.

They can be configured via the AMPT key or in the "Amplitude" tab of the "Input" dialog box.

The input settings provided here are identical to those in the "Input Source" > "Analog Baseband" tab, see "Analog Baseband Input Settings".

For more information see "Processing Data From the Analog Baseband Interface" .

└ Reference Level
└ Shifting the Display (Offset)
└ Unit
└ Setting the Reference Level Automatically (Auto Level)
└ Full Scale Level Mode / Value


Full Scale Level Mode / Value

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Amplitude Settings for Analog Baseband Input > Full Scale Level Mode / Value
Full Scale Level Mode / Value

The full scale level defines the maximum power you can input at the Baseband Input connector without clipping the signal.

The full scale level can be defined automatically according to the reference level, or manually.

For manual input, the following values can be selected:

  • 0.25 V
  • 0.5 V
  • 1 V
  • 2 V

If probes are connected, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

For details on probes see "Processing Data From the Analog Baseband Interface" .

Remote command:

INPut:​IQ:​FULLscale:​AUTO

INPut:​IQ:​FULLscale[:​LEVel]


Y-Axis Scaling

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Y-Axis Scaling
Y-Axis Scaling

The vertical axis scaling is configurable. In Code Domain Analysis, the y-axis usually displays the measured power levels.

└ Y-Maximum, Y-Minimum
└ Auto Scale Once
└ Restore Scale (Window)


Y-Maximum, Y-Minimum

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Y-Axis Scaling > Y-Maximum, Y-Minimum
Y-Maximum, Y-Minimum

Defines the amplitude range to be displayed on the y-axis of the evaluation diagrams.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum


Auto Scale Once

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Y-Axis Scaling > Auto Scale Once
Auto Scale Once

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings.

The display is only set once; it is not adapted further if the measurement settings are changed again.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE


Restore Scale (Window)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Y-Axis Scaling > Restore Scale (Window)
Restore Scale (Window)

Restores the default scale settings in the currently selected window.


Frequency Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select the "Frequency" tab in the "Input Settings" dialog box
└ Center frequency
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

span > 0: spanmin/2 ≤ fcenter ≤ fmax – spanmin/2

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Center Frequency Stepsize

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

This setting is available for frequency and time domain measurements.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"X * Span" | Sets the step size for the center frequency to a defined factor of the span. The "X-Factor" defines the percentage of the span. Values between 1 and 100 % in steps of 1 % are allowed. The default setting is 10 %.
"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Frontend Settings > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Trigger Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

For step-by-step instructions on configuring triggered measurements, see the main R&S FSW User Manual.

└ Trigger Source
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Digital I/Q
└ IF Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Capture Offset
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Source

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source
Trigger Source

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ Digital I/Q
└ IF Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Capture Offset


Trigger Source

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ Digital I/Q
└ IF Power


Free Run

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


Digital I/Q

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Source > Digital I/Q
Digital I/Q

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available:

Defines triggering of the measurement directly via the LVDS connector. In the selection list you must specify which general purpose bit (GP0 to GP5) will provide the trigger data.

Note: If the Digital I/Q enhanced mode is used, i.e. the connected device supports transfer rates up to 200 Msps, only the general purpose bits GP0 and GP1 are available as a Digital I/Q trigger source.

The following table describes the assignment of the general purpose bits to the LVDS connector pins.

(For details on the LVDS connector see "Description of the LVDS Connector" )

Assignment of general purpose bits to LVDS connector pins
Bit | LVDS pin
GP0 | SDATA4_P - Trigger1
GP1 | SDATA4_P - Trigger2
GP2 *) | SDATA0_P - Reserve1
GP3 *) | SDATA4_P - Reserve2
GP4 *) | SDATA0_P - Marker1
GP5 *) | SDATA4_P - Marker2
*): not available for Digital I/Q enhanced mode
Remote command:

TRIG:SOUR GP0, see TRIGger[:​SEQuence]:​SOURce


IF Power

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Source > IF Power
IF Power

The R&S FSW starts capturing data as soon as the trigger level is exceeded around the third intermediate frequency.

This trigger source is only available for RF input.

This trigger source is available for frequency and time domain measurements only.

It is not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

For frequency sweeps, the third IF represents the start frequency. The trigger bandwidth at the third IF depends on the RBW and sweep type.

For measurements on a fixed frequency (e.g. zero span or I/Q measurements), the third IF represents the center frequency.

The available trigger levels depend on the RF attenuation and preamplification. A reference level offset, if defined, is also considered.

For details on available trigger levels and trigger bandwidths see the data sheet.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce


Trigger Level

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]

For analog baseband (B71) or digital baseband (B17) input only:


Drop-Out Time

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Note: For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

Note: In MSRA/MSRT mode, the trigger offset defines the start of the sweep only for the MSRA/MSRT Master. For MSRA/MSRT applications, use the "Capture Offset" instead.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Slope

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Capture Offset

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Trigger Settings > Trigger Source > Capture Offset
Capture Offset

This setting is only available for applications in MSRA operating mode. It has a similar effect as the trigger offset in other measurements: it defines the time offset between the capture buffer start and the start of the extracted application data.

In MSRA mode, the offset must be a positive value, as the capture buffer starts at the trigger time = 0.

For details on the MSRA operating mode see "Applications and Operating Modes" .

Remote command:

[SENSe:​]MSRA:​CAPTure:​OFFSet


Signal Capture (Data Acquisition)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition)
Signal Capture (Data Acquisition)

How much and how data is captured from the input signal are defined in the "Signal Capture" settings.

MSRA operating mode

In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The data acquisition settings for the 3GPP FDD BTS application in MSRA mode define the application data extract. See "Application Data (MSRA) ".

For details on the MSRA operating mode see "Applications and Operating Modes" .

└ Sample Rate
└ Invert Q
└ RRC Filter State
└ Capture Mode
└ Capture Length (Frames)
└ Capture Offset
└ Frame To Analyze
└ Capture Time


Sample Rate

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition) > Sample Rate
Sample Rate

The sample rate is always 16 MHz (indicated for reference only).


Invert Q

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition) > Invert Q
Invert Q

Inverts the sign of the signal's Q-branch. The default setting is OFF.

Remote command:

[SENSe:​]CDPower:​QINVert


RRC Filter State

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition) > RRC Filter State
RRC Filter State

Selects if a root raised cosine (RRC) receiver filter is used or not. This feature is useful if the RRC filter is implemented in the device under test (DUT).

"ON" | If an unfiltered signal is received (normal case), the RRC filter should be used to get a correct signal demodulation. (Default settings)
"OFF" | If a filtered signal is received, the RRC filter should not be used to get a correct signal demodulation. This is the case if the DUT filters the signal.
Remote command:

[SENSe:​]CDPower:​FILTer[:​STATe]


Capture Mode

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition) > Capture Mode
Capture Mode

Captures a single slot or one complete frame.

Remote command:

[SENSe:​]CDPower:​BASE


Capture Length (Frames)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition) > Capture Length (Frames)
Capture Length (Frames)

Defines the capture length (amount of frames to record).

Note: if this setting is not available, "Capture Mode" is set to "Slot", i.e. only one slot is captured.

Remote command:

[SENSe:​]CDPower:​IQLength


Frame To Analyze

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition) > Frame To Analyze
Frame To Analyze

Defines the frame to be analyzed and displayed.

Note: if this setting is not available in UE tests, "Capture Mode" is set to "Slot", i.e. only one slot is captured.

Remote command:

[SENSe:​]CDPower:​FRAMe[:​VALue]


Capture Time

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Signal Capture (Data Acquisition) > Capture Time
Capture Time

This setting is read-only.

It indicates the capture time determined by the capture length and sample rate.


Application Data (MSRA)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Application Data (MSRA)
Application Data (MSRA)

For the 3GPP FDD BTS application in MSRA operating mode, the application data range is defined by the same settings used to define the signal capturing in Signal and Spectrum Analyzer mode (see "Signal Capture (Data Acquisition)".

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the analysis interval for the 3GPP FDD BTS measurement (see "Capture Offset").

The analysis interval cannot be edited manually, but is determined automatically according to the selected channel, slot or frame to analyze which is defined for the evaluation range, depending on the result display. Note that the frame/slot/channel is analyzed within the application data.


Synchronization (BTS Measurements Only)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Synchronization (BTS Measurements Only)
Synchronization (BTS Measurements Only)

For BTS tests, the individual channels in the input signal need to be synchronized to detect timing offsets in the slot spacings. These settings are described here.

└ Synchronization Type
└ Antenna1 / Antenna2
└ CPICH Mode
└ S-CPICH Code Nr
└ S-CPICH Antenna Pattern


Synchronization Type

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Synchronization (BTS Measurements Only) > Synchronization Type
Synchronization Type

Defines whether the signal is synchronized to the CPICH or the synchronization channel (SCH).

"CPICH" | The 3GPP FDD application assumes that the CPICH control channel is present in the signal and attempts to synchronize to this channel. If the signal does not contain CPICH, synchronization fails.
"SCH" | The 3GPP FDD application synchronizes to the signal without assuming the presence of a CPICH. This setting is required for measurements on test model 4 without CPICH. While this setting can also be used with other channel configurations, it should be noted that the probability of synchronization failure increases with the number of data channels.
Remote command:

[SENSe:​]CDPower:​STYPe


Antenna1 / Antenna2

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Synchronization (BTS Measurements Only) > Antenna1 / Antenna2
Antenna1 / Antenna2

Synchronization is configured for each diversity antenna individually, on separate tabs.

The 3GPP FDD standard defines two different CPICH patterns for diversity antenna 1 and antenna 2. The CPICH pattern used for synchronization can be defined depending on the antenna (standard configuration), or fixed to either pattern, independantly of the antenna (user-defined configuration).

Remote command:

[SENSe:​]CDPower:​ANTenna

└ CPICH Mode
└ S-CPICH Code Nr


CPICH Mode

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Synchronization (BTS Measurements Only) > Antenna1 / Antenna2 > CPICH Mode
CPICH Mode

Defines whether the common pilot channel (CPICH) is defined by its default position or a user-defined position.

"P-CPICH" | Standard configuration (CPICH is always on channel 0)
"S-CPICH" | User-defined configuration. Enter the CPICH code number in the "S-CPICH Code Nr" field.
Remote command:

[SENSe:​]CDPower:​UCPich:​ANT<antenna>[:​STATe]


S-CPICH Code Nr

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Synchronization (BTS Measurements Only) > Antenna1 / Antenna2 > S-CPICH Code Nr
S-CPICH Code Nr

If a user-defined CPICH definition is to be used, enter the code of the CPICH based on the spreading factor 256. Possible values are 0 to 255.

Remote command:

[SENSe:​]CDPower:​UCPich:​ANT<antenna>:​CODE


S-CPICH Antenna Pattern

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Synchronization (BTS Measurements Only) > S-CPICH Antenna Pattern
S-CPICH Antenna Pattern

Defines the pattern used for evaluation.

Remote command:

[SENSe:​]CDPower:​UCPich:​ANT<antenna>:​PATTern


Channel Detection

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection
Channel Detection

The channel detection settings determine which channels are found in the input signal.

Contents
  • General Channel Detection Settings
  • Channel Table Management
  • Channel Table Settings and Functions
  • Channel Details (BTS Measurements)
  • Channel Details (UE Measurements)


General Channel Detection Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection Settings
General Channel Detection Settings

Channel detection settings are configured in the "Channel Detection" dialog box which is displayed when you select the "Channel Detection" button in the configuration "Overview".

└ Inactive Channel Threshold (BTS measurements only)
└ Using Predefined Channel Tables
└ Comparing the Measurement Signal with the Predefined Channel Table
└ Timing Offset Reference


Inactive Channel Threshold (BTS measurements only)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection Settings > Inactive Channel Threshold (BTS measurements only)
Inactive Channel Threshold (BTS measurements only)

Defines the minimum power that a single channel must have compared to the total signal in order to be recognized as an active channel.

Remote command:

[SENSe:​]CDPower:​ICTReshold


Using Predefined Channel Tables

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection Settings > Using Predefined Channel Tables
Using Predefined Channel Tables

Defines the channel search mode.

"Predefined" | Compares the input signal to the predefined channel table selected in the "Predefined Tables" list
"Auto" | Detects channels automatically using pilot sequences
Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle[:​STATe]

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle[:​STATe]


Comparing the Measurement Signal with the Predefined Channel Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection Settings > Comparing the Measurement Signal with the Predefined Channel Table
Comparing the Measurement Signal with the Predefined Channel Table

If enabled, the 3GPP FDD application compares the measured signal to the predefined channel tables. In the result summary, only the differences to the predefined table settings are displayed.

Remote command:

CONFigure:​WCDPower[:​BTS]:​CTABle:​COMPare


Timing Offset Reference

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection Settings > Timing Offset Reference
Timing Offset Reference

Defines the reference for the timing offset of the displayed measured signal.

"Relative to CPICH" | The measured timing offset is shown in relation to the CPICH.
"Relative to Predefined Table" | If the predefined table contains timing offsets, the delta between the defined and measured offsets are displayed in the evaluations.
Remote command:

CONFigure:​WCDPower[:​BTS]:​CTABle:​TOFFset


Channel Table Management

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management
Channel Table Management

Channel tables are managed in the "Channel Detection" dialog box which is displayed when you select the "Channel Detection" button in the configuration "Overview".

└ Predefined Tables
└ Selecting a Table
└ Creating a New Table
└ Editing a Table
└ Copying a Table
└ Deleting a Table
└ Restoring Default Tables


Predefined Tables

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management > Predefined Tables
Predefined Tables

The list shows all available channel tables and marks the currently used table with a checkmark. The currently focussed table is highlighted blue.

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​CATalog?

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​CATalog?


Selecting a Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management > Selecting a Table
Selecting a Table

Selects the channel table currently focussed in the "Predefined Tables" list and compares it to the measured signal to detect channels.

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​SELect

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​SELect


Creating a New Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management > Creating a New Table
Creating a New Table

Creates a new channel table. See "Channel Details (BTS Measurements)".

For step-by-step instructions on creating a new channel table, see "To define or edit a channel table".


Editing a Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management > Editing a Table
Editing a Table

You can edit existing channel table definitions. The details of the selected channel are displayed in the "Channel Table" dialog box. See "Channel Details (BTS Measurements)".


Copying a Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management > Copying a Table
Copying a Table

Copies an existing channel table definition. The details of the selected channel are displayed in the "Channel Table" dialog box. See "Channel Details (BTS Measurements)".

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​COPY

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​COPY


Deleting a Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management > Deleting a Table
Deleting a Table

Deletes the currently selected channel table after a message is confirmed.

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DELete

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​DELete


Restoring Default Tables

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Management > Restoring Default Tables
Restoring Default Tables

Restores the predefined channel tables delivered with the instrument.


Channel Table Settings and Functions

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions
Channel Table Settings and Functions

Some general settings and functions are available when configuring a predefined channel table.

Channel tables are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

└ Name
└ Comment
└ Adding a Channel
└ Deleting a Channel
└ Creating a New Channel Table from the Measured Signal (Measure Table)
└ Sorting the Table
└ Cancelling Configuration
└ Saving the Table


Name

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Name
Name

Name of the channel table that will be displayed in the "Predefined Channel Tables" list.

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​NAME

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​NAME


Comment

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Comment
Comment

Optional description of the channel table.

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​COMMent

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​COMMent


Adding a Channel

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Adding a Channel
Adding a Channel

Inserts a new row in the channel table to define another channel.


Deleting a Channel

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Deleting a Channel
Deleting a Channel

Deletes the currently selected channel from the table.


Creating a New Channel Table from the Measured Signal (Measure Table)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Creating a New Channel Table from the Measured Signal (Measure Table)
Creating a New Channel Table from the Measured Signal (Measure Table)

Creates a completely new channel table according to the current measurement data.

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​MEASurement

UE measurements:

CONFigure:​WCDPower:​MS:​MEASurement


Sorting the Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Sorting the Table
Sorting the Table

Sorts the channel table entries.


Cancelling Configuration

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Cancelling Configuration
Cancelling Configuration

Closes the "Channel Table" dialog box without saving the changes.


Saving the Table

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Table Settings and Functions > Saving the Table
Saving the Table

Saves the changes to the table and closes the "Channel Table" dialog box.


Channel Details (BTS Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements)
Channel Details (BTS Measurements)

Channel details are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

└ Channel Type
└ Symbol Rate
└ Channel Number (Ch. SF)
└ Use TFCI
└ Timing Offset
└ Pilot Bits
└ CDP Relative
└ Status
└ Conflict


Channel Type

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Channel Type
Channel Type

Type of channel. For a list of possible channel types see "BTS Channel Types".

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​DATA


Symbol Rate

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Symbol Rate
Symbol Rate

Symbol rate at which the channel is transmitted.


Channel Number (Ch. SF)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Channel Number (Ch. SF)
Channel Number (Ch. SF)

Number of channel spreading code (0 to [spreading factor-1])

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​DATA


Use TFCI

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Use TFCI
Use TFCI

Indicates whether the slot format and data rate are determined by the Transport Format Combination Indicator(TFCI).

Remote command:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA


Timing Offset

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Timing Offset
Timing Offset

Defines a timing offset in relation to the CPICH channel. During evaluation, the detected timing offset can be compared to this setting; only the delta is displayed (see "Timing Offset Reference").

Remote command:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA


Pilot Bits

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Pilot Bits
Pilot Bits

Number of pilot bits of the channel (only valid for the control channel DPCCH)

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​DATA


CDP Relative

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > CDP Relative
CDP Relative

Code domain power (relative to the total power of the signal)

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​DATA


Status

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Status
Status

Indicates the channel status. Codes that are not assigned are marked as inactive channels.

Remote command:

BTS measurements:

CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA

UE measurements:

CONFigure:​WCDPower:​MS:​CTABle:​DATA


Conflict

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (BTS Measurements) > Conflict
Conflict

Indicates a code domain conflict between channel definitions (e.g. overlapping channels).


Channel Details (UE Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (UE Measurements)
Channel Details (UE Measurements)

Channel details are configured in the "Channel Table" dialog box which is displayed when you select the "New", "Copy" or "Edit" buttons for a predefined channel table in the "Channel Detection" dialog box.

└ Channel Type
└ Symbol Rate
└ Channel Number (Ch. SF)
└ Mapping
└ Pilot Bits
└ CDP Relative
└ Status


Symbol Rate

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (UE Measurements) > Symbol Rate
Symbol Rate

Symbol rate at which the channel is transmitted.


Mapping

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Channel Details (UE Measurements) > Mapping
Mapping

Branch onto which the channel is mapped (I or Q). The setting is not editable, since the standard specifies the channel assignment for each channel.


Sweep Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings
Sweep Settings

The sweep settings define how the data is measured.

└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Refresh
└ Sweep/Average Count


Continuous Sweep/RUN CONT

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

After triggering, starts the sweep and repeats it continuously until stopped. This is the default setting.

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. If the Sequencer is active, the "Continuous Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in continuous sweep mode is swept repeatedly.
Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

After triggering, starts the number of sweeps set in "Sweep Count". The measurement stops after the defined number of sweeps has been performed.

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. If the Sequencer is active, the "Single Sweep" softkey only controls the sweep mode for the currently selected channel; however, the sweep mode only has an effect the next time the Sequencer activates that channel, and only for a channel-defined sequence. In this case, a channel in single sweep mode is swept only once by the Sequencer.
Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings > Continue Single Sweep
Continue Single Sweep

After triggering, repeats the number of sweeps set in "Sweep Count", without deleting the trace of the last measurement.

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Refresh

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings > Refresh
Refresh

This function is only available if the Sequencer is deactivated and only for MSRA applications.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

This is useful, for example, after evaluation changes have been made or if a new sweep was performed from another application; in this case, only that application is updated automatically after data acquisition.

Note: To update all active applications at once, use the "Refresh all" function in the "Sequencer" menu.
(See "Refresh All" ).

Remote command:

INITiate:​REFResh


Sweep/Average Count

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings > Sweep/Average Count
Sweep/Average Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 200000 are allowed. If the values 0 or 1 are set, one sweep is performed.

The sweep count is applied to all the traces in all diagrams.

If the trace modes "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

For more information see "How Much Data is Measured: Sweep Points and Sweep Count" .

Remote command:

[SENSe:​]SWEep:​COUNt

[SENSe:​]AVERage:​COUNt


Automatic Settings

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings. In order to do so, a measurement is performed. The duration of this measurement can be defined automatically or manually.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu or in the configuration dialog box for the setting, where available.

MSRA operating mode

In MSRA operating mode, the following automatic settings are not available, as they require a new data acquisition. However, 3GPP FDD applications cannot perform data acquisition in MSRA operating mode.

└ Adjusting all Determinable Settings Automatically (Auto All)
└ Setting the Reference Level Automatically (Auto Level)
└ Autosearch for Scrambling Code
└ Auto Scale Window
└ Auto Scale All
└ Restore Scale (Window)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Adjusting all Determinable Settings Automatically (Auto All)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Adjusting all Determinable Settings Automatically (Auto All)
Adjusting all Determinable Settings Automatically (Auto All)

Activates all automatic adjustment functions for the current measurement settings.

This includes:

  • Auto Level
  • "Autosearch for Scrambling Code"
  • "Auto Scale All"

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​ALL


Autosearch for Scrambling Code

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Autosearch for Scrambling Code
Autosearch for Scrambling Code

Starts a search on the measured signal for all scrambling codes. The scrambling code that leads to the highest signal power is chosen as the new scrambling code.

Searching requires that the correct center frequency and level are set. The scrambling code search can automatically determine the primary scrambling code number. The secondary scrambling code number is expected as 0. Alternative scrambling codes can not be detected. Therefore the range for detection is 0x0000 – 0x1FF0h, where the last digit is always 0.

Remote command:

[SENSe:​]CDPower:​LCODe:​SEARch[:​IMMediate]?


Auto Scale Window

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Auto Scale Window
Auto Scale Window

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings in the currently selected window. No new measurement is performed.


Auto Scale All

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Auto Scale All
Auto Scale All

Automatically determines the optimal range and reference level position to be displayed for the current measurement settings in all displayed diagrams. No new measurement is performed.


Resetting the Automatic Measurement Time (Meastime Auto)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

This function is only available for the MSRA/MSRT Master, not for the applications.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


BW, Span, Lines and Marker Function Menus

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > BW, Span, Lines and Marker Function Menus
BW, Span, Lines and Marker Function Menus

The "Span", "Bandwidth", "Lines" and "Marker Function" menus are disabled for Code Domain Analysis measurements.


Zoom Functions

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > Code Domain Analysis and Time Alignment Error Measurements > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


RF Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements
RF Measurements

3GPP FDD measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you activate a 3GPP FDD application, Code Domain Analysis of the input signal is started automatically. However, the 3GPP FDD applications also provide various RF measurement types.

Selecting the measurement type
►

To select an RF measurement type, do one of the following:

  • Select the "Overview" softkey. In the "Overview", select the "Select Measurement" button. Select the required measurement.
  • Press the MEAS key on the front panel. In the "Select Measurement" dialog box, select the required measurement.

Some parameters are set automatically according to the 3GPP standard the first time a measurement is selected (since the last PRESET operation). A list of these parameters is given with each measurement type. The parameters can be changed, but are not reset automatically the next time you re-enter the measurement.

The main measurement configuration menus for the RF measurements are identical to the Spectrum application.

For details refer to "Common Measurement Settings" .

The measurement-specific settings for the following measurements are available in the "Analysis" dialog box (via the "Overview").

Contents
  • Channel Power (ACLR) Measurements
  • Occupied Bandwidth
  • Output Power Measurements
  • Spectrum Emission Mask
  • RF Combi
  • CCDF


Channel Power (ACLR) Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements > Channel Power (ACLR) Measurements
Channel Power (ACLR) Measurements

Channel Power ACLR measurements are performed as in the Spectrum application with the following predefined settings according to 3GPP specifications (adjacent channel leakage ratio).

Predefined settings for 3GPP FDD ACLR Channel Power measurements
Standard | (BTS measurements only):"Normal" base station
Number of adjacent channels | 2

For further details about the ACLR measurements refer to "Channel Power and Adjacent-Channel Power (ACLR) Measurement" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span
  • Number of adjacent channels
  • Fast ACLR mode

The main measurement menus for the RF measurements are identical to the Spectrum application. However, for SEM and ACLR measurements in BTS measurements, an additional softkey is available to select the required standard.

└ BTS Standard


BTS Standard

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements > Channel Power (ACLR) Measurements > BTS Standard
BTS Standard

Switches between Normal mode and Home BS (Home Base Station) mode. Switching this parameter changes the limits according to the specifications.

Remote command:

CONFigure:​WCDPower[:​BTS]:​STD


Occupied Bandwidth

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements > Occupied Bandwidth
Occupied Bandwidth

The Occupied Bandwidth measurement determines the bandwidth that the signal occupies. The occupied bandwidth is defined as the bandwidth in which – in default settings - 99 % of the total signal power is to be found. The percentage of the signal power to be included in the bandwidth measurement can be changed.

The Occupied Bandwidth measurement is performed as in the Spectrum application with default settings.

Predefined settings for 3GPP FDD OBW measurements
Setting | Default value
% Power Bandwidth | 99 %
Channel bandwidth | 3.84 MHz

For further details about the Occupied Bandwidth measurements refer to "Occupied Bandwidth Measurement (OBW)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • RBW, VBW
  • Sweep time
  • Span


Output Power Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements > Output Power Measurements
Output Power Measurements

The Output Power measurement determines the 3GPP FDD signal channel power.

In order to determine the Output Power, the 3GPP FDD application performs a Channel Power measurement as in the Spectrum application with the following settings:

Predefined settings for 3GPP FDD Output Channel Power measurements
Standard | W-CDMA 3GPP REV (BTS) / W-CDMA 3GPP FWD (UE) By default, the "Normal" base station standard is used. However, you can switch to the "Home" base station standard using the "BTS Standard" softkey.
Number of adjacent channels | 0


Spectrum Emission Mask

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements > Spectrum Emission Mask
Spectrum Emission Mask

The Spectrum Emission Mask measurement determines the power of the 3GPP FDD signal in defined offsets from the carrier and compares the power values with a spectral mask specified by 3GPP.

For further details about the Spectrum Emission Mask measurements refer to "Spectrum Emission Mask (SEM) Measurement" .

The 3GPP FDD applications perform the SEM measurement as in the Spectrum application with the following settings:

Predefined settings for 3GPP FDD SEM measurements
Standard | W-CDMA 3GPP REV (BTS) / W-CDMA 3GPP FWD (UE) By default, the "Normal" base station standard is used. However, you can switch to the "Home" base station standard using the "BTS Standard" softkey.
Span | +/- 8 MHz
Number of ranges | 11
Fast SEM | ON
Number of power classes | 4
Power reference type | Channel power

Changing the RBW and the VBW is restricted due to the definition of the limits by the standard.

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Sweep time
  • Span


RF Combi

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements > RF Combi
RF Combi

This measurement combines the following measurements:

  • "Channel Power (ACLR) Measurements"
  • "Occupied Bandwidth"
  • "Spectrum Emission Mask"

The advantage of the RF Combi measurement is that all RF results are measured with a single measurement process. This measurement is faster than the three individual measurements.

The RF Combi measurement is performed as in the Spectrum application with the following settings:

Predefined settings for 3GPP FDD RF Combi measurements
Standard | W-CDMA 3GPP REV (BTS) / W-CDMA 3GPP FWD (UE) By default, the "Normal" base station standard is used. However, you can switch to the "Home" base station standard using the "BTS Standard" softkey.
Number of adjacent channels | 2
Span | 25.5 MHz
Detector | RMS
RBW | 30 kHz
Sweep time | 100 ms
CP/ACLR | Active on trace 1
OBW | Active on trace 1
SEM | Active on trace 2
To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • RBW, VBW
  • Sweep time
  • Span
  • Number of adjacent channels


CCDF

3G FDD Measurements (R&S FSW-K72/K73) > Configuration > RF Measurements > CCDF
CCDF

The CCDF measurement determines the distribution of the signal amplitudes (complementary cumulative distribution function).

The CCDF measurement is performed as in the Spectrum application with the following settings:

Predefined settings for 3GPP FDD CCDF measurements
CCDF | Active on trace 1
Analysis bandwidth | 10 MHz
Number of samples | 62500
VBW | 5 MHz

For further details about the CCDF measurements refer to "Statistical Measurements (APD, CCDF)" .

To restore adapted measurement parameters, the following parameters are saved on exiting and are restored on re-entering this measurement:
  • Reference level and reference level offset
  • Analysis bandwidth
  • Number of samples


Analysis

3G FDD Measurements (R&S FSW-K72/K73) > Analysis
Analysis

General result analysis settings concerning the evaluation range, trace, markers, etc. can be configured via the "Analysis" button in the "Overview".

Analysis of RF Measurements

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in the 3GPP FDD applications.

See
  • "Common Analysis and Display Functions"
  • "Analyzing Measurements (Basics)"

The remote commands required to perform these tasks are described in "Analysis".

Contents
  • Evaluation Range
  • Code Domain Analysis Settings (BTS Measurements)
  • Code Domain Analysis Settings (UE Measurements)
  • Traces
  • Markers


Evaluation Range

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Evaluation Range
Evaluation Range

The evaluation range defines which channel, slot or frame is evaluated in the result display.

For UE measurements, the branch to be evaluated can also be defined.

└ Channel
└ Slot
└ Frame To Analyze
└ Branch (UE measurements only)
└ Details
└ Selecting a Different Branch for a Window


Channel

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Evaluation Range > Channel
Channel

Selects a channel for the following evaluations: "CDP PWR RELATIVE/ABSOLUTE", "POWER VS SLOT", "SYMBOL CONST","SYMBOL EVM"

Enter a channel number and spreading factor, separated by a decimal point.

The specified channel is selected and marked in red, if active. If no spreading factor is specified, the code on the basis of the spreading factor 512 is marked. For unused channels, the code resulting from the conversion is marked.

Example: Enter 5.128

Channel 5 is marked at spreading factor 128 (30 ksps) if the channel is active, otherwise code 20 at spreading factor 512.

Remote command:

[SENSe:​]CDPower:​CODE


Slot

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Evaluation Range > Slot
Slot

Selects the slot for evaluation. This affects the following evaluations (see also "Evaluation Methods for Code Domain Analysis"):

  • Code Domain Power
  • Peak Code Domain Error
  • Result Summary
  • Composite Constellation
  • Code Domain Error Power
  • Channel Table
  • Power vs Symbol
  • Symbol Const
  • Symbol EVM
  • Bitstream
Remote command:

[SENSe:​]CDPower:​SLOT


Branch (UE measurements only)

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Evaluation Range > Branch (UE measurements only)
Branch (UE measurements only)

Switches between the evaluation of the I and the Q branch in UE measurements.

Remote command:

CALCulate<n>:​CDPower:​Mapping

└ Details
└ Selecting a Different Branch for a Window


Details

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Evaluation Range > Branch (UE measurements only) > Details
Details

By default, the same branch is used for all evaluations. However, you can select a different branch for individual windows. These settings are only available in the detailed dialog box, which is displayed when you select the "Details" button in the "Evaluation Range" dialog box.

To hide the detailed dialog box for individual windows, select the "Hide" button.


Selecting a Different Branch for a Window

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Evaluation Range > Branch (UE measurements only) > Selecting a Different Branch for a Window
Selecting a Different Branch for a Window

By default, the same (common) branch is used by all windows, namely the one specified by the "Branch (UE measurements only)" setting.

In order to evaluate a different branch for an individual window, toggle the "Use Common Branch" setting to "No". Select the window from the list of active windows under "Specifics for", then select the "Branch".

Note: These settings are only available in the detailed dialog box, which is displayed when you select the "Details" button in the "Evaluation Range" dialog box.

Remote command:

CALCulate<n>:​CDPower:​Mapping


Code Domain Analysis Settings (BTS Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (BTS Measurements)
Code Domain Analysis Settings (BTS Measurements)

Some evaluations provide further settings for the results. The settings for BTS measurements are described here.

└ Compensate IQ Offset
└ Code Power Display
└ Show Difference to Previous Slot
└ Constellation Parameter B


Compensate IQ Offset

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (BTS Measurements) > Compensate IQ Offset
Compensate IQ Offset

If enabled, the I/Q offset is eliminated from the measured signal. This is useful to deduct a DC offset to the baseband caused by the DUT, thus improving the EVM. Note, however, that for EVM measurements according to standard, compensation must be disabled.

Remote command:

[SENSe:​]CDPower:​NORMalize


Code Power Display

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (BTS Measurements) > Code Power Display
Code Power Display

For "Code Domain Power" evaluation:

Defines whether the absolute power or the power relative to the chosen reference is displayed.

Note: In UE measurements, relative powers are always in relation to the total signal power.

"TOT" | Relative to the total signal power
"CPICH" | Relative to the power of the CPICH
Remote command:

[SENSe:​]CDPower:​PDISplay

[SENSe:​]CDPower:​PREFerence


Show Difference to Previous Slot

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (BTS Measurements) > Show Difference to Previous Slot
Show Difference to Previous Slot

For "Power vs. Slot" evaluation:

If enabled, the slot power difference between the current slot and the previous slot is displayed in the "Power vs. Slot" evaluation.

Remote command:

[SENSe:​]CDPower:​PDIFf


Constellation Parameter B

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (BTS Measurements) > Constellation Parameter B
Constellation Parameter B

For "Bitstream" evaluation:

Defines the constellation parameter B. According to 3GPP specification, the mapping of 16QAM symbols to an assigned bitstream depends on the constellation parameter B. This parameter can be adjusted to decide which bit mapping should be used for bitstream evaluation.

Remote command:

[SENSe:​]CDPower:​CPB


Code Domain Analysis Settings (UE Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (UE Measurements)
Code Domain Analysis Settings (UE Measurements)

Some evaluations provide further settings for the results. The settings for UE measurements are described here.

└ Measurement Interval
└ Compensate IQ Offset
└ Eliminate Tail Chips
└ Code Power Display


Measurement Interval

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (UE Measurements) > Measurement Interval
Measurement Interval

Switches between the analysis of a half slot or a full slot.

Both measurement intervals are influenced by the settings of "Eliminate Tail Chips": If "Eliminate Tail Chips" is set to "On", 96 chips at both ends of the measurement interval are not taken into account for analysis.

"Slot" | The length of each analysis interval is 2560 chips, corresponding to one time slot of the 3GPP signal. The time reference for the start of slot 0 is the start of a 3GPP radio frame.
"Halfslot" | The length of each analysis interval is reduced to 1280 chips, corresponding to half of one time slot of the 3GPP signal.
Remote command:

[SENSe:​]CDPower:​HSLot


Compensate IQ Offset

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (UE Measurements) > Compensate IQ Offset
Compensate IQ Offset

If enabled, the I/Q offset is eliminated from the measured signal. This is useful to deduct a DC offset to the baseband caused by the DUT, thus improving the EVM. Note, however, that for EVM measurements according to standard, compensation must be disabled.

Remote command:

[SENSe:​]CDPower:​NORMalize


Eliminate Tail Chips

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (UE Measurements) > Eliminate Tail Chips
Eliminate Tail Chips

Selects the length of the measurement interval for calculation of error vector magnitude (EVM) in accordance with 3GPP specification Release 5.

"On" | Changes of power are expected. Therefore an EVM measurement interval of one slot minus 25 µs at each end of the burst (3904 chips) is considered.
"Off" | Changes of power are not expected. Therefore an EVM measurement interval of one slot (4096 chips) is considered. (Default settings)
Remote command:

[SENSe:​]CDPower:​ETCHips


Code Power Display

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Code Domain Analysis Settings (UE Measurements) > Code Power Display
Code Power Display

For "Code Domain Power" evaluation:

Defines whether the absolute power or the power relative to the total signal is displayed.

"Absolute" | Absolute power levels
"Relative" | Relative to the total signal power
Remote command:

[SENSe:​]CDPower:​PDISplay


Traces

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Traces
Traces

The trace settings determine how the measured data is analyzed and displayed on the screen.

In CDA evaluations, only one trace can be active in each diagram at any time.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

└ Trace Mode


Trace Mode

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Traces > Trace Mode
Trace Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves each trace point in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Markers

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display.

Markers are configured in the "Marker" dialog box which is displayed when you do one of the following:

  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.
  • Press the MKR key, then select the "Marker Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Markers in Code Domain Analysis measurements

In Code Domain Analysis measurements, the markers are set to individual symbols, codes, slots or channels, depending on the result display. Thus you can use the markers to identify individual codes, for example.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Search Settings
  • Marker Positioning Functions


Individual Marker Settings

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Individual Marker Settings
Individual Marker Settings

In CDA evaluations, up to 4 markers can be activated in each diagram at any time.

└ Marker 1 / Marker 2 / Marker 3 / Marker 4
└ Selected Marker
└ Marker State
└ X-value
└ Marker Type
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / Marker 4

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Individual Marker Settings > Marker 1 / Marker 2 / Marker 3 / Marker 4
Marker 1 / Marker 2 / Marker 3 / Marker 4

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 4 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: For Code Domain Analysis the marker position moves from one slot (PCG) / channel / code / symbol to the next, depending on the current evaluation.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?


Selected Marker

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Individual Marker Settings > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Individual Marker Settings > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


X-value

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Individual Marker Settings > X-value
X-value

Defines the position of the marker on the x-axis (channel, slot, symbol, depending on evaluation).

Remote command:

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​MARKer<m>:​X


Marker Type

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Individual Marker Settings > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


All Markers Off

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Individual Marker Settings > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > General Marker Settings
General Marker Settings

General marker settings are defined in the "Marker Config" tab of the "Marker" dialog box.

└ Marker Table Display


Marker Table Display

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Marker Search Settings

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Search Settings
Marker Search Settings

Several functions are available to set the marker to a specific position very quickly and easily. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

These settings are available as softkeys in the "Marker To" menu, or in the "Search" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search" tab.
└ Search Mode for Next Peak


Search Mode for Next Peak

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Marker Positioning Functions

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions
Marker Positioning Functions

The following functions set the currently selected marker to the result of a peak search. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key.

Markers in Code Domain Analysis measurements

In Code Domain Analysis measurements, the markers are set to individual symbols, codes, slots or channels, depending on the result display. Thus you can use the markers to identify individual codes, for example.

└ Select Marker
└ Search Next Peak
└ Search Next Minimum
└ Peak Search
└ Search Minimum
└ Marker To CPICH
└ Marker To PCCPCH


Select Marker

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions > Select Marker
Select Marker

Selects the subsequent marker (marker 1/2/3/4 or delta marker) to be edited or to be used for a marker function. The currently selected marker number is highlighted.

Remote command:

Marker selected via suffix <m> in remote commands.


Search Next Peak

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Next Minimum

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Peak Search

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Minimum

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Marker To CPICH

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions > Marker To CPICH
Marker To CPICH

Sets the marker to the CPICH channel.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​CPICh


Marker To PCCPCH

3G FDD Measurements (R&S FSW-K72/K73) > Analysis > Markers > Marker Positioning Functions > Marker To PCCPCH
Marker To PCCPCH

Sets the marker to the PCCPCH channel.

Remote command:

CALCulate<n>:​MARKer<m>:​FUNCtion:​PCCPch


I/Q Data Import and Export

3G FDD Measurements (R&S FSW-K72/K73) > I/Q Data Import and Export
I/Q Data Import and Export

Baseband signals mostly occur as so-called complex baseband signals, i.e. a signal representation that consists of two channels; the in phase (I) and the quadrature (Q) channel. Such signals are referred to as I/Q signals. I/Q signals are useful because the specific RF or IF frequencies are not needed. The complete modulation information and even distortion that originates from the RF, IF or baseband domains can be analyzed in the I/Q baseband.

Importing and exporting I/Q signals is useful for various applications:
  • Generating and saving I/Q signals in an RF or baseband signal generator or in external software tools to analyze them with the R&S FSW later
  • Capturing and saving I/Q signals with an RF or baseband signal analyzer to analyze them with the R&S FSW or an external software tool later

As opposed to storing trace data, which may be averaged or restricted to peak values, I/Q data is stored as it was captured, without further processing. The data is stored as complex values in 32-bit floating-point format. Multi-channel data is not supported. The I/Q data is stored in a format with the file extension .iq.tar.

For a detailed description see "I/Q Data File Format (iq-tar)" .

Export only in MSRA mode

In MSRA mode, I/Q data can only be exported to other applications; I/Q data cannot be imported to the MSRA Master or any MSRA applications.

For details on import and export functions see "Import/Export Functions" .


Optimizing and Troubleshooting the Measurement

3G FDD Measurements (R&S FSW-K72/K73) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement:

Synchronization fails:
  • Check the frequency.
  • Check the reference level.
  • Check the scrambling code.
  • When using an external trigger, check whether an external trigger is being sent to the R&S FSW.
Contents
  • Error Messages


Error Messages

3G FDD Measurements (R&S FSW-K72/K73) > Optimizing and Troubleshooting the Measurement > Error Messages
Error Messages

Error messages are entered in the error/event queue of the status reporting system in the remote control mode and can be queried with the command SYSTem:ERRor?.

A short explanation of the device-specific error messages for the 3GPP FDD applications is given below.

Status bar message

Description

Sync not found

This message is displayed if synchronization is not possible.

Possible causes are that frequency, level, scrambling code, Invert Q values are set incorrectly, or the input signal is invalid.

Sync OK

This message is displayed if synchronization is possible.

Incorrect pilot symbols

This message is displayed if one or more of the received pilot symbols are not equal to the specified pilot symbols of the 3GPP standard.

Possible causes are:

  • Incorrectly sent pilot symbols in the received frame.
  • Low signal to noise ratio (SNR) of the W-CDMA signal.
  • One or more code channels have a significantly lower power level compared to the total power. The incorrect pilots are detected in these channels because of low channel SNR.
  • One or more channels are sent with high power ramping. In slots with low relative power to total power, the pilot symbols might be detected incorrectly (check the signal quality by using the symbol constellation display


How to Perform Measurements in 3GPP FDD Applications

3G FDD Measurements (R&S FSW-K72/K73) > How to Perform Measurements in 3GPP FDD Applications
How to Perform Measurements in 3GPP FDD Applications

The following step-by-step instructions demonstrate how to perform measurements with the 3GPP FDD applications.

To perform Code Domain Analysis

  1. Press the MODE key on the front panel and select the "3GPP FDD BTS" applications for base station tests, or "3GPP FDD UE" for user equipment tests.

    Code Domain Analysis of the input signal is performed by default.

  2. Select the "Overview" softkey to display the "Overview" for Code Domain Analysis.

  3. Select the "Signal Description" button and configure the expected input signal and used scrambling code.

  4. Select the "Input/Frontend" button and then the "Frequency" tab to define the input signal's center frequency.

  5. Optionally, select the "Trigger" button and define a trigger for data acquisition, for example an external trigger to start capturing data only when a useful signal is transmitted.

  6. Select the "Signal Capture" button and define the acquisition parameters for the input signal.

    In MSRA mode, define the application data instead, see "To select the application data for MSRA measurements".

  7. If necessary, select the "Synchronization" button and change the channel synchronization settings.

  8. Select the "Channel Detection" button and define how the individual channels are detected within the input signal. If necessary, define a channel table as described in "To define or edit a channel table".

  9. Select the "Display Config" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  10. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  11. Select the "Analysis" button in the "Overview" to configure how the data is evaluated in the individual result displays.

    • Select the channel, slot or frame to be evaluated.
    • Configure specific settings for the selected evaluation method(s).
    • Optionally, configure the trace to display the average over a series of sweeps. If necessary, increase the "Sweep/Average Count" in the "Sweep Config" dialog box.
    • Configure markers and delta markers to determine deviations and offsets within the results, e.g. when comparing errors or peaks.

  12. Start a new sweep with the defined settings.

    In MSRA mode you may want to stop the continuous measurement mode by the Sequencer and perform a single data acquisition:

    1. Select the Sequencer icon ( [image]) from the toolbar.

    2. Set the Sequencer state to "OFF".

    3. Press the RUN SINGLE key.

To define or edit a channel table

Channel tables contain a list of channels to be detected and their specific parameters. You can create user-defined and edit pre-defined channel tables.

  1. Select the "Channel Detection" softkey from the main "Code Domain Analyzer" menu to open the "Channel Detection" dialog box.

  2. To define a new channel table, select the "New" button next to the "Predefined Tables" list.

    To edit an existing channel table:

    1. Select the existing channel table in the "Predefined Tables" list.

    2. Select the "Edit" button next to the "Predefined Tables" list.

  3. In the "Channel Table" dialog box, define a name and, optionally, a comment that describes the channel table. The comment is displayed when you set the focus on the table in the "Predefined Tables" list.

  4. Define the channels to be detected using one of the following methods:

    Select the "Measure Table" button to create a table that consists of the channels detected in the currently measured signal.

    Or:

    1. Select the "Add Channel" button to insert a row for a new channel below the currently selected row in the channel table.

    2. Define the channel specifications required for detection:

      • Symbol rate
      • Channel number
      • Whether TFCI is used
      • Timing offset, if applicable
      • Number of pilot bits (for DPCCH only)
      • The channel's code domain power (relative to the total signal power)

  5. Select the "Save Table" button to store the channel table.

    The table is stored and the dialog box is closed. The new channel table is included in the "Predefined Tables" list in the "Channel Detection" dialog box.

  6. To activate the use of the new channel table:

    1. Select the table in the "Predefined Tables" list.

    2. Select the "Select" button.

      A checkmark is displayed next to the selected table.

    3. Toggle the "Use Predefined Channel Table" setting to "Predefined".

    4. Toggle the "Compare Meas Signal with Predefined Table" setting to "On".

    5. Start a new measurement.

To determine the Time Alignment Error

  1. Press the MODE key on the front panel and select the "3GPP FDD BTS" applications for base station tests, or "3GPP FDD UE" for user equipment tests.

    Code Domain Analysis of the input signal is performed by default.

  2. Press the "Synch." softkey to display the "Synchronization" dialog box. Configure the location of the S-CPICH for antenna 2 and select the "Antenna Pattern".

  3. Select the Time Alignment Error measurement:

    1. Press the MEAS key on the front panel.

    2. In the "Select Measurement" dialog box, select the "Time Alignment Error" button.

    The Time Alignment Error is calculated and displayed immediately.

To perform an RF measurement

  1. Press the MODE key on the front panel and select the "3GPP FDD BTS" applications for base station tests, or "3GPP FDD UE" for user equipment tests.

    The R&S FSW opens a new measurement channel for the 3GPP FDD application. Code Domain Analysis of the input signal is performed by default.

  2. Select the RF measurement:

    1. Press the MEAS key on the front panel.

    2. In the "Select Measurement" dialog box, select the required measurement.

    The selected measurement is activated with the default settings for the 3GPP FDD application immediately.

  3. If necessary, adapt the settings as described for the individual measurements in "Measurements" .

  4. Select the "Display Config" button and select the evaluation methods that are of interest to you.

    Arrange them on the display to suit your preferences.

  5. Exit the SmartGrid mode and select the "Overview" softkey to display the "Overview" again.

  6. Select the "Analysis" button in the "Overview" to make use of the advanced analysis functions in the result displays.

    • Configure a trace to display the average over a series of sweeps; if necessary, increase the "Sweep Count" in the "Sweep" settings.
    • Configure markers and delta markers to determine deviations and offsets within the evaluated signal.
    • Use special marker functions to calculate noise or a peak list.
    • Configure a limit check to detect excessive deviations.

  7. Optionally, export the trace data of the graphical evaluation results to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".

To select the application data for MSRA measurements

In multi-standard radio analysis you can analyze the data captured by the MSRA Master in the 3GPP FDD BTS application. Assuming you have detected a suspect area of the captured data in another application, you would now like to analyze the same data in the 3GPP FDD BTS application.

  1. Select the "Overview" softkey to display the "Overview" for Code Domain Analysis.

  2. Select the "Signal Capture" button.

  3. Define the application data range as the "Capture Length (Frames)". You must determine the number of frames according to the following formula:

    <No of frames> = <measurement time in seconds> / 10 ms (time per frame)

    Add an additional frame as the first frame may start before the suspect measurement range.

  4. Define the starting point of the application data as the "Capture offset". The offset is calculated according to the following formula:

    <capture offset> = <starting point for application> - <starting point in capture buffer>

  5. The analysis interval is automatically determined according to the selected channel, slot or frame to analyze (defined for the evaluation range), depending on the result display. Note that the frame/slot/channel is analyzed within the application data. If the analysis interval does not yet show the required area of the capture buffer, move through the frames/slots/channels in the evaluation range or correct the application data range.

  6. If the Sequencer is off, select the "Refresh" softkey in the "Sweep" menu to update the result displays for the changed application data.


Measurement Examples

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples
Measurement Examples

Some practical examples for basic 3GPP°FDD user equipment tests are provided here. They describe how operating and measurement errors can be avoided using correct presettings. The measurements are performed with an R&S FSW equipped with option R&S FSW-K73. The measurements can be performed for base station tests in a similar way with option R&S FSW-K72.

Key settings are shown as examples to avoid measurement errors. Following the correct setting, the effect of an incorrect setting is shown.

The measurements are performed using the following devices and accessories:

  • The R&S FSW with Application Firmware R&S FSW-K73: 3GPP FDD UE user equipment test
  • The Vector Signal Generator R&S SMU with option R&S SMU-B45: digital standard 3GPP (options R&S SMU-B20 and R&S SMU-B11 required)
  • 1 coaxial cable, 50Ω, approx. 1 m, N connector
  • 1 coaxial cable, 50Ω, approx. 1 m, BNC connector

The following measurements are described:

Contents
  • Measurement 1: Measuring the Signal Channel Power
  • Measurement 2: Determining the Spectrum Emission Mask
  • Measurement 3: Measuring the Relative Code Domain Power
  • Measurement 4: Triggered Measurement of Relative Code Domain Power
  • Measurement 5: Measuring the Composite EVM
  • Measurement 6: Determining the Peak Code Domain Error


Measurement 1: Measuring the Signal Channel Power

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 1: Measuring the Signal Channel Power
Measurement 1: Measuring the Signal Channel Power

The measurement of the spectrum gives an overview of the 3GPP FDD UE signal and the spurious emissions close to the carrier.

Test setup
►

Connect the RF output of the R&S SMU to the RF input of the R&S FSW (coaxial cable with N connectors).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 2.1175 GHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "WCDMA/3GPP"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > UP/REVERSE"

  7. "DIGITAL STD > TEST MODELS > DPCCH_DPDCH960ksps"

  8. "DIGITAL STD > Select User Equipment > UE 1" = "ON"

  9. "DIGITAL STD > WCDMA/3GPP > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > 3GPP FDD UE"

  3. "AMPT > Reference level"= 0 dBm

  4. "FREQ > Center frequency" = 2.1175 GHz

  5. "MEAS > POWER"

  6. "AMPT > Scale Config > Auto Scale Once"

Result
Measurement Example 1: Measuring the Signal Channel Power


Measurement 2: Determining the Spectrum Emission Mask

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 2: Determining the Spectrum Emission Mask
Measurement 2: Determining the Spectrum Emission Mask

The 3GPP specification defines a measurement which monitors the compliance with a spectral mask in a range of at least ±12.5 MHz around the 3GPP FDD UE carrier. To assess the power emissions in the specified range, the signal power is measured in the range near the carrier using a 30kHz filter, in the ranges far away from the carrier using a 1MHz filter. The resulting trace is compared to a limit line defined in the 3GPP specification.

Test setup
►

Connect the RF output of the R&S SMU to the RF input of the R&S FSW (coaxial cable with N connectors).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 2.1175 GHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "WCDMA/3GPP"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > UP/REVERSE"

  7. "DIGITAL STD > TEST MODELS > DPCCH_DPDCH960ksps"

  8. "DIGITAL STD > Select User Equipment > UE 1" = "ON"

  9. "DIGITAL STD > WCDMA/3GPP > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > 3GPP FDD UE"

  3. "AMPT > Reference level"= 0 dBm

  4. "FREQ > Center frequency" = 2.1175 GHz

  5. "MEAS > Spectrum Emission Mask"

  6. "AMPT > Scale Config > Auto Scale Once"

Result

The following results are displayed:

  • Spectrum of the 3GPP FDD UE signal
  • Limit line defined in the standard
  • Information on limit line violations (passed/failed)
Measurement Example 2: Determining the Spectrum Emission Mask


Measurement 3: Measuring the Relative Code Domain Power

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 3: Measuring the Relative Code Domain Power
Measurement 3: Measuring the Relative Code Domain Power

A code domain power measurement on one of the channel configurations is shown in the following. Basic parameters of CDP analysis are changed to demonstrate the effects of values that are not adapted to the input signal.

Test setup

  1. Connect the RF output of the R&S SMU to the RF input of the R&S FSW (coaxial cable with N connectors).

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference output (REF) on the rear panel of R&S SMU (coaxial cable with BNC connectors).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 2.1175 GHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "WCDMA/3GPP"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > UP/REVERSE"

  7. "DIGITAL STD > TEST MODELS > DPCCH_DPDCH960ksps"

  8. "DIGITAL STD > Select User Equipment > UE 1" = "ON"

  9. "DIGITAL STD > WCDMA/3GPP > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > 3GPP FDD UE"

  3. "AMPT > Reference level"= 10 dBm

  4. "FREQ > Center frequency" = 2.1175 GHz

  5. "AMPT > Scale Config > Auto Scale Once"

Result

Window 1 shows the code domain power of the signal, on the Q branch.

Window 2 shows the result summary, i.e. the numeric results of the CDP measurement.

Measurement Example 3: Measuring the Relative Code Domain Power
Contents
  • Synchronizing the Reference Frequencies
  • Behaviour with Deviating Center Frequency
  • Behaviour with Incorrect Scrambling Code


Synchronizing the Reference Frequencies

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 3: Measuring the Relative Code Domain Power > Synchronizing the Reference Frequencies
Synchronizing the Reference Frequencies

The synchronization of the reference oscillators both of the DUT and R&S FSW strongly reduces the measured frequency error.

Test setup
►

Connect the reference input (REF INPUT (1...20 MHZ)) on the rear panel of the R&S FSW to the reference output (REF) on the rear panel of R&S SMU (coaxial cable with BNC connectors).

Settings on the R&S SMU

The settings on the R&S SMU remain the same.

Settings on the R&S FSW

In addition to the settings of the basic test, activate the use of an external reference:

► | "SETUP > Reference > Reference Frequency Input = External Reference 10 MHz"
 | The displayed carrier frequency error should be < 10 Hz.


Behaviour with Deviating Center Frequency

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 3: Measuring the Relative Code Domain Power > Behaviour with Deviating Center Frequency
Behaviour with Deviating Center Frequency

In the following, the behaviour of the DUT and the R&S FSW with an incorrect center frequency setting is shown.

  1. Tune the center frequency of the signal generator in 0.5 kHz steps.

  2. Watch the measurement results on the R&S FSW screen:

    • Up to 1 kHz, a frequency error causes no apparent difference in measurement accuracy of the code domain power measurement.
    • Above a frequency error of 1 kHz, the probability of an impaired synchronization increases. With continuous measurements, at times all channels are displayed in blue with almost the same level.
    • Above a frequency error of approx. 2 kHz, a CDP measurement cannot be performed. The R&S FSW displays all possible codes in blue with a similar level.

  3. Reset the frequency to 2.1175 GHz both on the R&S SMU and on the R&S FSW.

Measurement Example 3: Measuring the Relative Code Domain Power with Incorrect Center Frequency


Behaviour with Incorrect Scrambling Code

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 3: Measuring the Relative Code Domain Power > Behaviour with Incorrect Scrambling Code
Behaviour with Incorrect Scrambling Code

A valid CDP measurement can be carried out only if the scrambling code set on the R&S FSW is identical to that of the transmitted signal.

Settings on the R&S SMU
  • "SCRAMBLING CODE" = 0000
Settings on the R&S FSW
  • "Meas Config > Signal Description > Scrambling Code" = 0001
Result

The CDP display shows all possible codes with approximately the same level.

Measurement Example 3: Measuring the Relative Code Domain Power with Incorrect Scrambling Code


Measurement 4: Triggered Measurement of Relative Code Domain Power

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 4: Triggered Measurement of Relative Code Domain Power
Measurement 4: Triggered Measurement of Relative Code Domain Power

If the code domain power measurement is performed without external triggering, a section of approximately 20 ms of the test signal is recorded at an arbitrary moment to detect the start of a 3GPP FDD UE frame in this section. Depending on the position of the frame start, the required computing time can be quite long. Applying an external (frame) trigger can reduce the computing time.

Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 2.1175 GHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "WCDMA/3GPP"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > UP/REVERSE"

  7. "DIGITAL STD > TEST MODELS > DPCCH_DPDCH960ksps"

  8. "DIGITAL STD > Select User Equipment > UE 1" = "ON"

  9. "DIGITAL STD > WCDMA/3GPP > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > 3GPP FDD UE"

  3. "AMPT > Reference level"= 10 dBm

  4. "FREQ > Center frequency" = 2.1175 GHz

  5. "Meas Config > Signal Description > Scrambling Code" = 0000

  6. "TRIG > External Trigger 1"

  7. "AMPT > Scale Config > Auto Scale Once"

Results

The following is displayed:

  • Window 1: Code domain power of signal (channel configuration with 3 data channels on Q branch)
  • Window 2: Result summery, including the Trigger to Frame, i.e. offset between trigger event and start of 3GPP FDD UE frame
Measurement Example 4: Triggered Measurement of Relative Code Domain Power

The repetition rate of the measurement increases considerably compared to the repetition rate of a measurement without an external trigger.

Trigger Offset

A delay of the trigger event referenced to the start of the 3GPP FDD UE frame can be compensated by modifying the trigger offset.

► | Setting on the R&S FSW: "TRIG > Trigger Offset" = 100 µs
 | The "Trigger to Frame" parameter in the Result Summary (Window 2) changes: "Trigger to Frame" = -100 µs


Measurement 5: Measuring the Composite EVM

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 5: Measuring the Composite EVM
Measurement 5: Measuring the Composite EVM

The 3GPP specification defines the composite EVM measurement as the average square deviation of the total signal.

An ideal reference signal is generated from the demodulated data. The test signal and the reference signal are compared with each other. The square deviation yields the composite EVM.

Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 2.1175 GHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "WCDMA/3GPP"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > UP/REVERSE"

  7. "DIGITAL STD > TEST MODELS > DPCCH_DPDCH960ksps"

  8. "DIGITAL STD > Select User Equipment > UE 1" = "ON"

  9. "DIGITAL STD > WCDMA/3GPP > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > 3GPP FDD UE"

  3. "AMPT > Reference level"= 10 dBm

  4. "FREQ > Center frequency" = 2.1175 GHz

  5. "TRIG > External Trigger 1"

  6. "MEAS CONFIG > Display Config > Composite EVM" (Window 2)

  7. "AMPT > Scale Config > Auto Scale Once"

Results

The following is displayed:

  • Window 1: Code domain power of signal, branch Q
  • Window 2: Composite EVM (EVM for total signal)
Measurement Example 5: Measuring the Composite EVM


Measurement 6: Determining the Peak Code Domain Error

3G FDD Measurements (R&S FSW-K72/K73) > Measurement Examples > Measurement 6: Determining the Peak Code Domain Error
Measurement 6: Determining the Peak Code Domain Error

The peak code domain error measurement is defined in the 3GPP specification for FDD signals.

An ideal reference signal is generated from the demodulated data. The test signal and the reference signal are compared with each other. The difference of the two signals is projected onto the classes of the different spreading factors. The peak code domain error measurement is obtained by summing up the symbols of each difference signal slot and searching for the maximum error code.

Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU

  1. PRESET

  2. "FREQ" = 2.1175 GHz

  3. "LEVEL"= 0 dBm

  4. "DIGITAL STD" = "WCDMA/3GPP"

  5. "DIGITAL STD > Set Default"

  6. "DIGITAL STD > LINK DIRECTION > UP/REVERSE"

  7. "DIGITAL STD > TEST MODELS > DPCCH_DPDCH960ksps"

  8. "DIGITAL STD > Select User Equipment > UE 1" = "ON"

  9. "DIGITAL STD > WCDMA/3GPP > STATE"= "ON"

Settings on the R&S FSW

  1. PRESET

  2. "MODE > 3GPP FDD UE"

  3. "AMPT > Reference level"= 0 dBm

  4. "FREQ > Center frequency" = 2.1175 GHz

  5. "TRIG > External Trigger 1"

  6. "MEAS CONFIG > Display Config > Peak Code Domain Error" (Window 2)

  7. "AMPT > Scale Config > Auto Scale Once"

Results

The following is displayed:

  • Window 1: Code domain power of signal, branch Q
  • Window 2: Peak code domain error (projection of error onto the class with spreading factor 256)
Measurement Example 6: Determining the Peak Code Domain Error


Remote Commands for 3GPP FDD Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements
Remote Commands for 3GPP FDD Measurements

The following commands are required to perform measurements in 3GPP FDD applications in a remote environment.

It is assumed that the R&S FSW has already been set up for remote control in a network as described in "How to Set Up a Network and Remote Control" .

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following topics specific to 3GPP applications are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating 3GPP FDD Measurements
  • Selecting a Measurement
  • Configuring Code Domain Analysis and Time Alignment Error Measurements
  • Configuring RF Measurements
  • Configuring the Result Display
  • Starting a Measurement
  • Retrieving Results
  • Analysis
  • Configuring the Application Data Range (MSRA mode only)
  • Querying the Status Registers
  • Commands for Compatibility
  • Programming Examples (R&S FSW-K73)


Introduction

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Common Suffixes
Common Suffixes

In 3GPP FDD applications, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<n> | 1..16 | Window
<t> | 1 (CDA) 6 (RF) | Trace
<m> | 1..4 (CDA) 1..16 (RF) | Marker
<ch> | 1..18 (Tx channel) 1..11 (ALT channel) | Channel in RF measurements
<k> | 1..8 (Limit line) 1 | 2 (Display line) | Line in RF measurements


Activating 3GPP FDD Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements
Activating 3GPP FDD Measurements

3GPP FDD measurements require a special application on the R&S FSW. The measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

This command is not available if the MSRA Master channel is selected.

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

See also INSTrument:​CREate[:​NEW].

For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".

Parameters:
<ChannelType>
BWCD

3GPP FDD BTS option, R&S FSW–K72

MWCD

3GPP FDD UE option, R&S FSW–K73


SYSTem:PRESet:CHANnel[:EXECute]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Activating 3GPP FDD Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Selecting a Measurement

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Selecting a Measurement
Selecting a Measurement

The following commands are required to define the measurement type in a remote environment. For details on available measurements see "Measurements and Result Display".

List of Commands
CONFigure:WCDPower[:BTS]:MEASurement
CONFigure:WCDPower:MS:MEASurement


CONFigure:WCDPower[:BTS]:MEASurement

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Selecting a Measurement > CONFigure:WCDPower[:BTS]:MEASurement
CONFigure:WCDPower[:BTS]:MEASurement <Type>

This command selects the type of 3GPP FDD BTS base station tests.

Parameters:
<Type>
ACLR | ESPectrum | WCDPower | POWer | OBANdwith | CCDF | RFCombi | TAERror
ACLR

Adjacent-channel power measurement (standard 3GPP WCDMA Forward) with predefined settings

ESPectrum

Measurement of spectrum emission mask

WCDPower

Code domain power measurement. This selection has the same effect as command INSTrument:SELect BWCD

POWer

Channel power measurement (standard 3GPP WCDMA Forward) with predefined settings

OBANdwith | OBWidth

Measurement of occupied power bandwidth

CCDF

Measurement of complementary cumulative distribution function

RFCombi

Combined Adjacent Channel Power (Ch Power ACLR) measurement with Occupied Bandwidth and Spectrum Emission Mask

TAERror

Time Alignment Error measurement

*RST: OFF
Example:

CONF:WCDP:MEAS POW

Mode: BTS application only
Manual operation: See "Result List"
See "Ch Power ACLR"
See "Occupied Bandwidth"
See "Power"
See "RF Combi"
See "Spectrum Emission Mask"
See "CCDF"
See "Creating a New Channel Table from the Measured Signal (Measure Table)"


CONFigure:WCDPower:MS:MEASurement

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Selecting a Measurement > CONFigure:WCDPower:MS:MEASurement
CONFigure:WCDPower:MS:MEASurement <Type>

This command selects the 3GPP FDD UE user equipment tests.

Parameters:
<Type>
ACLR | ESPectrum | WCDPower | POWer | OBANdwith | OBWidth | CCDF
ACLR

Adjacent-channel power measurement (standard 3GPP WCDMA Reverse) with predefined settings

ESPectrum

Measurement of spectrum emission mask

WCDPower

Code domain power measurement. This selection has the same effect as command INSTrument:SELect MWCD

POWer

Channel power measurement (standard 3GPP WCDMA Reverse) with predefined settings

OBANdwith | OBWidth

Measurement of occupied power bandwidth.

CCDF

Measurement of complementary cumulative distribution function.

*RST: WCDPower
Example:

CONF:WCDP:MS:MEAS POW

Example:

See "Programming Examples (R&S FSW-K73)".

Mode: UE application only
Manual operation: See "Creating a New Channel Table from the Measured Signal (Measure Table)"


Configuring Code Domain Analysis and Time Alignment Error Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements
Configuring Code Domain Analysis and Time Alignment Error Measurements

The following commands are required to configure Code Domain Analysis and Time Alignment Error measurements.

Contents
  • Signal Description
  • Configuring the Data Input and Output
  • Frontend Configuration
  • Configuring Triggered Measurements
  • Signal Capturing
  • Synchronization
  • Channel Detection
  • Sweep Settings
  • Automatic Settings
  • Evaluation Range
  • Code Domain Analysis Settings (BTS Measurements)
  • Code Domain Analysis Settings (UE Measurements)


Signal Description

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description
Signal Description

The signal description provides information on the expected input signal.

Contents
  • BTS Signal Description
  • BTS Scrambling Code
  • UE Signal Description


BTS Signal Description

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description
BTS Signal Description

The following commands describe the input signal in BTS measurements.

List of Commands
[SENSe:]CDPower:ANTenna
[SENSe:]CDPower:HSDPamode
[SENSe:]CDPower:LCODe:SEARch[:IMMediate]?
[SENSe:]CDPower:LCODe:SEARch:LIST?
[SENSe:]CDPower:MIMO
[SENSe:]CDPower:PCONtrol


[SENSe:]CDPower:ANTenna

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > [SENSe:]CDPower:ANTenna
[SENSe:]CDPower:ANTenna <Mode>

This command activates or deactivates the antenna diversity mode and selects the antenna to be used.

Parameters:
<Mode>
OFF | 1 | 2
*RST: OFF
Example:

CDP:ANT 1

Mode: BTS application only
Manual operation: See "Antenna Diversity"
See "Antenna Number"
See "Antenna1 / Antenna2"


[SENSe:]CDPower:HSDPamode

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > [SENSe:]CDPower:HSDPamode
[SENSe:]CDPower:HSDPamode <State>

This command defines whether the HS-DPCCH channel is searched or not.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The high speed channels can be detected. A detection of the modulation type (QPSK /16QAM) is done instead of a detection of pilot symbols.

OFF | 0

The high speed channel can not be detected. A detection of pilot symbols is done instead a detection of the modulation type (QPSK /16QAM)

*RST: 1
Example:

SENS:CDP:HSDP OFF

Manual operation: See "HSDPA/UPA"


[SENSe:]CDPower:LCODe:SEARch[:IMMediate]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > [SENSe:]CDPower:LCODe:SEARch[:IMMediate]?
[SENSe:]CDPower:LCODe:SEARch[:IMMediate]?

This command automatically searches for the scrambling codes that lead to the highest signal power. The code with the highest power is stored as the new scrambling code for further measurements.

Searching requires that the correct center frequency and level are set. The scrambling code search can automatically determine the primary scrambling code number. The secondary scrambling code number is expected as 0. Alternative scrambling codes can not be detected. Therefore the range for detection is 0x0000 – 0x1FF0h, where the last digit is always 0.

If the search is successful (PASS), a code was found and can be queried using [SENSe:​]CDPower:​LCODe:​SEARch:​LIST?.

Parameters:
<Status> | PASSed Scrambling code(s) found. FAILed No scrambling code found.
Example: | SENS:CDP:LCOD:SEAR? Searches the scrambling code that leads to the highest signal power and returns the status of the search.
Usage: | Query only
Mode: | BTS application only
Manual operation: | See "Autosearch for Scrambling Code"


[SENSe:]CDPower:LCODe:SEARch:LIST?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > [SENSe:]CDPower:LCODe:SEARch:LIST?
[SENSe:]CDPower:LCODe:SEARch:LIST?

This command returns the automatic search sequence (see [SENSe:​]CDPower:​LCODe:​SEARch[:​IMMediate]?) as a comma-separated list of results for each detected scrambling code.

Return values:
<Code1>

Scrambling code in decimal format.

Range: 16 * n, with n = 0...511
<Code2>

Scrambling code in hexadecimal format.

Range: 0x0000h – 0x1FF0h, where the last digit is always 0
<CPICHPower>

Highest power value for the corresponding scrambling code.

Example:

SENS:CDP:LCOD:SEAR:LIST?

Result:

16,0×10,-18.04,32,0×20,-22.87,48,0×30,-27.62,64,0×40,-29.46

(Explanation in table below)

Usage: Query only
Mode: BTS application only
Manual operation: See "Scrambling Codes"
Description of query results in example:
Code (dec) | Code(hex) | CPICH power (dBm)
16 | 0x10 | -18.04
32 | 0x20 | -22.87
48 | 0x30 | -27.62
64 | 0x40 | -29.46


[SENSe:]CDPower:MIMO

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > [SENSe:]CDPower:MIMO
[SENSe:]CDPower:MIMO <State>

Activates or deactivates single antenna MIMO measurement mode.

Channels that have modulation type MIMO-QPSK or MIMO-16QAM are only recognized as active channels if this setting is ON.

For details see "MIMO".

Parameters:
<State>
ON | OFF
*RST: OFF
Example: SENS:CDP:MIMO ON
Mode: BTS application only
Manual operation: See "MIMO"


[SENSe:]CDPower:PCONtrol

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Signal Description > [SENSe:]CDPower:PCONtrol
[SENSe:]CDPower:PCONtrol <Position>

This command determines the power control measurement position. An enhanced channel search is used to consider the properties of compressed mode channels.

Parameters:
<Position>
SLOT | PILot
SLOT

The slot power is averaged from the beginning of the slot to the end of the slot.

PILot

The slot power is averaged from the beginning of the pilot symbols of the previous slot to the beginning of the pilot symbols of the current slot.

*RST: PILot
Example:

SENS:CDP:PCON SLOT

Switch to power averaging from slot start to the end of the slot. An enhanced channel search is used to consider the properties of compressed mode channels.

SENS:CDP:PCON PIL

Switch to power averaging from the pilot symbols of the previous slot number to the start of the pilots of the displayed slot number.

The channel search only considers standard channels.

Mode: BTS application only
Manual operation: See "Compressed Mode"


BTS Scrambling Code

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code
BTS Scrambling Code

The scrambling code identifies the base station transmitting the signal in BTS measurements.

List of Commands
[SENSe:]CDPower:LCODe:DVALue
[SENSe:]CDPower:LCODe[:VALue]


[SENSe:]CDPower:LCODe:DVALue

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code > [SENSe:]CDPower:LCODe:DVALue
[SENSe:]CDPower:LCODe:DVALue <ScramblingCode>

This command defines the scrambling code in decimal format.

Parameters:
<ScramblingCode>
<numeric value>
*RST: 0
Example:

SENS:CDP:LCOD:DVAL 3

Defines the scrambling code in decimal format.

Example:

See "Programming Examples (R&S FSW-K73)"

Manual operation: See "Scrambling Code"
See "Format Hex/Dec"
See "Format"


[SENSe:]CDPower:LCODe[:VALue]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > BTS Scrambling Code > [SENSe:]CDPower:LCODe[:VALue]
[SENSe:]CDPower:LCODe[:VALue] <ScramblingCode>

This command defines the scrambling code in hexadecimal format.

Parameters:
<ScramblingCode>
Range: | #H0 to #H1fff
*RST: | #H0
Example:

SENS:CDP:LCOD #H2

Defines the scrambling code in hexadecimal format.

Manual operation: See "Format Hex/Dec"
See "Scrambling Code"


UE Signal Description

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description
UE Signal Description

The following commands describe the input signal in UE measurements.

Useful commands for describing UE signals described elsewhere:
  • [SENSe:​]CDPower:​LCODe[:​VALue]
  • [SENSe:​]CDPower:​HSDPamode
Remote commands exclusive to describing UE signals:
List of Commands
[SENSe:]CDPower:LCODe:TYPE
[SENSe:]CDPower:QPSK
[SENSe:]CDPower:SFACtor


[SENSe:]CDPower:LCODe:TYPE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description > [SENSe:]CDPower:LCODe:TYPE
[SENSe:]CDPower:LCODe:TYPE <Type>

This command switches between long and short scrambling code.

Parameters:
<Type>
LONG | SHORt
*RST: LONG
Example:

CDP:LCOD:TYPE SHOR

Mode: UE application only
Manual operation: See "Type"


[SENSe:]CDPower:QPSK

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description > [SENSe:]CDPower:QPSK
[SENSe:]CDPower:QPSK <State>

If enabled, it is assumed that the signal uses QPSK modulation only. Thus, no synchronization is required and the measurement can be performed with optimized settings and speed.

Parameters:
<State>
ON | OFF
*RST: OFF
Mode: BTS application only
Manual operation: See "QPSK Modulation Only"


[SENSe:]CDPower:SFACtor

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Description > UE Signal Description > [SENSe:]CDPower:SFACtor
[SENSe:]CDPower:SFACtor <SpreadingFactor>

This command defines the spreading factor. The spreading factor is only significant for Peak Code Domain Error evaluation.

Parameters:
<SpreadingFactor>
4 | 8 | 16 | 32 | 64 | 128 | 256 | 512
*RST: 512
Example:

SENS:CDP:SFACtor 16


Configuring the Data Input and Output

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output
Configuring the Data Input and Output
Contents
  • RF Input
  • Remote Commands for the Digital Baseband Interface (R&S FSW-B17)
  • Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
  • Setting up Probes
  • Configuring the Outputs


RF Input

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

(For details on the status register see the R&S FSW User Manual).

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:CONNector

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input > INPut:CONNector
INPut:CONNector <ConnType>

Determines whether the RF input data is taken from the RF input connector or the optional Analog Baseband I connector. This command is only available if the Analog Baseband interface (R&S FSW-B71) is installed and active for input.

For more information see "Processing Data From the Analog Baseband Interface" .

Parameters:
<ConnType>
RF

RF input connector

AIQI

Analog Baseband I connector

*RST: RF
Example: INP:CONN:AIQI

Selects the analog baseband input.

Usage: SCPI confirmed
Manual operation: See "Input Connector"


INPut:COUPling

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

The command is not available for measurements with the Digital Baseband Interface (R&S FSW-B17).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

DIQ

Digital IQ data (only available with optional Digital Baseband Interface R&S FSW-B17)

For details on I/Q input see "Digital Input" .

AIQ

Analog Baseband signal (only available with optional Analog Baseband Interface R&S FSW-B71)

For details on Analog Baseband input see "Processing Data From the Analog Baseband Interface" .

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Radio Frequency State"
See "Digital I/Q Input State"
See "Analog Baseband Input State"


Remote Commands for the Digital Baseband Interface (R&S FSW-B17)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17)
Remote Commands for the Digital Baseband Interface (R&S FSW-B17)

The following commands are required to control the Digital Baseband Interface (R&S FSW-B17) in a remote environment.They are only available if this option is installed.

For more information on the Digital Baseband Interface see " Processing Data from the Digital Baseband Interface (-B17)" .

For more information on the Digital Baseband Interface see the R&S FSW I/Q Analyzer User Manual.

Information on the STATus:QUEStionable:DIQ register can be found in "STATus:QUEStionable:DIQ Register".

Contents
  • Configuring Digital I/Q Input and Output
  • STATus:QUEStionable:DIQ Register


Configuring Digital I/Q Input and Output

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output
Configuring Digital I/Q Input and Output
Remote commands for the R&S DigIConf software

Remote commands for the R&S DigIConf software always begin with SOURce:EBOX. Such commands are passed on from the R&S FSW to the R&S DigIConf automatically which then configures the R&S EX-IQ-BOX via the USB connection.

Be sure to connect the R&S EX-IQ-BOX to the R&S FSW via USB, not via LAN!

All remote commands available for configuration via the R&S DigIConf software are described in the "R&S®EX-IQ-BOX Digital Interface Module R&S®DigIConf Software Operating Manual".

Example 1:

SOURce:EBOX:*RST

SOURce:EBOX:*IDN?

Result:

"Rohde&Schwarz,DigIConf,02.05.436 Build 47"

Example 2:

SOURce:EBOX:USER:CLOCk:REFerence:FREQuency 5MHZ

Defines the frequency value of the reference clock.

Remote commands exclusive to digital I/Q data input and output
List of Commands
INPut:DIQ:CDEVice
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
OUTPut:DIQ
OUTPut:DIQ:CDEVice


INPut:DIQ:CDEVice

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:CDEVice
INPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q input from the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<SampleRate>

Maximum or currently used sample rate of the connected device in Hz (depends on the used connection protocol version; indicated by <SampleRateType> parameter)

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<SampleRateType>
0

Maximum sample rate is displayed

1

Current sample rate is displayed

<FullScaleLevel>

The level (in dBm) that should correspond to an I/Q sample with the magnitude "1" (if transferred from connected device);

If not available, 9.97e37 is returned

Example: INP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Connected Instrument"


INPut:DIQ:RANGe[:UPPer]:AUTO

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:AUTO <State>

If enabled, the digital input full scale level is automatically set to the value provided by the connected device (if available).

This command is only available if the optional Digital Baseband interface (option R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe:COUPling

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe:COUPling <State>

If enabled, the reference level for digital input is adjusted to the full scale level automatically if the full scale level changes.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Adjust Reference Level to Full Scale Level"


INPut:DIQ:RANGe[:UPPer]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer] <Level>

Defines or queries the "Full Scale Level", i.e. the level that corresponds to an I/Q sample with the magnitude "1".

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
<numeric value>
Range: | 1 μV to 7.071 V
*RST: | 1 V
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Full Scale Level"


INPut:DIQ:RANGe[:UPPer]:UNIT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:RANGe[:UPPer]:UNIT <Unit>

Defines the unit of the full scale level (see "Full Scale Level"). The availability of units depends on the measurement application you are using.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<Level>
VOLT | DBM | DBPW | WATT | DBMV | DBUV | DBUA | AMPere
*RST: Volt
Manual operation: See "Full Scale Level"


INPut:DIQ:SRATe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe
INPut:DIQ:SRATe <SampleRate>

This command specifies or queries the sample rate of the input signal from the Digital Baseband Interface (R&S FSW-B17, see "Input Sample Rate").

Parameters:
<SampleRate>
Range: | 1 Hz to 10 GHz
*RST: | 32 MHz
Example:

INP:DIQ:SRAT 200 MHz

Manual operation: See "Input Sample Rate"


INPut:DIQ:SRATe:AUTO

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > INPut:DIQ:SRATe:AUTO
INPut:DIQ:SRATe:AUTO <State>

If enabled, the sample rate of the digital I/Q input signal is set automatically by the connected device.

This command is only available if the optional Digital Baseband Interface (R&S FSW-B17) is installed.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Input Sample Rate"


OUTPut:DIQ

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > OUTPut:DIQ
OUTPut:DIQ <State>

This command turns continuous output of I/Q data to the optional Digital Baseband Interface (R&S FSW-B17) on and off.

Using the digital input and digital output simultaneously is not possible.

If digital baseband output is active, the sample rate is restricted to 100 MHz (200 MHz if enhanced mode is possible; max. 160 MHz bandwidth).

Parameters:
<State>
ON | OFF
*RST: OFF
Example: OUTP:DIQ ON
Example:

See "Converting an RF Signal to a Digital I/Q Signal via the Digital Baseband Interface (-B17)" .

Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Digital Baseband Output"


OUTPut:DIQ:CDEVice

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > Configuring Digital I/Q Input and Output > OUTPut:DIQ:CDEVice
OUTPut:DIQ:CDEVice

This command queries the current configuration and the status of the digital I/Q data output to the optional Digital Baseband Interface (R&S FSW-B17).

For details see "Interface Status Information" .

Return values:
<ConnState>

Defines whether a device is connected or not.

0

No device is connected.

1

A device is connected.

<DeviceName>

Device ID of the connected device

<SerialNumber>

Serial number of the connected device

<PortName>

Port name used by the connected device

<NotUsed>

to be ignored

<MaxTransferRate>

Maximum data transfer rate of the connected device in Hz

<ConnProtState>

State of the connection protocol which is used to identify the connected device.

Not Started
Has to be Started
Started
Passed
Failed
Done
<PRBSTestState>

State of the PRBS test.

Not Started
Has to be Started
Started
Passed
Failed
Done
<NotUsed>

to be ignored

<Placeholder>

for future use; currently "0"

Example: OUTP:DIQ:CDEV?

Result:

1,SMU200A,103634,Out A,70000000,100000000,Passed,Not Started,0,0
Example:

See "Output via the Optional Digital Baseband Interface (-B17)" .

Manual operation: See "Output Settings Information"
See "Connected Instrument"


STATus:QUEStionable:DIQ Register

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register
STATus:QUEStionable:DIQ Register

This register contains information about the state of the digital I/Q input and output. This register is available with option Digital Baseband Interface (R&S FSW-B17)Digital Baseband Interface (R&S FSW-B17).

The status of the STATus:QUESTionable:DIQ register is indicated in bit 14 of the STATus:QUESTionable register.

You can read out the state of the register with STATus:​QUEStionable:​DIQ:​CONDition? and STATus:​QUEStionable:​DIQ[:​EVENt]?.

Bit No.

Meaning

0

Digital I/Q Input Device connected

This bit is set if a device is recognized and connected to the Digital Baseband Interface of the analyzer.

1

Digital I/Q Input Connection Protocol in progress

This bit is set while the connection between analyzer and digital baseband data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

2

Digital I/Q Input Connection Protocol error

This bit is set if an error occurred during establishing of the connect between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

3

Digital I/Q Input PLL unlocked

This bit is set if the PLL of the Digital I/Q input is out of lock due to missing or unstable clock provided by the connected Digital I/Q TX device. To solve the problem the Digital I/Q connection has to be newly initialized after the clock has been restored.

4

Digital I/Q Input DATA Error

This bit is set if the data from the Digital I/Q input module is erroneous. Possible reasons:

  • Bit errors in the data transmission. The bit will only be set if an error occurred at the current measurement.
  • Protocol or data header errors. May occurred at data synchronization problems or vast transmission errors. The bit will be set constantly and all data will be erroneous. To solve the problem the Digital I/Q connection has to be newly initialized.

NOTE: If this error is indicated repeatedly either the Digital I/Q LVDS connection cable or the receiving or transmitting device might be defect.

5

not used

6

Digital I/Q Input FIFO Overload

This bit is set if the sample rate on the connected instrument is higher than the input sample rate setting on the R&S FSW. Possible solution:

  • Reduce the sample rate on the connected instrument
  • Increase the input sample rate setting on the R&S FSW

7

not used

8

Digital I/Q Output Device connected

This bit is set if a device is recognized and connected to the Digital I/Q Output.

9

Digital I/Q Output Connection Protocol in progress

This bit is set while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

10

Digital I/Q Output Connection Protocol error

This bit is set if an error occurred while the connection between analyzer and digital I/Q data signal source (e.g. R&S SMU, R&S Ex-I/Q-Box) is established.

11

Digital I/Q Output FIFO Overload

This bit is set if an overload of the Digital I/Q Output FIFO occurred. This happens if the output data rate is higher than the maximal data rate of the connected instrument. Reduce the sample rate to solve the problem.

12-14

not used

15

This bit is always set to 0.

List of Commands
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?


STATus:QUEStionable:DIQ:CONDition?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:CONDition? <ChannelName>

This command reads out the CONDition section of the STATus:QUEStionable:DIQ:CONDition status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ:COND?
Usage: | Query only


STATus:QUEStionable:DIQ:ENABle

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<SumBit>
Range: 0 to 65535
Usage: SCPI confirmed


STATus:QUEStionable:DIQ:NTRansition

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ:PTRansition

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ:PTRansition <BitDefinition>,<ChannelName>

This command controls the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.

Setting parameters:
<BitDefinition>
Range: 0 to 65535


STATus:QUEStionable:DIQ[:EVENt]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Remote Commands for the Digital Baseband Interface (R&S FSW-B17) > STATus:QUEStionable:DIQ Register > STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:DIQ[:EVENt]? <ChannelName>

This command queries the contents of the "EVENt" section of the STATus:QUEStionable:DIQ register for IQ measurements.

Readout deletes the contents of the "EVENt" section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Example: | STAT:QUES:DIQ?
Usage: | Query only


Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71)
Configuring Input via the Analog Baseband Interface (R&S FSW-B71)

The following commands are required to control the Analog Baseband Interface (R&S FSW-B71) in a remote environment.They are only available if this option is installed.

For more information on the Analog Baseband Interface see "Processing Data From the Analog Baseband Interface" .

Useful commands for Analog Baseband data described elsewhere:
  • INP:SEL AIQ (see INPut:​SELect)
  • [SENSe:​]FREQuency:​CENTer
For calibration:
  • DIAGnostic:​SERVice:​INPut[:​SELect]
  • DIAGnostic:​SERVice:​INPut:​AIQ[:​TYPE]
Remote commands exclusive to Analog Baseband data input and output
List of Commands
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
[SENSe:]PROBe<ch>:SETup:CMOFfset
TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?


INPut:IQ:BALanced[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:BALanced[:STATe]
INPut:IQ:BALanced[:STATe] <State>

This command defines whether the input is provided as a differential signal via all 4 Analog Baseband connectors or as a plain I/Q signal via 2 simple-ended lines.

Parameters:
<State>
ON

Differential

OFF

Simple-ended

*RST: ON
Example: INP:IQ:BAL OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Input configuration"


INPut:IQ:FULLscale:AUTO

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale:AUTO <State>

This command defines whether the full scale level (i.e. the maximum input power on the Baseband Input connector) is defined automatically according to the reference level, or manually.

Parameters:
<State>
ON

Automatic definition

OFF

Manual definition according to INPut:​IQ:​FULLscale[:​LEVel]

*RST: ON
Example: INP:IQ:FULL:AUTO OFF
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:FULLscale[:LEVel]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:FULLscale[:LEVel]
INPut:IQ:FULLscale[:LEVel] <PeakVoltage>

This command defines the peak voltage at the Baseband Input connector if the full scale level is set to manual mode (see INPut:​IQ:​FULLscale:​AUTO).

Parameters:
<PeakVoltage>
0.25 V | 0.5 V | 1 V | 2 V

Peak voltage level at the connector.

For probes, the possible full scale values are adapted according to the probe's attenuation and maximum allowed power.

*RST: 1V
Example: INP:IQ:FULL 0.5V
Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "Full Scale Level Mode / Value"


INPut:IQ:TYPE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > INPut:IQ:TYPE
INPut:IQ:TYPE <DataType>

This command defines the format of the input signal.

Parameters:
<DataType>
IQ | I | Q
IQ

The input signal is filtered and resampled to the sample rate of the application.

Two input channels are required for each input signal, one for the in-phase component, and one for the quadrature component.

I

The in-phase component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0 (see [SENSe:​]FREQuency:​CENTer), the in-phase component of the input signal is down-converted first (Low IF I).

Q

The quadrature component of the input signal is filtered and resampled to the sample rate of the application. If the center frequency is not 0, the quadrature component of the input signal is down-converted first (Low IF Q).

*RST: IQ
Example:

INP:IQ:TYPE Q

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Manual operation: See "I/Q Mode"


CALibration:AIQ:DCOFfset:I

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:I <Offset>

This command defines a DC offset of the I input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:I 0.001


CALibration:AIQ:DCOFfset:Q

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > CALibration:AIQ:DCOFfset:Q
CALibration:AIQ:DCOFfset:Q <Offset>

This command defines a DC offset of the Q input from the Analog Baseband interface (R&S FSW-B71).

Parameters:
<Offset>
numeric value

DC offset

*RST: | 0
Default unit: | V
Example: CAL:AIQ:DCOF:Q 0.001


[SENSe:]PROBe<ch>:SETup:CMOFfset

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > [SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<ch>:SETup:CMOFfset <CMOffset>

Sets the common mode offset. The setting is only available if a differential probe is connected to the R&S FSW.

If the probe is disconnected, the common mode offset of the probe is reset to 0.0 V.

For details see "Common Mode Offset" .

Suffix:
<ch>
1..4

Selects the input channel.

Parameters:
<CMOffset>
Range: | -100E+24 to 100E+24
Increment: | 1E-3
*RST: | 0
Default unit: | V


TRACe:IQ:APCon[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon[:STATe]
TRACe:IQ:APCon[:STATe] <State>

If enabled, the average power consumption is calculated at the end of the I/Q data measurement. This command must be set before the measurement is performed!

The conversion factors A and B for the calculation are defined using TRACe:​IQ:​APCon:​A and TRACe:​IQ:​APCon:​B.

The results can be queried using TRACe:​IQ:​APCon:​RESult?.

For details see "Average Power Consumption" .

Parameters:
<State>
ON | OFF
*RST: OFF
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:A

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:A
TRACe:IQ:APCon:A <ConvFact>

Defines the conversion factor A for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 1.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:B

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:B
TRACe:IQ:APCon:B <ConvFact>

Defines the conversion factor B for the calculation of the average power consumption.

For details see "Average Power Consumption" .

Parameters:
<ConvFact>
numeric value
*RST: 0.0
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?


TRACe:IQ:APCon:RESult?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring Input via the Analog Baseband Interface (R&S FSW-B71) > TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon:RESult?

Queries the average power consumption for an analog baseband input. This value is only calculated at the end of the I/Q data measurement if the TRACe:​IQ:​APCon[:​STATe] command is set to ON before the measurement is performed!

For details see "Average Power Consumption" .

Parameters:
<Average>
numeric value
Default unit: W
Example:
*RST
TRAC:IQ:STAT ON
TRAC:IQ:SRAT 1MHZ
TRAC:IQ:RLEN 1000000
TRAC:IQ:APC:STAT ON
TRAC:IQ:APC:A 3.0
TRAC:IQ:APC:B 0.6
INIT;*WAI
TRAC:IQ:APC:RES?
Usage: Query only


Setting up Probes

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Setting up Probes
Setting up Probes

Probes can be connected to the optional BASEBAND INPUT connectors, if the Analog Baseband interface ( option R&S FSW-B71) is installed.

List of Commands
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?


[SENSe:]PROBe<p>:ID:PARTnumber?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:PARTnumber?

Queries the R&S part number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<PartNumber> | Part number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:ID:SRNumber?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:ID:SRNumber?

Queries the serial number of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<SerialNo> | Serial number in a string.
Usage: | Query only


[SENSe:]PROBe<p>:SETup:MODE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:MODE <Mode>

Select the action that is started with the micro button on the probe head.

See also: "Microbutton Action".

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Parameters:
<Mode>
RSINgle

Run single: starts one data acquisition.

NOACtion

Nothing is started on pressing the micro button.

*RST: RSINgle
Manual operation: See "Microbutton Action"


[SENSe:]PROBe<p>:SETup:NAME?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:NAME?

Queries the name of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Name> | Name string
Usage: | Query only


[SENSe:]PROBe<p>:SETup:STATe?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:STATe?

Queries if the probe at the specified connector is active (detected) or not active (not detected). To switch the probe on, i.e. activate input from the connector, use INP:SEL:AIQ (see INPut:​SELect).

Suffix:
<p>
1 | 2 | 3

Selects the connector:

1 = Baseband Input I

2 = Baseband Input Q

3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")

Return values:
<State>
DETected | NDETected
*RST: NDETected
Usage: Query only


[SENSe:]PROBe<p>:SETup:TYPE?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Setting up Probes > [SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]PROBe<p>:SETup:TYPE?

Queries the type of the probe.

Suffix: |
<p> | 1 | 2 | 3 Selects the connector: 1 = Baseband Input I 2 = Baseband Input Q 3 = RF (currently not supported; use "1" with RF Input Connector setting "Baseband Input I")
Return values:
<Type> | String containing one of the following values: – None (no probe detected) – active differential – active single-ended
Usage: | Query only


Configuring the Outputs

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce
OUTPut:IF:IFFRequency


DIAGnostic:SERVice:NSOurce

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


OUTPut:IF:IFFRequency

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring the Data Input and Output > Configuring the Outputs > OUTPut:IF:IFFRequency
OUTPut:IF:IFFRequency <Frequency>

This command defines the frequency for the IF output. The IF frequency of the signal is converted accordingly.

This command is available in the time domain and if the IF/VIDEO/DEMOD output is configured for IF.

Parameters:
<Frequency>
*RST: 50.0 MHz


Frontend Configuration

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration
Frontend Configuration

The following commands configure frequency, amplitude and y-axis scaling settings, which represent the "frontend" of the measurement setup.

Contents
  • Frequency
  • Amplitude Settings
  • Configuring the Attenuation


Frequency

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center Frequency"
See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:OFFSet

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Note: In MSRA mode, the setting command is only available for the MSRA Master. For MSRA applications, only the query command is available.

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Amplitude Settings

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings
Amplitude Settings

The following commands are required to configure the amplitude settings in a remote environment.

Useful commands for amplitude settings described elsewhere:
  • INPut:​COUPling
  • INPut:​IMPedance
  • [SENSe:​]ADJust:​LEVel
Remote commands exclusive to amplitude settings:
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
INPut:GAIN:STATe
INPut:GAIN[:VALue]


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE

Automatic scaling of the y-axis is performed once, then switched off again.

Usage: | SCPI confirmed
Manual operation: | See "Auto Scale Once"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Maximum, Y-Minimum"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Y-Maximum, Y-Minimum"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division

(For example 10 dB in the Code Domain Power result display.)


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


INPut:GAIN:STATe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

This function is not available for input from the Digital Baseband Interface (R&S FSW-B17).

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the preamplification is defined by INPut:​GAIN[:​VALue].

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Amplitude Settings > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Configuring the Attenuation

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Configuring the Attenuation
Configuring the Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Configuring the Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

This function is not available if the Digital Baseband Interface (R&S FSW-B17) is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Frontend Configuration > Configuring the Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

This command is only available with option R&S FSW-B25.

It is not available if R&S FSW-B17 is active.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring Triggered Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements
Configuring Triggered Measurements

The following commands are required to configure a triggered measurement in a remote environment. The tasks for manual operation are described in "Trigger Settings".

The *OPC command should be used after commands that retrieve data so that subsequent commands to change the selected trigger source are held off until after the sweep is completed and the data has been returned.

Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


TRIGger[:SEQuence]:BBPower:HOLDoff

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:BBPower:HOLDoff <Period>

This command defines the holding time before the baseband power trigger event.

The command requires the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Period>
Range: | 150 ns to 1000 s
*RST: | 150 ns
Example: TRIG:SOUR BBP

Sets the baseband power trigger source.

TRIG:BBP:HOLD 200 ns

Sets the holding time to 200 ns.


TRIGger[:SEQuence]:DTIMe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

For input from the Analog Baseband Interface (R&S FSW-B71) using the baseband power trigger (BBP), the default drop out time is set to 100 ns to avoid unintentional trigger events (as no hysteresis can be configured in this case).

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Note: If you perform gated measurements in combination with the IF Power trigger, the R&S FSW ignores the holding time for frequency sweep, FFT sweep, zero span and I/Q data measurements.

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel:BBPower

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:BBPower <Level>

This command sets the level of the baseband power trigger.

This command is available for the Digital Baseband Interface (R&S FSW-B17) and the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<Level>
Range: | -50 dBm to +20 dBm
*RST: | -20 dBm
Example: TRIG:LEV:BB -30DBM
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Note that the variable INPUT/OUTPUT connectors (ports 2+3) must be set for use as input using the OUTPut:​TRIGger<port>:​DIRection command.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IFPower

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

For compatibility reasons, this command is also available for the "baseband power" trigger source when using the Analog Baseband Interface (R&S FSW-B71).

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .


TRIGger[:SEQuence]:LEVel:IQPower

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .


TRIGger[:SEQuence]:LEVel:RFPower

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:LEVel:VIDeo

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:LEVel:VIDeo <Level>

This command defines the level the video signal must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<Level>
Range: | 0 PCT to 100 PCT
*RST: | 50 PCT
Example: TRIG:LEV:VID 50PCT


TRIGger[:SEQuence]:SLOPe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

(Frequency and time domain measurements only.)

Not available for input from the Digital Baseband Interface (R&S FSW-B17) or the Analog Baseband Interface (R&S FSW-B71).

IFPower

Second intermediate frequency

(For frequency and time domain measurements only.)

Not available for input from the Digital Baseband Interface (R&S FSW-B17). For input from the Analog Baseband Interface (R&S FSW-B71), this parameter is interpreted as BBPower for compatibility reasons.

TIME

Time interval

(For frequency and time domain measurements only.)

PSEN

External power sensor

(For frequency and time domain measurements only.)

GP0 | GP1 | GP2 | GP3 | GP4 | GP5

For applications that process I/Q data, such as the I/Q Analyzer or optional applications, and only if the Digital Baseband Interface (R&S FSW-B17) is available.

Defines triggering of the measurement directly via the LVDS connector. The parameter specifies which general purpose bit (0 to 5) will provide the trigger data.

The assignment of the general purpose bits used by the Digital IQ trigger to the LVDS connector pins is provided in "Digital I/Q".

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "Digital I/Q"
See "IF Power"


TRIGger[:SEQuence]:TIME:RINTerval

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:TIME:RINTerval
TRIGger[:SEQuence]:TIME:RINTerval <Interval>

This command defines the repetition interval for the time trigger.

Parameters:
<Interval>
2.0 ms to 5000
Range: | 2 ms to 5000 s
*RST: | 1.0 s
Example: TRIG:SOUR TIME

Selects the time trigger input for triggering.

TRIG:TIME:RINT 50

The sweep starts every 50 s.


Configuring the Trigger Output

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Configuring Triggered Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Signal Capturing

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Capturing
Signal Capturing

The following commands are required to configure how much and how data is captured from the input signal.

MSRA operating mode

In MSRA operating mode, only the MSRA Master channel actually captures data from the input signal. The data acquisition settings for the 3GPP FDD application in MSRA mode define the application data (see "Configuring the Application Data Range (MSRA mode only)").

For details on the MSRA operating mode see "Applications and Operating Modes" .

Useful commands for configuring data acquisition described elsewhere:
  • [SENSe:​]CDPower:​FRAMe[:​VALue]
Remote commands exclusive to signal capturing:
List of Commands
[SENSe:]CDPower:BASE
[SENSe:]CDPower:FILTer[:STATe]
[SENSe:]CDPower:IQLength
[SENSe:]CDPower:QINVert
[SENSe:]CDPower:SBANd


[SENSe:]CDPower:BASE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Capturing > [SENSe:]CDPower:BASE
[SENSe:]CDPower:BASE <BaseValue>

This command defines the base of the CDP analysis.

Parameters:
<BaseValue>
SLOT | FRAMe
SLOT

Only one slot of the signal is analyzed.

FRAMe

The complete 3GPP frame is analyzed.

*RST: FRAMe
Example:

CDP:BASE SLOT

Manual operation: See "Capture Mode"


[SENSe:]CDPower:FILTer[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Capturing > [SENSe:]CDPower:FILTer[:STATe]
[SENSe:]CDPower:FILTer[:STATe] <State>

This command selects if a root raised cosine (RRC) receiver filter is used or not. This feature is useful if the RRC filter is implemented in the device under test (DUT).

Parameters:
<State>
ON | 1

If an unfiltered signal is received (normal case), the RRC filter should be used to get a correct signal demodulation.

OFF | 0

If a filtered signal is received, the RRC filter should not be used to get a correct signal demodulation. This is the case if the DUT filters the signal.

*RST: 1
Example:

SENS:CDP:FILT:STAT OFF

Manual operation: See "RRC Filter State"


[SENSe:]CDPower:IQLength

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Capturing > [SENSe:]CDPower:IQLength
[SENSe:]CDPower:IQLength <CaptureLength>

This command specifies the number of frames that are captured by one sweep.

Parameters:
<CaptureLength>
Range: | 1 to 100
*RST: | 1
Example:

SENS:CDP:IQLength 3

Manual operation: See "Capture Length (Frames)"


[SENSe:]CDPower:QINVert

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Capturing > [SENSe:]CDPower:QINVert
[SENSe:]CDPower:QINVert <State>

This command inverts the Q-branch of the signal.

Parameters:
ON | OFF
*RST: OFF
Example: CDP:QINV ON

Activates inversion of Q-branch

Example:

See "Measurement 5: Measuring the Composite EVM" .

Manual operation: See "Invert Q"


[SENSe:]CDPower:SBANd

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Signal Capturing > [SENSe:]CDPower:SBANd
[SENSe:]CDPower:SBANd <NORMal | INVers>

This command is used to swap the left and right sideband.

Parameters:
<NORMal | INVers>
*RST: NORM
Example: CDP:SBAN INV

Switches the right and left sideband.


Synchronization

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Synchronization
Synchronization

For BTS tests, the individual channels in the input signal need to be synchronized to detect timing offsets in the slot spacings. These commands are described here. they are only available in the 3GPP FDD BTS application

Useful commands for synchronization described elsewhere:
  • [SENSe:​]CDPower:​ANTenna
Remote commands exclusive to synchronization:
List of Commands
[SENSe:]CDPower:UCPich:ANT<antenna>:CODE
[SENSe:]CDPower:UCPich:ANT<antenna>:PATTern
[SENSe:]CDPower:UCPich:ANT<antenna>[:STATe]
[SENSe:]CDPower:STYPe


[SENSe:]CDPower:UCPich:ANT<antenna>:CODE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Synchronization > [SENSe:]CDPower:UCPich:ANT<antenna>:CODE
[SENSe:]CDPower:UCPich:ANT<antenna>:CODE <CodeNumber>

This command sets the code number of the user defined CPICH used for signal analysis.

Note: this command is equivalent to the command [SENSe:​]CDPower:​UCPich:​CODE for antenna 1.

Suffix:
<antenna>
1 | 2

Antenna to be configured

Parameters:
<CodeNumber>
Range: | 0 to 225
*RST: | 0
Example:

SENS:CDP:UCP:ANT2:CODE 10

Mode: BTS application only
Manual operation: See "S-CPICH Code Nr"


[SENSe:]CDPower:UCPich:ANT<antenna>:PATTern

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Synchronization > [SENSe:]CDPower:UCPich:ANT<antenna>:PATTern
[SENSe:]CDPower:UCPich:ANT<antenna>:PATTern <Pattern>

This command defines which pattern is used for signal analysis for the user-defined CPICH (see [SENSe:​]CDPower:​UCPich:​ANT<antenna>[:​STATe]).

Note: this command is equivalent to the command [SENSe:​]CDPower:​UCPich:​PATTern for antenna 1.

Suffix:
<antenna>
1 | 2

Antenna to be configured

Parameters:
<Pattern>
1 | 2
1

fixed usage of "Pattern 1" according to standard

2

fixed usage of "Pattern 2" according to standard

*RST: 2
Example:

SENS:CDP:UCP:ANT2:PATT 1

Mode: BTS application only
Manual operation: See "S-CPICH Antenna Pattern"


[SENSe:]CDPower:UCPich:ANT<antenna>[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Synchronization > [SENSe:]CDPower:UCPich:ANT<antenna>[:STATe]
[SENSe:]CDPower:UCPich:ANT<antenna>[:STATe] <State>

Defines whether the common pilot channel (CPICH) is defined by a user-defined position instead of its default position.

Note: this command is equivalent to the command [SENSe:​]CDPower:​UCPich[:​STATe] for antenna 1.

Suffix:
<antenna>
1 | 2

Antenna to be configured

Parameters:
<State>
0

Standard configuration (CPICH is always on channel 0)

1

User-defined configuration, position defined using [SENSe:​]CDPower:​UCPich:​ANT<antenna>:​CODE.

*RST: 0
Example:

SENS:CDP:CPIC:ANT2:STAT 1

Mode: BTS application only
Manual operation: See "CPICH Mode"


[SENSe:]CDPower:STYPe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Synchronization > [SENSe:]CDPower:STYPe
[SENSe:]CDPower:STYPe <Type>

This command selects the type of synchronization.

Parameters:
<Type>
CPICh | SCHannel
CPICh

Synchronization is carried out to CPICH. For this type of synchronization, the CPICH must be available in the input signal.

SCHannel

Synchronization is carried out without CPICh. This type of synchronization is required for test model 4 without CPICH.

*RST: CPICh
Example:

SENS:CDP:STYP SCH

Mode: BTS application only
Manual operation: See "Synchronization Type"


Channel Detection

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection
Channel Detection

The channel detection settings determine which channels are found in the input signal. The commands for working with channel tables are described here.

When the channel type is required as a parameter by a remote command or provided as a result for a remote query, the following abbreviations and assignments to a numeric value are used:

BTS channel types and their assignment to a numeric parameter value
Param. | Channel type | Description
0 | DPCH | Dedicated Physical Channel of a standard frame
1 | PICH | Paging Indication Channel
2 | CPICH | Common Pilot Channel
3 | PSCH | Primary Synchronization Channel
4 | SSCH | Secondary Synchronization Channel
5 | PCCPCH | Primary Common Control Physical Channel
6 | SCCPCH | Secondary Common Control Physical Channel
7 | HS_SCCH | HSDPA: High Speed Shared Control Channel
8 | HS_PDSCH | HSDPA: High Speed Physical Downlink Shared Channel
9 | CHAN | Channel without any pilot symbols (QPSK modulated)
10 | CPRSD | Dedicated Physical Channel in compressed mode
11 | CPR-TPC | Dedicated Physical Channel in compressed mode TPC symbols are sent in the first slot of the gap.
12 | CPR-SF/2 | Dedicated Physical Channel in compressed mode using half spreading factor (SF/2).
13 | CPR-SF/2-TPC | Dedicated Physical Channel in compressed mode using half spreading factor (SF/2). TPC symbols are sent in the first slot of the gap.
14 | EHICH-ERGCH | HSUPA: Enhanced HARQ Hybrid Acknowledgement Indicator Channel HSUPA: Enhanced Relative Grant Channel
15 | EAGCH | E-AGCH: Enhanced Absolute Grant Channel
16 | SCPICH | Secondary Common Pilot Channel
UE channel types and their assignment to a numeric parameter value
Param. | Channel type | Description
0 | DPDCH | Dedicated Physical Data Channel
1 | DPCCH | Dedicated Physical Control Channel
2 | HS-DPCCH | High-Speed Dedicated Physical Control Channel
3 | E-DPCCH | Enhanced Dedicated Physical Control Channel
4 | E_DPDCH | Enhanced Dedicated Physical Data Channel
Contents
  • General Channel Detection
  • Managing Channel Tables
  • Configuring Channel Tables
  • Configuring Channel Details (BTS Measurements)
  • Configuring Channel Details (UE Measurements)


General Channel Detection

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection
General Channel Detection

The following commands configure how channels are detected in general.

Useful commands for general channel detection described elsewhere:
  • CONFigure:​WCDPower[:​BTS]:​CTABle[:​STATe]
  • CONFigure:​WCDPower[:​BTS]:​CTABle:​SELect
  • CONFigure:​WCDPower:​MS:​CTABle[:​STATe]
  • CONFigure:​WCDPower:​MS:​CTABle:​SELect
Remote commands exclusive to general channel detection:
List of Commands
CONFigure:WCDPower[:BTS]:CTABle:COMPare
CONFigure:WCDPower[:BTS]:CTABle:TOFFset
[SENSe:]CDPower:ICTReshold


CONFigure:WCDPower[:BTS]:CTABle:COMPare

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection > CONFigure:WCDPower[:BTS]:CTABle:COMPare
CONFigure:WCDPower[:BTS]:CTABle:COMPare <State>

This command switches between normal predefined mode and predefined channel table compare mode.

In the compare mode a predefined channel table model can be compared with the measurement in respect to power, pilot length and timing offset of the active channels.

Comparision is a submode of predefined channel table measurement. It only influences the measurement if the "Channel Search Mode" is set to Predefined (see CONFigure:​WCDPower[:​BTS]:​CTABle[:​STATe]). If the compare mode is selected, the power values, pilot lengths and timing offsets are measured and are compared with the values from the predefined channel table. The "Timing Offset" setting is disabled in this case. The differences between the measured and the predefined values are visualized in the corresponding columns of the "CHANNEL TABLE" evaluation (see "Channel Table"). The following columns are displayed in the channel table:

  • PilotL is the substraction of PilotLengthMeasured - PilotLengthPredefined
  • PwrRel is the substraction of PowerRelMeasured - PowerRelPredefined
  • T Offs is the substraction of TimingOffsetMeasured - TimingOffsetPredefined

For non-active channels dashes are shown.

Parameters:
<State>
ON | OFF
ON

predefined channel table compare mode

OFF

normal predefined mode

*RST: OFF
Example:

CONF:WCDP:CTAB:COMP ON

Mode: BTS application only
Manual operation: See "Comparing the Measurement Signal with the Predefined Channel Table"


CONFigure:WCDPower[:BTS]:CTABle:TOFFset

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection > CONFigure:WCDPower[:BTS]:CTABle:TOFFset
CONFigure:WCDPower[:BTS]:CTABle:TOFFset <Mode>

This command specifies whether the timing offset and pilot length are measured or if the values are taken from the predefined table.

Parameters:
<Mode> | PRED | MEAS PRED The timing offset and pilot length values from the predefined table are used. MEAS The timing offset and the pilot length are measured by the application. The channel configuration is specified via the predefined channel table.
Example: | CONF:WCDP:CTAB:TOFF MEAS
Mode: | BTS application only
Manual operation: | See "Timing Offset Reference"


[SENSe:]CDPower:ICTReshold

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > General Channel Detection > [SENSe:]CDPower:ICTReshold
[SENSe:]CDPower:ICTReshold <ThresholdLevel>

This command defines the minimum power that a single channel must have compared to the total signal in order to be regarded as an active channel. Channels below the specified threshold are regarded as "inactive".

Parameters:
<ThresholdLevel>
Range: | -100 dB to 0 dB
*RST: | -60 dB
Example:

SENS:CDP:ICTR -100

Mode: BTS application only
Manual operation: See "Inactive Channel Threshold (BTS measurements only)"


Managing Channel Tables

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables
Managing Channel Tables
List of Commands
CONFigure:WCDPower[:BTS]:CTABle[:STATe]
CONFigure:WCDPower[:BTS]:CTABle:CATalog?
CONFigure:WCDPower[:BTS]:CTABle:COPY
CONFigure:WCDPower[:BTS]:CTABle:DELete
CONFigure:WCDPower[:BTS]:CTABle:SELect
CONFigure:WCDPower:MS:CTABle[:STATe]
CONFigure:WCDPower:MS:CTABle:CATalog?
CONFigure:WCDPower:MS:CTABle:COPY
CONFigure:WCDPower:MS:CTABle:DELete
CONFigure:WCDPower:MS:CTABle:SELect


CONFigure:WCDPower[:BTS]:CTABle[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower[:BTS]:CTABle[:STATe]
CONFigure:WCDPower[:BTS]:CTABle[:STATe] <State>

This command switches the channel table on or off. When switched on, the measured channel table is stored under the name "RECENT" and is selected for use. After the "RECENT" channel table is switched on, another channel table can be selected with the command CONFigure:​WCDPower[:​BTS]:​CTABle:​SELect.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CONF:WCDP:CTAB ON

Mode: BTS application only
Manual operation: See "Using Predefined Channel Tables"


CONFigure:WCDPower[:BTS]:CTABle:CATalog?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower[:BTS]:CTABle:CATalog?
CONFigure:WCDPower[:BTS]:CTABle:CATalog?

This command reads out the names of all channel tables stored on the instrument. The first two result values are global values for all channel tables, the subsequent values are listed for each individual table.

Return values:
<TotalSize> | Sum of file sizes of all channel table files (in bytes)
<FreeMem> | Available memory left on hard disk (in bytes)
<FileName> | File name of individual channel table file
<FileSize> | File size of individual channel table file (in bytes)
Example: | CONF:WCDP:CTAB:CAT? Sample result (description see table below): 52853,2634403840,3GB_1_16.XML,3469,3GB_1_32.XML,5853,3GB_1_64.XML,10712,3GB_2.XML,1428,3GB_3_16.XML,3430,3GB_3_32.XML,5868,3GB_4.XML,678,3GB_5_2.XML,2554,3GB_5_4.XML,4101,3GB_5_8.XML,7202,3GB_6.XML,7209,MYTABLE.XML,349
Usage: | Query only
Mode: | BTS application only
Manual operation: | See "Predefined Tables"
Description of query results in example:
Value | Description
52853 | Total size of all channel table files: 52583 bytes
2634403840 | Free memory on hard disk: 2.6 Gbytes
3GB_1_16.XML | Channel table 1: 3GB_1_16.XML
3469 | File size for channel table 1: 3469 bytes
3GB_1_32.XML | Channel table 2: 3GB_1_32.XML
5853 | File size for channel table 2: 5853 bytes
3GB_1_64.XML | Channel table 3: 3GB_1_64.XML
10712 | File size for channel table 3: 10712 bytes
... | Channel table x: ...


CONFigure:WCDPower[:BTS]:CTABle:COPY

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower[:BTS]:CTABle:COPY
CONFigure:WCDPower[:BTS]:CTABle:COPY <FileName>

This command copies one channel table onto another one. The channel table to be copied is selected with command CONFigure:​WCDPower[:​BTS]:​CTABle:​NAME.

The name of the channel table may contain a maximum of 8 characters.

Parameters:
<FileName> | name of the new channel table
Example: | CONF:WCDP:CTAB:NAME 'NEW_TAB' Defines the channel table name to be copied. CONF:WCDP:CTAB:COPY 'CTAB_2' Copies channel table 'NEW_TAB' to 'CTAB_2'.
Usage: | Event
Mode: | BTS application only
Manual operation: | See "Copying a Table"


CONFigure:WCDPower[:BTS]:CTABle:DELete

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower[:BTS]:CTABle:DELete
CONFigure:WCDPower[:BTS]:CTABle:DELete

This command deletes the selected channel table. The channel table to be deleted is selected with the command CONFigure:​WCDPower[:​BTS]:​CTABle:​NAME.

Example: | CONF:WCDP:CTAB:NAME 'NEW_TAB' Defines the channel table name to be deleted. CONF:WCDP:CTAB:DEL Deletes the table.
Mode: | BTS application only
Manual operation: | See "Deleting a Table"


CONFigure:WCDPower[:BTS]:CTABle:SELect

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower[:BTS]:CTABle:SELect
CONFigure:WCDPower[:BTS]:CTABle:SELect <FileName>

This command selects a predefined channel table file for comparison during channel detection. Before using this command, the "RECENT" channel table must be switched on first with the command CONFigure:​WCDPower[:​BTS]:​CTABle[:​STATe].

Parameters:
<FileName>
*RST: RECENT
Example: CONF:WCDP:CTAB ON

Switches the channel table on.

CONF:WCDP:CTAB:SEL 'CTAB_1'

Selects the predefined channel table 'CTAB_1'.

Mode: BTS application only
Manual operation: See "Selecting a Table"


CONFigure:WCDPower:MS:CTABle[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower:MS:CTABle[:STATe]
CONFigure:WCDPower:MS:CTABle[:STATe] <State>

This command switches the channel table on or off. When switched on, the measured channel table is stored under the name "RECENT" and is selected for use. After the "RECENT" channel table is switched on, another channel table can be selected with the command CONFigure:​WCDPower:​MS:​CTABle:​SELect.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CONF:WCDP:CTAB ON

Mode: UE application only
Manual operation: See "Using Predefined Channel Tables"


CONFigure:WCDPower:MS:CTABle:CATalog?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower:MS:CTABle:CATalog?
CONFigure:WCDPower:MS:CTABle:CATalog?

This command reads out the names of all channel tables stored on the instrument. The first two result values are global values for all channel tables, the subsequent values are listed for each individual table.

Return values:
<TotalSize> | Sum of file sizes of all channel table files (in bytes)
<FreeMem> | Available memory left on hard disk (in bytes)
<FileName> | File name of individual channel table file
<FileSize> | File size of individual channel table file (in bytes)
Usage: | Query only
Mode: | UE application only
Manual operation: | See "Predefined Tables"


CONFigure:WCDPower:MS:CTABle:COPY

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower:MS:CTABle:COPY
CONFigure:WCDPower:MS:CTABle:COPY <FileName>

This command copies one channel table onto another one. The channel table to be copied is selected with command CONFigure:​WCDPower:​MS:​CTABle:​NAME.

The name of the channel table may contain a maximum of 8 characters.

Parameters:
<FileName> | Name of the new channel table
Example: | CONF:WCDP:MS:CTAB:NAME 'NEW_TAB' Defines the channel table name to be copied. CONF:WCDP:MS:CTAB:COPY 'CTAB_2' Copies channel table 'NEW_TAB' to 'CTAB_2'.
Mode: | UE application only
Manual operation: | See "Copying a Table"


CONFigure:WCDPower:MS:CTABle:DELete

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower:MS:CTABle:DELete
CONFigure:WCDPower:MS:CTABle:DELete

This command deletes the selected channel table. The channel table to be deleted is selected with the command CONFigure:​WCDPower:​MS:​CTABle:​NAME.

Example: | CONF:WCDP:MS:CTAB:NAME 'NEW_TAB' Defines the channel table name to be deleted. CONF:WCDP:MS:CTAB:DEL
Mode: | UE application only
Manual operation: | See "Deleting a Table"


CONFigure:WCDPower:MS:CTABle:SELect

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Managing Channel Tables > CONFigure:WCDPower:MS:CTABle:SELect
CONFigure:WCDPower:MS:CTABle:SELect <FileName>

This command selects a predefined channel table file for comparison during channel detection. Before using this command, the "RECENT" channel table must be switched on first with the command CONFigure:​WCDPower:​MS:​CTABle[:​STATe].

Parameters:
<FileName>
*RST: RECENT
Example:

CONF:WCDP:MS:CTABl ON

Switches the channel table on.

CONF:WCDP:CTAB:MS:SEL 'CTAB_1'

Selects the predefined channel table 'CTAB_1'.

Mode: UE application only
Manual operation: See "Selecting a Table"


Configuring Channel Tables

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Tables
Configuring Channel Tables

Some general settings and functions are available when configuring a predefined channel table.

Remote commands exclusive to configuring channel tables:
List of Commands
CONFigure:WCDPower[:BTS]:CTABle:NAME
CONFigure:WCDPower[:BTS]:CTABle:COMMent
CONFigure:WCDPower:MS:CTABle:NAME
CONFigure:WCDPower:MS:CTABle:COMMent


CONFigure:WCDPower[:BTS]:CTABle:NAME

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Tables > CONFigure:WCDPower[:BTS]:CTABle:NAME
CONFigure:WCDPower[:BTS]:CTABle:NAME <Name>

This command creates a new channel table file or selects an existing channel table in order to copy or delete it.

Parameters:
<Name>
<file name>
*RST: RECENT
Example:

CONF:WCDP:CTAB:NAME 'NEW_TAB'

Mode: BTS application only
Manual operation: See "Name"


CONFigure:WCDPower[:BTS]:CTABle:COMMent

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Tables > CONFigure:WCDPower[:BTS]:CTABle:COMMent
CONFigure:WCDPower[:BTS]:CTABle:COMMent <Comment>

This command defines a comment for the selected channel table:

Prior to this command, the name of the channel table has to be defined with command CONFigure:​WCDPower[:​BTS]:​CTABle:​NAME. The values of the table are defined with command CONFigure:​WCDPower[:​BTS]:​CTABle:​DATA.

Parameters:
<Comment> |
Example: | CONF:WCDP:CTAB:NAME 'NEW_TAB' Defines the channel table name. CONF:WCDP:CTAB:COMM 'Comment for table 1' Defines a comment for the table. CONF:WCDP:CTAB:DATA 8,0,0,0,0,0,1,0.00,8,1,0,0,0,0,1,0.00,7,1,0,256,8,0,1,0.00 Defines the table values.
Mode: | BTS application only
Manual operation: | See "Comment"


CONFigure:WCDPower:MS:CTABle:NAME

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Tables > CONFigure:WCDPower:MS:CTABle:NAME
CONFigure:WCDPower:MS:CTABle:NAME <FileName>

This command creates a new channel table file or selects an existing channel table in order to copy or delete it.

Parameters:
<FileName>
<file name>
*RST: RECENT
Example:

CONF:WCDP:CTAB:NAME 'NEW_TAB'

Mode: UE application only
Manual operation: See "Name"


CONFigure:WCDPower:MS:CTABle:COMMent

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Tables > CONFigure:WCDPower:MS:CTABle:COMMent
CONFigure:WCDPower:MS:CTABle:COMMent <Comment>

This command defines a comment for the selected channel table:

Prior to this command, the name of the channel table has to be defined with command CONFigure:​WCDPower:​MS:​CTABle:​NAME. The values of the table are defined with command CONFigure:​WCDPower:​MS:​CTABle:​DATA.

Parameters:
<Comment> |
Example: | CONF:WCDP:MS:CTAB:NAME 'NEW_TAB' Defines the channel table name. CONF:WCDP:MS:CTAB:COMM 'Comment for table 1' Defines a comment for the table.
Mode: | UE application only
Manual operation: | See "Comment"


Configuring Channel Details (BTS Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Details (BTS Measurements)
Configuring Channel Details (BTS Measurements)

The following commands are used to configure individual channels in a predefined channel table in BTS measurements.

List of Commands
CONFigure:WCDPower[:BTS]:CTABle:DATA


CONFigure:WCDPower[:BTS]:CTABle:DATA

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Details (BTS Measurements) > CONFigure:WCDPower[:BTS]:CTABle:DATA
CONFigure:WCDPower[:BTS]:CTABle:DATA <CodeClass>, <CodeNumber>, <UseTFCI>, <TimingOffset>, <PilotLength>, <ChannelType>, <Status>, <CDP>

This command defines or queries the values of the selected channel table. Each line of the table consists of 8 values.

Channels PICH, CPICH and PCCPCH may only be defined once. If channel CPICH or PCCPCH is missing in the command, it is automatically added at the end of the table.

Prior to this command, the name of the channel table has to be defined with the command CONFigure:​WCDPower[:​BTS]:​CTABle:​NAME.

Parameters:
<CodeClass>
Range: 2 to 9
<CodeNumber>
Range: 0 to 511
<UseTFCI>
0 | 1
0

not used

1

used

<TimingOffset>
Step width: 256; for code class 9: 512
Range: 0 to 38400
<PilotLength>

code class 9: 4

code class 8: 2,4, 8

code class 7: 4, 8

code class 5/6: 8

code class 2/3/4: 16

<ChannelType>

For the assignment of channel types to parameters see table "BTS channel types and their assignment to a numeric parameter value".

<Status>
0

not active

1

active

<CDP>
for queries: CDP relative to total signal power; for settings: CDP absolute or relative
Example: CONF:WCDP:CTAB:NAME 'NEW_TAB'

Defines the channel table name.

CONF:WCDP:CTAB:DATA 8,0,0,0,0,0,1,0.00,8,1,0,0,0,0,1,0.00,7,1,0,256,8,0,1,0.00
Mode: BTS application only
Manual operation: See "Channel Type"
See "Channel Number (Ch. SF)"
See "Use TFCI"
See "Timing Offset"
See "Pilot Bits"
See "CDP Relative"
See "Status"


Configuring Channel Details (UE Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Details (UE Measurements)
Configuring Channel Details (UE Measurements)

The following commands are used to configure individual channels in a predefined channel table in UE measurements.

List of Commands
CONFigure:WCDPower:MS:CTABle:DATA
CONFigure:WCDPower:MS:CTABle:DATA:HSDPcch
CONFigure:WCDPower:MS:CTABle:EDATa
CONFigure:WCDPower:MS:CTABle:EDATa:EDPCc


CONFigure:WCDPower:MS:CTABle:DATA

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Details (UE Measurements) > CONFigure:WCDPower:MS:CTABle:DATA
CONFigure:WCDPower:MS:CTABle:DATA <CodeClass>,<NoActChan>,<PilotLength>

This command defines the values of the selected channel table.

The Channel DPCCH may only be defined once. If channel DPCCH is missing in the command data, it is automatically added at the end of the table. Prior to this command, the name of the channel table has to be defined with the command CONFigure:​WCDPower:​MS:​CTABle:​NAME.

Setting parameters:
<CodeClass>

Code class of channel 1. I-mapped

Range: 2 to 9
<NoActChan>

Number of active channels

Range: 1 to 7
<PilotLength>

pilot length of channel DPCCH

Return values:
<CodeClass>

Code class of channel 1. I-mapped

Range: 2 to 9
<NoActChan>

Number of active channels

Range: 1 to 7
<PilotLength>

pilot length of channel DPCCH

<CDP1>

Measured relative code domain power values of channel 1

<CDP2>

Measured relative code domain power values of channel 2

<CDP3>

Measured relative code domain power values of channel 3

<CDP4>

Measured relative code domain power values of channel 4

<CDP5>

Measured relative code domain power values of channel 5

<CDP6>

Measured relative code domain power values of channel 6

Example:

CONF:WCDP:MS:CTAB:DATA 8,0,0,5,1,0.00, 4,1,1,0,1,0.00, 4,1,0,0,1,0.00

The following channels are defined: DPCCH and two data channels with 960 ksps.

Mode: UE application only
Manual operation: See "Channel Type"
See "Channel Number (Ch. SF)"
See "Pilot Bits"
See "CDP Relative"
See "Status"


CONFigure:WCDPower:MS:CTABle:DATA:HSDPcch

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Details (UE Measurements) > CONFigure:WCDPower:MS:CTABle:DATA:HSDPcch
CONFigure:WCDPower:MS:CTABle:DATA:HSDPcch <State>

This command activates or deactivates the HS-DPCCH entry in a predefined channel table.

Parameters:
<State>
*RST: ON
Example:

CONF:WCDP:MS:CTAB:DATA:HSDP ON

Mode: UE application only


CONFigure:WCDPower:MS:CTABle:EDATa

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Details (UE Measurements) > CONFigure:WCDPower:MS:CTABle:EDATa
CONFigure:WCDPower:MS:CTABle:EDATa <CodeClass>, <NoActChan>

This command defines the values for an E-DPCCH channel in the selected channel table. The channel table must be selected using the command CONFigure:​WCDPower:​MS:​CTABle:​NAME.

Setting parameters:
<CodeClass>

Code class of channel

Range: 2 to 9
<NoActChan>

Number of active channels

Range: 0 to 4
Return values:
<CodeClass>

Code class of channel

Range: 2 to 9
<NoActChan>

Number of active channels

Range: 0 to 4
<ECDP1>

Measured relative code domain power values of channel 1

<ECDP2>

Measured relative code domain power values of channel 2

<ECDP3>

Measured relative code domain power values of channel 3

<ECDP4>

Measured relative code domain power values of channel 4

Example:

CONF:WCDP:MS:CTAB:EDAT 8,3

Mode: UE application only


CONFigure:WCDPower:MS:CTABle:EDATa:EDPCc

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Channel Detection > Configuring Channel Details (UE Measurements) > CONFigure:WCDPower:MS:CTABle:EDATa:EDPCc
CONFigure:WCDPower:MS:CTABle:EDATa:EDPCc <State>

This command activates or deactivates the E-DPCCH entry in a predefined channel table.

Parameters:
<State>
*RST: OFF
Example:

CONF:WCDP:MS:CTAB:EDAT:EDPC ON

Mode: UE application only


Sweep Settings

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings
Sweep Settings
List of Commands
[SENSe:]AVERage:COUNt
[SENSe:]SWEep:COUNt


[SENSe:]AVERage:COUNt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>

This command defines the number of sweeps that the application uses to average traces.

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweep measurements, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<AverageCount>

If you set a average count of 0 or 1, the application performs one single sweep in single sweep mode.

In continuous sweep mode, if the average count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


[SENSe:]SWEep:COUNt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Sweep Settings > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps that the application uses to average traces.

(For Pulse measurements, see also "Trace Statistics" ).

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweeps, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<SweepCount>

When you set a sweep count of 0 or 1, the R&S FSW performs one single sweep in single sweep mode.

In continuous sweep mode, if the sweep count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 200000
*RST: | 0
Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Sweep/Average Count"


Automatic Settings

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings
Automatic Settings
MSRA operating mode

In MSRA operating mode, the following commands are not available, as they require a new data acquisition. However, 3GPP FDD applications cannot perform data acquisition in MSRA operating mode.

Useful commands for adjusting settings automatically described elsewhere:
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​AUTO ONCE
  • [SENSe:​]CDPower:​LCODe:​SEARch[:​IMMediate]?
Remote commands exclusive to adjusting settings automatically:
List of Commands
CONFigure:WCDPower[:BTS]:ASCale[:STATe]
CONFigure:WCDPower[:BTS]:MCARrier:STATe
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel


CONFigure:WCDPower[:BTS]:ASCale[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > CONFigure:WCDPower[:BTS]:ASCale[:STATe]
CONFigure:WCDPower[:BTS]:ASCale[:STATe] <State>

Activate this command if multiple carriers are used. In this case, the autoscaling function automatically changes the level settings if the center frequency is changed to another carrier.

Parameters:
<State>
ON | OFF
*RST: ON
Example:

CONF:WCDP:ASC:STAT ON

Mode: BTS application only


CONFigure:WCDPower[:BTS]:MCARrier:STATe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > CONFigure:WCDPower[:BTS]:MCARrier:STATe
CONFigure:WCDPower[:BTS]:MCARrier:STATe <State>

Activate this command if multiple carriers are used. In this case, the adjust reference level procedure ensures that the settings of RF attenuation and reference level are optimally adjusted for measuring a multicarrier signal.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CONF:WCDP:MCAR:STAT ON

Mode: BTS application only


[SENSe:]ADJust:ALL

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > [SENSe:]ADJust:ALL
[SENSe:]ADJust:ALL

This command initiates a measurement to determine and set the ideal settings for the current task automatically (only once for the current measurement).

This includes:

  • Reference level
  • Scrambling code
  • Scaling
Example: | ADJ:ALL
Usage: | Event
Manual operation: | See "Adjusting all Determinable Settings Automatically (Auto All)"


[SENSe:]ADJust:CONFigure:DURation

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Automatic Settings > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Evaluation Range

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Evaluation Range
Evaluation Range

The evaluation range defines which data is evaluated in the result display.

List of Commands
[SENSe:]CDPower:CODE
[SENSe:]CDPower:FRAMe[:VALue]
[SENSe:]CDPower:SLOT
[SENSe:]CDPower:MAPPing
CALCulate<n>:CDPower:Mapping


[SENSe:]CDPower:CODE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Evaluation Range > [SENSe:]CDPower:CODE
[SENSe:]CDPower:CODE <CodeNumber>

This command sets the code number. The code number refers to code class 9 (spreading factor 512).

Parameters:
<CodeNumber>
<numeric value>
*RST: 0
Example:

SENS:CDP:CODE 30

Manual operation: See "Channel"


[SENSe:]CDPower:FRAMe[:VALue]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Evaluation Range > [SENSe:]CDPower:FRAMe[:VALue]
[SENSe:]CDPower:FRAMe[:VALue] <Frame>

This command defines the frame to be analyzed within the captured data.

Parameters:
<Frame>
<numeric value>
Range: | [0 ... CAPTURE_LENGTH – 1]
*RST: | 1
Example:

CDP:FRAM:VAL 1

Manual operation: See "Frame To Analyze"


[SENSe:]CDPower:SLOT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Evaluation Range > [SENSe:]CDPower:SLOT
[SENSe:]CDPower:SLOT <SlotNumber>

This command selects the (CPICH) slot number to be evaluated.

Parameters:
<SlotNumber>
<numeric value>
*RST: 0
Example:

SENS:CDP:SLOT 3

Manual operation: See "Slot"


[SENSe:]CDPower:MAPPing

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Evaluation Range > [SENSe:]CDPower:MAPPing
[SENSe:]CDPower:MAPPing <SignalBranch>

This command switches between I and Q branches of the signal for all evaluations (if not specified otherwise using CALCulate<n>:​CDPower:​Mapping).

Parameters:
<SignalBranch>
I | Q
*RST: Q
Example:

CDP:MAPP Q

Mode: UE application only


CALCulate<n>:CDPower:Mapping

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Evaluation Range > CALCulate<n>:CDPower:Mapping
CALCulate<n>:CDPower:Mapping <SignalBranch>

This command adjusts the mapping for the evaluations Code Domain Power and Code Domain Error Power in a specific window.

Parameters:
<SignalBranch>
I | Q | AUTO
I

The I-branch of the signal will be used for evaluation

Q

The Q-branch of the signal will be used for evaluation

AUTO

The branch selected by the [SENSe:​]CDPower:​MAPPing command will be used for evaluation.

*RST: AUTO
Example:

CALC:CDP:MAPPING AUTO

Mode: UE application only
Manual operation: See "Branch (UE measurements only)"
See "Selecting a Different Branch for a Window"


Code Domain Analysis Settings (BTS Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (BTS Measurements)
Code Domain Analysis Settings (BTS Measurements)

Some evaluations provide further settings for the results. The commands for BTS measurements are described here.

List of Commands
CALCulate:MARKer<m>:FUNCtion:ZOOM
[SENSe:]CDPower:CPB
[SENSe:]CDPower:NORMalize
[SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PDIFf
[SENSe:]CDPower:PREFerence


CALCulate:MARKer<m>:FUNCtion:ZOOM

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (BTS Measurements) > CALCulate:MARKer<m>:FUNCtion:ZOOM
CALCulate:MARKer<m>:FUNCtion:ZOOM <State>

If marker zoom is activated, the number of channels displayed on the screen in the code domain power and code domain error power result diagram is reduced to 64.

The currently selected marker defines the center of the displayed range.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

CALC:MARK:FUNC:ZOOM ON


[SENSe:]CDPower:CPB

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (BTS Measurements) > [SENSe:]CDPower:CPB
[SENSe:]CDPower:CPB <Value>

This command selects the constellation parameter B. According to 3GPP specification, the mapping of 16QAM symbols to an assigned bit pattern depends on the constellation parameter B.

Parameters:
<Value>
<numeric value>
*RST: 0
Example:

SENS:CDP:CDP 1

Manual operation: See "Constellation Parameter B"


[SENSe:]CDPower:NORMalize

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (BTS Measurements) > [SENSe:]CDPower:NORMalize
[SENSe:]CDPower:NORMalize <State>

If enabled, the I/Q offset is eliminated from the measured signal. This is useful to deduct a DC offset to the baseband caused by the DUT, thus improving the EVM. Note, however, that for EVM measurements according to standard, compensation must be disabled.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

SENS:CDP:NORM ON

Activates the elimination of the I/Q offset.

Manual operation: See "Compensate IQ Offset"


[SENSe:]CDPower:PDISplay

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (BTS Measurements) > [SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PDISplay <Mode>

This command switches between showing the absolute or relative power.

This parameter only affects the Code Domain Power evaluation.

Parameters:
<Mode>
ABS | REL
ABSolute

Absolute power levels

RELative

Power levels relative to total signal power or (BTS application only) CPICH channel power (see [SENSe:​]CDPower:​PREFerence)

*RST: ABS
Example:

SENS:CDP:PDIS ABS

Manual operation: See "Code Power Display"
See "Code Power Display"


[SENSe:]CDPower:PDIFf

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (BTS Measurements) > [SENSe:]CDPower:PDIFf
[SENSe:]CDPower:PDIFf <State>

This command defines which slot power difference is displayed in the Power vs Slot evaluation.

Parameters:
<State>
ON | OFF
ON

The slot power difference to the previous slot is displayed.

OFF

The current slot power of each slot is displayed.

*RST: OFF
Example:

SENS:CDP:PDIF ON

Mode: BTS application only
Manual operation: See "Show Difference to Previous Slot"


[SENSe:]CDPower:PREFerence

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (BTS Measurements) > [SENSe:]CDPower:PREFerence
[SENSe:]CDPower:PREFerence <Mode>

This command defines the reference for the relative CDP measurement values.

Parameters:
<Mode>
TOTal | CPICh
TOTal

Total signal power

CPICh

CPICH channel power

*RST: TOTal
Example:

SENS:CDP:PREF CPIC

Mode: BTS application only
Manual operation: See "Code Power Display"


Code Domain Analysis Settings (UE Measurements)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (UE Measurements)
Code Domain Analysis Settings (UE Measurements)

Some evaluations provide further settings for the results. The commands for UE measurements are described here.

Useful commands for Code Domain Analysis described elsewhere:
  • CALCulate:​MARKer<m>:​FUNCtion:​ZOOM
  • [SENSe:​]CDPower:​NORMalize
  • [SENSe:​]CDPower:​PDISplay
Remote commands exclusive to Code Domain Analysis in UE Measurements:
List of Commands
[SENSe:]CDPower:ETCHips
[SENSe:]CDPower:HSLot


[SENSe:]CDPower:ETCHips

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (UE Measurements) > [SENSe:]CDPower:ETCHips
[SENSe:]CDPower:ETCHips <State>

This command selects length of the measurement interval for calculation of error vector magnitude (EVM). In accordance with 3GPP specification Release 5, the EVM measurement interval is one slot (4096 chips) minus 25 µs (3904 chips) at each end of the burst if power changes are expected. If no power changes are expected, the evaluation length is one slot (4096 chips).

Parameters:
<State>
ON

Changes of power are expected. Therefore an EVM measurement interval of one slot minus 25 µs (3904 chips) is considered.

OFF

Changes of power are not expected. Therefore an EVM measurement interval of one slot (4096 chips) is considered

*RST: OFF
Example:

SENS:CDP:ETCH ON

Manual operation: See "Eliminate Tail Chips"


[SENSe:]CDPower:HSLot

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring Code Domain Analysis and Time Alignment Error Measurements > Code Domain Analysis Settings (UE Measurements) > [SENSe:]CDPower:HSLot
[SENSe:]CDPower:HSLot <State>

This command switches between the analysis of half slots and full slots.

Parameters:
<State>
ON | OFF
ON

30 (half) slots are evaluated

OFF

15 (full) slots are evaluated

*RST: OFF
Example:

SENS:CDP:HSL ON

Mode: UE application only
Manual operation: See "Measurement Interval"


Configuring RF Measurements

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring RF Measurements
Configuring RF Measurements

RF measurements are performed in the Spectrum application, with some predefined settings as described in "RF Measurements".

For details on configuring these RF measurements in a remote environment, see "Configuring and Performing Measurements" .

The 3GPP FDD RF measurements must be activated for a 3GPP FDD application, see "Activating 3GPP FDD Measurements".

The individiual measurements are activated using the CONFigure:​WCDPower[:​BTS]:​MEASurement command (see "Selecting a Measurement").

Contents
  • Special RF Configuration Commands
  • Analysis


Special RF Configuration Commands

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring RF Measurements > Special RF Configuration Commands
Special RF Configuration Commands

In addition to the common RF measurement configuration commands described for the base unit, the following special commands are available in 3GPP FDD applications:

List of Commands
CONFigure:WCDPower[:BTS]:STD


CONFigure:WCDPower[:BTS]:STD

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring RF Measurements > Special RF Configuration Commands > CONFigure:WCDPower[:BTS]:STD
CONFigure:WCDPower[:BTS]:STD <Type>

Switches between Normal mode and Home BS (Home Base Station) mode for ACP and SEM measurements in the BTS application. Switching this parameter changes the limits according to the specifications.

Parameters:
<Type>
HOME | NORMal
HOME

Home Base Station

NORMal

Normal mode

*RST: NORMal
Example: CONF:WCDP:BTS:STD HOME
Mode: BTS application only
Manual operation: See "BTS Standard"


Analysis

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring RF Measurements > Analysis
Analysis

General result analysis settings concerning the trace, markers, lines etc. for RF measurements are identical to the analysis functions in the Spectrum application except for some special marker functions and spectrograms, which are not available in the 3GPP FDD applications.

See
  • "Zooming into the Display"
  • "Configuring the Trace Display and Retrieving Trace Data"
  • "Working with Markers"
  • "Configuring Display and Limit Lines"


Configuring the Result Display

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display
Configuring the Result Display

The following commands are required to configure the screen display in a remote environment. The tasks for manual operation are described in "Measurements and Result Display".

Contents
  • General Window Commands
  • Working with Windows in the Display
  • Zooming into the Display


General Window Commands

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example: LAY:ADD? '1',BEL,'XPOW:CDP:ABSolute'

Adds a Code Domain Power display below window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Bitstream"
See "Channel Table"
See "Code Domain Power"
See "Code Domain Error Power"
See "Composite Constellation"
See "Composite EVM"
See "EVM vs Chip"
See "Frequency Error vs Slot"
See "Mag Error vs Chip"
See "Marker Table"
See "Peak Code Domain Error"
See "Phase Discontinuity vs Slot"
See "Phase Error vs Chip"
See "Power vs Slot"
See "Power vs Symbol"
See "Result Summary"
See "Symbol Constellation"
See "Symbol EVM"
See "Symbol Magnitude Error"
See "Symbol Phase Error"
See "Diagram"
See "Result Summary"
See "Marker Peak List"
<WindowType> parameter values for 3GPP FDD application
Parameter value | Window type
BITStream | Bitstream
CCONst | Composite Constellation
CDPower | Code Domain Power
CDEPower | Code Domain Error Power
CEVM | Composite EVM
CTABle | Channel Table
EVMChip | EVM vs Chip
FESLot | Frequency Error vs Slot
MECHip | Magnitude Error vs Chip
MTABle | Marker table
PCDerror | Peak Code Domain Error
PDSLot | Phase Discontinuity vs Slot
PECHip | Phase Error vs Chip
PSLot | Power vs Slot
PSYMbol | Power vs Symbol
RSUMmary | Result Summary
SCONst | Symbol Constellation
SEVM | Symbol EVM
SMERror | Symbol Magnitude Error
SPERror | Symbol Phase Error


LAYout:CATalog[:WINDow]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Zooming into the Display

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Result Display > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Starting a Measurement

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement
Starting a Measurement

The measurement is started immediately when a 3GPP FDD application is activated, however, you can stop and start a new measurement any time.

List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
SYSTem:SEQuencer


ABORt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

With sweep count or average count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


INITiate:SEQuencer:REFResh[:ALL]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > INITiate:SEQuencer:REFResh[:ALL]
INITiate:SEQuencer:REFResh[:ALL]

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only in MSRA or MSRT mode.

The data in the capture buffer is re-evaluated by all active MSRA/MSRT applications.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INIT:SEQ:REFR Refreshes the display for all channels.
Usage: | Event


SYSTem:SEQuencer

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Starting a Measurement > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


Retrieving Results

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results
Retrieving Results

The following commands are required to retrieve the results from a 3GPP FDD measurement in a remote environment.

When the channel type is required as a parameter by a remote command or provided as a result for a remote query, abbreviations or assignments to a numeric value are used as described in "Channel Detection".

Useful commands described elsewhere:
  • "Storing Measurement Results"
Specific commands:
Contents
  • Retrieving Calculated Measurement Results
  • Measurement Results for TRACe<n>[:DATA]? TRACE<n>
  • Retrieving Trace Results
  • Exporting Trace Results
  • Retrieving RF Results


Retrieving Calculated Measurement Results

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Calculated Measurement Results
Retrieving Calculated Measurement Results

The following commands describe how to retrieve the calculated results from the CDA and Time Alignment Error measurements.

List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:TAERror:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:WCDPower[:BTS]:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:WCDPower:MS:RESult?


CALCulate<n>:MARKer<m>:FUNCtion:TAERror:RESult?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Calculated Measurement Results > CALCulate<n>:MARKer<m>:FUNCtion:TAERror:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:TAERror:RESult? <ResultType>

This command queries the result of a time alignment measurement (see "Time Alignment Error Measurements").

Query parameters:
<ResultType> | TAERror Returns the time offset between the two antenna signals in chips.
Example: | CALC:MARK:FUNC:TAER:RES? TAER
Usage: | Query only
Mode: | BTS application only
Manual operation: | See "Result List"


CALCulate<n>:MARKer<m>:FUNCtion:WCDPower[:BTS]:RESult?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Calculated Measurement Results > CALCulate<n>:MARKer<m>:FUNCtion:WCDPower[:BTS]:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:WCDPower[:BTS]:RESult? <Measurement>

This command queries the measured and calculated results of the 3GPP FDD BTS code domain power measurement.

Query parameters:
<Measurement> | The parameter specifies the required evaluation method. ACHannels Number of active channels ARCDerror relative code domain error averaged over all channels with modulation type 64QAM CDPabsolute code domain power absolute CDPRelative code domain power relative CERRor chip rate error CHANnel channel number CSLot channel slot number EVMPeak error vector magnitude peak EVMRms error vector magnitude RMS FERRor frequency error in Hz IOFFset imaginary part of the I/Q offset IQIMbalance I/Q imbalance IQOFfset I/Q offset MACCuracy composite EVM MPIC average power of inactive channels MTYPe modulation type: 2 – QPSK 4 – 16 QAM 5 – 64 QAM 15 – NONE PCDerror peak code domain error PSYMbol number of pilot bits PTOTal total power QOFFset real part of the I/Q offset RCDerror relative code domain error RHO rho value for every slot SRATe symbol rate TFRame trigger to frame TOFFset timing offset
Example: | CALC:MARK:FUNC:WCDP:RES? PTOT
Usage: | Query only
Mode: | BTS application only
Manual operation: | See "Code Domain Power" See "Result Summary"


CALCulate<n>:MARKer<m>:FUNCtion:WCDPower:MS:RESult?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Calculated Measurement Results > CALCulate<n>:MARKer<m>:FUNCtion:WCDPower:MS:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:WCDPower:MS:RESult? <Measurement>

This command queries the measured and calculated results of the 3GPP FDD UE code domain power measurement.

Query parameters:
<Measurement> | The parameter specifies the required evaluation method. ACHannels Number of active channels CDPabsolute code domain power absolute CDPRelative code domain power relative CERRor chip rate error CHANnel channel number CMAPping Channel branch CSLot channel slot number EVMPeak error vector magnitude peak EVMRms error vector magnitude RMS FERRor frequency error in Hz IQIMbalance I/Q imbalance IQOFfset I/Q offset MACCuracy composite EVM MPIC average power of the inactive codes for the selected slot MTYPe modulation type: BPSK-I: 0 BPSK-Q: 1 4PAM-I: 6 4PAM-Q: 7 NONE: 15 PCDerror peak code domain error PSYMbol Number of pilot bits PTOTal total power RHO rho value for every slot SRATe symbol rate TFRame trigger to frame TOFFset timing offset
Example: | CALC:MARK:FUNC:WCDP:MS:RES? PTOT
Example: | See "Programming Examples (R&S FSW-K73)"
Usage: | Query only
Mode: | UE application only
Manual operation: | See "Code Domain Power"


Measurement Results for TRACe<n>[:DATA]? TRACE<n>

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n>
Measurement Results for TRACe<n>[:DATA]? TRACE<n>

The evaluation method selected by the LAY:ADD:WIND command also affects the results of the trace data query (TRACe<n>[:DATA]? TRACE<n>, see TRACe<n>[:​DATA]?).

Details on the returned trace data depending on the evaluation method are provided here.

For details on the graphical results of these evaluation methods, see "Measurements and Result Display".

Contents
  • Code Domain Power
  • Channel Table
  • Code Domain Error Power
  • Power vs Slot
  • Result Summary
  • Composite EVM (RMS)
  • Peak Code Domain Error
  • Composite Constellation
  • Power vs Symbol
  • Symbol Constellation
  • Symbol EVM
  • Bitstream
  • Frequency Error vs Slot
  • Phase Discontinuity vs Slot
  • EVM vs Chip
  • Mag Error vs Chip
  • Phase Error vs Chip
  • Symbol Magnitude Error
  • Symbol Phase Error


Code Domain Power

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Code Domain Power
Code Domain Power

When the trace data for this evaluation is queried, 5 values are transmitted for each channel:

  • the code class
  • the channel number
  • the absolute level
  • the relative level
  • the timing offset

For details on these parameters see TRACe<n>[:​DATA]?.


Channel Table

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Channel Table
Channel Table

When the trace data for this evaluation is queried, 5 values are transmitted for each channel:

  • the class
  • the channel number
  • the absolute level
  • the relative level
  • the timing offset

For details on these parameters see TRACe<n>[:​DATA]?.

Example:

The following example shows the results of a query for three channels with the following configuration:

Channel | Spreading factor | Channel number | Timing offset
1st | 512 | 7 | 0
2nd | 4 | 1 | 256 chips
3rd | 128 | 255 | 2560 chips

This yields the following result:

9, 7, -40, -20, 0, 2, 1, -40, -20, 256, 7, 255, -40, -20, 2560

The channel order is the same as in the CDP diagram, i.e. it depends on their position in the code domain of spreading factor 512.


Code Domain Error Power

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Code Domain Error Power
Code Domain Error Power

When the trace data for this evaluation is queried, 4 values are transmitted for each channel with code class 9:

code class | Highest code class of a downlink signal, always set to 9 (CC9)
code number | Code number of the evaluated CC9 channel [0...511]
CDEP | Code domain error power value of the CC9 channel in [dB]
channel flag | Indicates whether the CC9 channel belongs to an assigned code channel: 0b00-0d0: CC9 is inactive. 0b01-0d1: CC9 channel belongs to an active code channel. 0b11-0d3: CC9 channel belongs to an active code channel; sent pilot symbols are incorrect

The channels are sorted by code number.


Power vs Slot

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs Slot
Power vs Slot

When the trace data for this evaluation is queried, 16 pairs of slots (slot number of CPICH) and level values are transferred:

<slot number>, <level value in dB> (for 16 slots)


Result Summary

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Result Summary
Result Summary

When the trace data for this evaluation is queried, the results of the result summary are output in the following order:

<composite EVM [%]>,

<peak CDE [dB]>,

<carr freq error [Hz]>,

<chip rate error [ppm]>,

<total power [dB]>,

<trg to frame [µs]>,

<EVM peak channel [%]>,

<EVM mean channel [%]>,

<code class>,

<channel number>,

<power abs. channel [dB]>,

<power rel. channel [dB], referenced to CPICH or total power>,

<timing offset [chips]>,

<I/Q offset [%]>,

<I/Q imbalance [%]>


Composite EVM (RMS)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Composite EVM (RMS)
Composite EVM (RMS)

When the trace data for this evaluation is queried, 15 pairs of slots (slot number of CPICH) and level values are transferred:

<slot number>, <level value in %> (for 15 slots)


Peak Code Domain Error

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Peak Code Domain Error
Peak Code Domain Error

When the trace data for this evaluation is queried, 15 pairs of slots (slot number of CPICH) and level values are transferred:

<slot number>, <level value in dB> (for 15 slots)


Composite Constellation

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Composite Constellation
Composite Constellation

When the trace data for this evaluation is queried, the real and the imaginary branches of the chip constellation at the selected slot are transferred:

<Re1>, <Im1>, <Re2>, <Im2>, ...., <Re2560>, <Im2560>

The values are normalized to the square root of the average power at the selected slot.


Power vs Symbol

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Power vs Symbol
Power vs Symbol

When the trace data for this evaluation is queried, the power of each symbol at the selected slot is transferred. The values indicate the difference to the reference power in dB. The number of the symbols depends on the spreading factor of the selected channel:

NOFSymbols=10*2(8-CodeClass)


Symbol Constellation

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Constellation
Symbol Constellation

When the trace data for this evaluation is queried, the real and the imaginary branches are transferred:

<Re0>, <Im0>, <Re1>, <Im1>, ...., <Ren>, <Imn>

The number of level values depends on the spreading factor:

Spreading factor | Number of level values
512 | 5
256 | 10
128 | 20
64 | 40
32 | 80
16 | 160
8 | 320
4 | 640


Symbol EVM

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol EVM
Symbol EVM

When the trace data for this evaluation is queried, the real and the imaginary branches are transferred:

<Re0>, <Im0>, <Re1>, <Im1>, ...., <Ren>, <Imn>

The number of level values depends on the spreading factor:

Spreading factor | Number of level values
512 | 5
256 | 10
128 | 20
64 | 40
32 | 80
16 | 160
8 | 320
4 | 640


Bitstream

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Bitstream
Bitstream

When the trace data for this evaluation is queried, the bit stream of one slot is transferred. Each symbol contains two consecutive bits in the case of a QPSK modulated slot and 4 consecutive bits in the case of a 16QAM modulated slot. One value is transferred per bit (range 0, 1). The number of symbols is not constant and may vary for each sweep. Individual symbols in the bit stream may be invalid depending on the channel type and the bit rate (symbols without power). The assigned invalid bits are marked by one of the digits "6", "7" or "9".

The values and number of the bits are as follows (without HS-DPCCH channels, see [SENSe:​]CDPower:​HSDPamode) :

Bit values and numbers without HS-DPCCH channels
Unit | []
Value range | {0, 1, 6, 9} 0 - Low state of a transmitted bit 1 - High state of a transmitted bit 6 - Bit of a symbol of a suppressed slot of a DPCH in Compressed Mode (DPCH-CPRSD) 9 - Bit of a suppressed symbol of a DPCH (e.g. TFCI off)
Bits per slot | NBitPerSymb = 2
Number of symbols | NSymb = 10*2(8-Code Class)
Number of bits | NBit = NSymb * NBitPerSymb
Format | Bit00, Bit01, Bit10, Bit11, Bit20, Bit21,.... , BitNSymb 0, BitNSymb 1

The values and number of the bits including HS-DPCCH channels (see [SENSe:​]CDPower:​HSDPamode) are as follows:

Bit values and numbers including HS-DPCCH channels
Unit | []
Value range | {0, 1, 6, 7, 8, 9} 0 - Low state of a transmitted bit 1 - High state of a transmitted bit 6 - Bit of a symbol of a suppressed slot of a DPCH in Compressed Mode (DPCH-CPRSD) 7 - Bit of a switched-off symbol of an HS-PDSCH channel 8 - Fill value for unused bits of a lower order modulation symbol in a frame containing higher order modulation 9 - Bit of a suppressed symbol of a DPCH (e.g. TFCI off)
Bits per symbol | NBitPerSymb = {2, 4, 6}
Symbols per slot | NSymb_Slot = 10*2(8-Code Class)
Symbols per frame | NSymb_Frame = 15*NSymb_Slot= 150*2(8-Code Class)
Number of bits | NBit = NSymb_Frame * NBitPerSymb_MAX
Format (16QAM) | Bit00,Bit01,Bit02,Bit03,Bit10,Bit11,Bit12,Bit13,.... ... , BitNSymb_Frame 0,BitNSymb_Frame 1,BitNSymb_Frame 2, BitNSymb_Frame 3
Format (64QAM) | Bit00, Bit01, Bit02, Bit03, Bit04, Bit05, Bit10, Bit11, Bit12, Bit13, Bit14, Bit15, ..., BitNSymb_Frame 0,BitNSymb_Frame 1,BitNSymb_Frame 2,BitNSymb_Frame 3,BitNSymb_Frame 4,BitNSymb_Frame 5


Frequency Error vs Slot

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Frequency Error vs Slot
Frequency Error vs Slot

When the trace data for this evaluation is queried, 15 pairs of slot (slot number of CPICH) and values are transferred:

<slot number>, <value in Hz>


Phase Discontinuity vs Slot

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Phase Discontinuity vs Slot
Phase Discontinuity vs Slot

When the trace data for this evaluation is queried, 15 pairs of slot (slot number of CPICH) and values are transferred:

<slot number>, <value in deg>


EVM vs Chip

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > EVM vs Chip
EVM vs Chip

When the trace data for this evaluation is queried, a list of vector error values of all chips at the selected slot is returned (=2560 values). The values are calculated as the square root of the square difference between the received signal and the reference signal for each chip, normalized to the square root of the average power at the selected slot.


Mag Error vs Chip

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Mag Error vs Chip
Mag Error vs Chip

When the trace data for this evaluation is queried, a list of magnitude error values of all chips at the selected slot is returned (=2560 values). The values are calculated as the magnitude difference between the received signal and the reference signal for each chip in %, and are normalized to the square root of the average power at the selected slot.


Phase Error vs Chip

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Phase Error vs Chip
Phase Error vs Chip

When the trace data for this evaluation is queried, a list of phase error values of all chips in the selected slot is returned (=2560 values). The values are calculated as the phase difference between the received signal and the reference signal for each chip in degrees, and are normalized to the square root of the average power at the selected slot.


Symbol Magnitude Error

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Magnitude Error
Symbol Magnitude Error

When the trace data for this evaluation is queried, the magnitude error in % of each symbol at the selected slot is transferred. The number of the symbols depends on the spreading factor of the selected channel:

NOFSymbols=10*2(8-CodeClass)


Symbol Phase Error

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Measurement Results for TRACe<n>[:DATA]? TRACE<n> > Symbol Phase Error
Symbol Phase Error

When the trace data for this evaluation is queried, the phase error in degrees of each symbol at the selected slot is transferred. The number of the symbols depends on the spreading factor of the selected channel:

NOFSymbols=10*2(8-CodeClass)


Retrieving Trace Results

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results
Retrieving Trace Results

The following commands describe how to retrieve the trace data from the CDA and Time Alignment Error measurements. Note that for these measurements, only 1 trace per window can be configured.

  • FORMat[:​DATA]
  • TRACe<n>[:​DATA]?
  • TRACe<n>[:DATA]? TRACE1
  • TRACe<n>[:DATA]? ABITstream
  • TRACe<n>[:DATA]? ATRACE1
  • TRACe<n>[:DATA]? CTABle
  • TRACe<n>[:DATA]? CWCDp
  • TRACe<n>[:DATA]? FINal1
  • TRACe<n>[:DATA]? LIST
  • TRACe<n>[:DATA]? PWCDp
  • TRACe<n>[:DATA]? TPVSlot
List of Commands
FORMat[:DATA]
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?


FORMat[:DATA]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

For details on data formats see "Formats for Returned Values: ASCII Format and Binary Format" .

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <MeasMode>

This command queries the trace data from the measurement. Depending on the selected measurement mode, the results vary. For a detailed description of the results, see the individual commands.

Query parameters:
<MeasMode> | ATRACE1 | ABITstream1 | CTABLe | CEVM | CWCDp | FINAL1 | LIST | PWCDp | TPVSlot | TRACE1 The data type defines which type of trace data is read.
Example: | TRAC:DATA? ATRACE
Usage: | Query only


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? TRACE1

This command returns the trace data. Depending on the evaluation, the trace data format varies.

The channels are output in a comma-separated list in ascending order sorted by code number, i.e. in the same sequence they are displayed on screen.

For details see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>".

Return values:
<CodeClass> | 2 … 9 Code class of the channel
<ChannelNo> | 0 … 511 Code number of the channel
<AbsLevel> | dBm Absolute level of the code channel at the selected channel slot.
<RelLevel> | % Relative level of the code channel at the selected channel slot referenced to CPICH or total power.
<TimingOffset> | 0 … 38400 [chips] Timing offset of the code channel to the CPICH frame start. The value is measured in chips. The step width is 256 chips in the case of code class 2 to 8, and 512 chips in the case of code class 9.
Example: | TRAC2:DATA? TRACE1 Returns the trace data from trace 1 in window 2.
Usage: | Query only
Manual operation: | See "Code Domain Error Power" See "Composite Constellation" See "Composite EVM" See "EVM vs Chip" See "Mag Error vs Chip" See "Peak Code Domain Error" See "Phase Discontinuity vs Slot" See "Phase Error vs Chip" See "Power vs Symbol" See "Result Summary" See "Symbol Constellation" See "Symbol EVM" See "Symbol Magnitude Error" See "Symbol Phase Error"


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? ABITstream

This command returns the bit streams of all 15 slots one after the other. The output format may be REAL, UINT or ASCII. The number of bits of a 16QAM-modulated channel is twice that of a QPSK-modulated channel, the number of bits of a 64QAM-modulated channel is three times that of a QPSK-modulated channel.

This query is only available if the evaluation for the corresponding window is set to "Bitstream" using the LAY:ADD:WIND "XTIM:CDP:BSTReam" command (see LAYout:​ADD[:​WINDow]?).

The output format is identical to that of the TRAC:DATA? TRAC command for an activated Bitstream evaluation (see "Measurement Results for TRACe<n>[:DATA]? TRACE<n>"). The only difference is the number of symbols which are evaluated. The ABITstream parameter evaluates all symbols of one entire frame (vs. only one slot for TRAC:DATA? TRAC).

The values 7 and 8 are only used in case of a varying modulation type of an HS-PDSCH channel. In this case the number of bits per symbol (NBitPerSymb) varies, as well. However, the length of the transmitted bit vector (NBit) depends only on the maximum number of bits per symbol in that frame. Thus, if the modulation type changes throughout the frame this will not influence the number of bits being transmitted (see examples below).

Example: | LAY:REPL 2,"XTIM:CDP:BSTReam" Sets the evaluation for window 2 to bit stream. TRAC2:DATA? ABITstream Returns the bit streams of all 15 slots in window 2, one after the other.
Usage: | Query only
Manual operation: | See "Bitstream"

Examples for bits 7 and 8 for changing modulation types

Example 1:

Some slots of the frame are 64QAM modulated, other are 16QAM and QPSK modulated and some are switched OFF (NONE). If one or more slots of the frame are 64QAM modulated, six bits per symbol are transmitted and if the highest modulation order is 16QAM, four bits per symbol are transmitted. In any slot of the frame with lower order modulation, the first two or four of the four or six bits are marked by the number 8 and the last bits represent the transmitted symbol. If no power is transmitted in a slot, four or six entries per symbol of value 7 are transmitted.

Example 2:

Some slots of the frame are QPSK modulated and some are switched OFF. If one or more slots of the frame are QPSK modulated and no slot is 16QAM modulated, 2 bits per symbol are transmitted. If no power is transmitted in a slot, 2 entries per symbol of value 7 are transmitted.

Example 3:

Some slots of a DPCH are suppressed because of compressed mode transmission. The bits of the suppressed slots are marked by the digit '6'. In this case, always 2 bits per symbol are transmitted.


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? ATRace1

This command returns a list of absolute Frequency Error vs Slot values for all 16 slots (based on CPICH slots). In contrast to the TRACE1 parameter return value, absolute values are returned.

Return values:
<SlotNumber>

Slot number

<FreqError>

Absolute frequency error

Default unit: Hz
Example: TRAC2:DATA? ATR

Returns a list of absolute frequency errors for all slots in window 2.

Usage: Query only
Mode: BTS application only
Manual operation: See "Frequency Error vs Slot"


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? CTABle

This command returns the pilot length and the channel state (active, inactive) in addition to the values returned for TRACE<t>.

This command is only available for Code Domain Power or Channel Table evaluations (see "Evaluation Methods for Code Domain Analysis").

Return values:
<CodeClass>
2 … 9

Code class of the channel

<ChannelNo>
0 … 511

Code number of the channel

<AbsLevel>
dBm

Absolute level of the code channel at the selected channel slot.

<RelLevel>
%

Relative level of the code channel at the selected channel slot referenced to CPICH or total power.

<TimingOffset>
0 … 38400 [chips]

Timing offset of the code channel to the CPICH frame start. The value is measured in chips. The step width is 256 chips in the case of code class 2 to 8, and 512 chips in the case of code class 9.

<PilotLength>

The length of the pilot symbols. According to the 3GPP standard, the pilot length range depends on the code class.

Range: | 0,2,4,8,16
Default unit: | symbols
<ActiveFlag>
0 | 1

Flag to indicate whether a channel is active (1) or not (0)

Example: TRAC:DATA? CTABle

Returns a list of channel information, including the pilot length and channel state.

Usage: Query only
Manual operation: See "Channel Table"
See "Code Domain Power"


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? CWCDp

This command returns additional results to the values returned for TRACE<t>.

The result is a comma-separated list with 10 values for each channel; the channels are output in ascending order sorted by code number, i.e. in the same sequence they are displayed on screen.

This command is only available for Code Domain Power or Channel Table evaluations (see "Evaluation Methods for Code Domain Analysis").

Return values:
<CodeClass>
2 … 9

Code class of the channel

<ChannelNo>
0 … 511

Code number of the channel

<AbsLevel>
dBm

Absolute level of the code channel at the selected channel slot.

<RelLevel>
%

Relative level of the code channel at the selected channel slot referenced to CPICH or total power.

<TimingOffset>
0 … 38400 [chips]

Timing offset of the code channel to the CPICH frame start. The value is measured in chips. The step width is 256 chips in the case of code class 2 to 8, and 512 chips in the case of code class 9.

<PilotLength>

The length of the pilot symbols. According to the 3GPP standard, the pilot length range depends on the code class.

Range: | 0,2,4,8,16
Default unit: | symbols
<ActiveFlag>
0 | 1

Flag to indicate whether a channel is active (1) or not (0)

<ChannelType>

Channel type. For details see table "BTS channel types and their assignment to a numeric parameter value".

Range: 0 … 16
<ModType>

Modulation type of the code channel at the selected channel slot

2

QPSK

4

16 QAM

15

NONE

There is no power in the selected channel slot (slot is switched OFF).

Range: 2,4,15
<Reserved>

for future use

Example: TRAC:DATA? CWCDp

Returns a list of channel information for each channel in ascending order.

Usage: Query only
Manual operation: See "Channel Table"
See "Code Domain Power"


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? FINal1

This command returns the peak list. For each peak the following results are given:

Return values:
<Freq> | Peak frequency
<Level> | Peak level
<DeltaLevel> | Delta between current peak level and next higher peak level
Example: | TRAC2:DATA? FINal1 Returns a list of peak values.
Usage: | Query only
Mode: | BTS application only


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? LIST

This command returns the peak list of the spectrum emission mask measurement list evaluation.

An array of values is returned for each range of the limit line:

<array of range 1>, <array of range 2>, ….., <array of range n>,

where each array consists of the following values:

<No>, <Start>, <Stop>, <RBW>, <Freq>, <Levelabs>, <Levelrel>, <Delta>, <Limitcheck>, <Unused1>, <Unused2>

Parameters:
<No>

Number of the limit line range

<Start>

Start frequency of the limit line range

Default unit: Hz
<Stop>

Stop frequency of the limit line range

Default unit: Hz
<RBW>

Resolution bandwidth of the limit line range

Default unit: Hz
<Freq>

Frequency of the peak power within the range

Default unit: Hz
<Levelabs>

Absolute power of the peak within the range

Default unit: dBm
<Levelrel>

Relative power of the peak within the range related to channel power

Default unit: dB
<Delta>

Power difference to margin power

Default unit: dB
<Limitcheck>
0 | 1

Indicates whether the power is below [0] or above [1] the limit line

<Unused1>

for future use

<Unused2>

for future use

Example: TRAC2:DATA? LIST

Returns a list of SEM results for all slots in window 2.

Usage: Query only


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? PWCDp

This command returns the pilot length in addition to the values returned for "TRACE<t>".

This command is only available for Code Domain Power or Channel Table evaluations (see "Evaluation Methods for Code Domain Analysis").

Return values:
<CodeClass>
2 … 9

Code class of the channel

<ChannelNo>
0 … 511

Code number of the channel

<AbsLevel>
dBm

Absolute level of the code channel at the selected channel slot.

<RelLevel>
%

Relative level of the code channel at the selected channel slot referenced to CPICH or total power.

<TimingOffset>
0 … 38400 [chips]

Timing offset of the code channel to the CPICH frame start. The value is measured in chips. The step width is 256 chips in the case of code class 2 to 8, and 512 chips in the case of code class 9.

<PilotLength>
0,2,4,8,16

The length of the pilot symbols. According to the 3GPP standard, the pilot length range depends on the code class.

Default unit: symbols
Example: TRAC:DATA? PWCDp

Returns a list of channel information, including the pilot length.

Usage: Query only
Mode: BTS application only
Manual operation: See "Channel Table"
See "Code Domain Power"


TRACe<n>[:DATA]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? TPVSlot

This command returns a comma-separated list of absolute Power vs Slot results for all 16 slots. In contrast to the TRACE<t> parameter result, absolute values are returned.

Return values:
<SlotNumber> | 0...15 CPICH slot number
<Level> | dBm Slot level value
Example: | CALC2:FEED 'XTIM:CDP:PVSLot:ABSolute' Sets the evaluation for window 2 to POWER VS SLOT. TRAC2:DATA? TPVSlot Returns a list of absolute frequency errors for all slots in window 2.
Usage: | Query only
Manual operation: | See "Power vs Slot"


Exporting Trace Results

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Exporting Trace Results
Exporting Trace Results

RF measurement trace results can be exported to a file.

For more commands concerning data and results storage see the R&S FSW User Manual.

List of Commands
MMEMory:STORe:FINal
MMEMory:STORe<n>:TRACe
FORMat:DEXPort:DSEParator


MMEMory:STORe:FINal

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Exporting Trace Results > MMEMory:STORe:FINal
MMEMory:STORe:FINal <FileName>

This command exports the marker peak list to a file.

The file format is *.dat.

Parameters:
<FileName> | String containing the path and name of the target file.
Return values:
<TraceNo> | Always 1
<Frequency> | Frequency of the peak in Hz
<Level> | Absolute level of the peak in dBm
<DeltaLevel> | Distance to the limit line in dB
Example: | MMEM:STOR:FIN 'C:\test' Saves the current marker peak list in the file test.dat.


MMEMory:STORe<n>:TRACe

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Exporting Trace Results > MMEMory:STORe<n>:TRACe
MMEMory:STORe<n>:TRACe <Trace>, <FileName>

This command exports trace data from the specified window to an ASCII file.

For details on the file format see "Reference: ASCII File Export Format" .

Trace export is only available for RF measurements.

Secure User Mode

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Parameters:
<Trace> | Number of the trace to be stored
<FileName> | String containing the path and name of the target file.
Example: | MMEM:STOR1:TRAC 3,'C:\TEST.ASC' Stores trace 3 from window 1 in the file TEST.ASC.
Usage: | SCPI confirmed


FORMat:DEXPort:DSEParator

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Exporting Trace Results > FORMat:DEXPort:DSEParator
FORMat:DEXPort:DSEParator <Separator>

This command selects the decimal separator for data exported in ASCII format.

Parameters:
<Separator>
COMMa

Uses a comma as decimal separator, e.g. 4,05.

POINt

Uses a point as decimal separator, e.g. 4.05.

*RST: *RST has no effect on the decimal separator. Default is POINt.
Example: FORM:DEXP:DSEP POIN

Sets the decimal point as separator.


Retrieving RF Results

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving RF Results
Retrieving RF Results

The following commands are required to retrieve the results of the 3GPP FDD RF measurements.

See also:
  • MMEMory:​STORe:​FINal
List of Commands
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate<n>:MARKer<m>:Y?
CALCulate:STATistics:RESult<t>?


CALCulate:LIMit<k>:FAIL?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving RF Results > CALCulate:LIMit<k>:FAIL?
CALCulate:LIMit<k>:FAIL?

This command queries the result of a limit check.

Note that for SEM measurements, the limit line suffix <k> is irrelevant, as only one specific SEM limit line is checked for the currently relevant power class.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result>
0

PASS

1

FAIL

Example: INIT;*WAI

Starts a new sweep and waits for its end.

CALC:LIM3:FAIL?

Queries the result of the check for limit line 3.

Example:

See "Example: SEM Measurement" .

Usage: Query only
SCPI confirmed
Manual operation: See "RF Combi"
See "Spectrum Emission Mask"


CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving RF Results > CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult? <Measurement>

This command queries the results of power measurements.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Suffix:
<sb>
1 | 2 | 3

Sub block in a Multi-SEM measurement; for all other measurements: irrelevant

Query parameters:
<Measurement>
ACPower | MCACpower

ACLR measurements (also known as adjacent channel power or multicarrier adjacent channel measurements).

Returns the power for every active transmission and adjacent channel. The order is:

• power of the transmission channels

• power of adjacent channel (lower,upper)

• power of alternate channels (lower,upper)

MSR ACLR results:

For MSR ACLR measurements, the order of the returned results is slightly different:

• power of the transmission channels

• total power of the transmission channels for each sub block

• power of adjacent channels (lower, upper)

• power of alternate channels (lower, upper)

• power of gap channels (lower1, upper1, lower2, upper2)

The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

CN

Carrier-to-noise measurements.

Returns the C/N ratio in dB.

CN0

Carrier-to-noise measurements.

Returns the C/N ratio referenced to a 1 Hz bandwidth in dBm/Hz.

CPOWer

Channel power measurements.

Returns the channel power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the channel power of the reference range (in the specified sub block).

PPOWer

Peak power measurements.

Returns the peak power. The unit of the return values depends on the scaling of the y-axis:

• logarithmic scaling returns the power in the current unit

• linear scaling returns the power in W

For SEM measurements, the return value is the peak power of the reference range (in the specified sub block).

OBANdwidth | OBWidth

Occupied bandwidth.

Returns the occupied bandwidth in Hz.

Example:

See "Example: Configuring and Performing an ACLR Measurement" .

Example:

See "Example: Configuring and Performing an MSR ACLR Measurement" .

Example:

See "Programming example" .

Example:

See "Programming Example: OBW Measurement" .

Example:

See "Programming Examples (R&S FSW-K73)".

Example:

See "Programming Examples ( BTS)"

Usage: Query only
Manual operation: See "Ch Power ACLR"
See "Occupied Bandwidth"
See "Power"
See "RF Combi"
See "Spectrum Emission Mask"
See "CCDF"


CALCulate<n>:MARKer<m>:Y?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving RF Results > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table" See "CCDF" See "Marker Peak List" See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


CALCulate:STATistics:RESult<t>?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Retrieving Results > Retrieving RF Results > CALCulate:STATistics:RESult<t>?
CALCulate:STATistics:RESult<t>? <ResultType>

This command queries the results of a CCDF or ADP measurement for a specific trace.

Parameters:
<ResultType>
MEAN

Average (=RMS) power in dBm measured during the measurement time.

PEAK

Peak power in dBm measured during the measurement time.

CFACtor

Determined crest factor (= ratio of peak power to average power) in dB.

ALL

Results of all three measurements mentioned before, separated by commas: <mean power>,<peak power>,<crest factor>

Example: CALC:STAT:RES2? ALL

Reads out the three measurement results of trace 2. Example of answer string: 5.56,19.25,13.69 i.e. mean power: 5.56 dBm, peak power 19.25 dBm, crest factor 13.69 dB

Example:

See "Programming Example: Measuring Statistics" .

Usage: Query only
Manual operation: See "CCDF"


Analysis

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis
Analysis

The following commands define general result analysis settings concerning the traces and markers.

Contents
  • Traces
  • Markers


Traces

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Traces
Traces

The trace settings determine how the measured data is analyzed and displayed on the screen. In 3GPP FDD applications, only one trace per window can be configured for Code Domain Analysis.

List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]


DISPlay[:WINDow<n>]:TRACe<t>:MODE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with [SENSe:​]SWEep:​COUNt. Note that synchronization to the end of the measurement is possible only in single sweep mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trace Mode"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 for TRACe1, 0 for TRACe 2 to 6
Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


Markers

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. In 3GPP FDD applications, only 4 markers per window can be configured for Code Domain Analysis.

Contents
  • Individual Marker Settings
  • General Marker Settings
  • Marker Search and Positioning Settings


Individual Marker Settings

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings
Individual Marker Settings
List of Commands
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?


CALCulate<n>:MARKer<m>[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:X

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The unit is either Hz (frequency domain) or s (time domain) or dB (statistics).

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker Peak List"
See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:MARKer<m>:AOFF

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:DELTamarker<m>[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker:AOFF

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:X

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

Range: The value range and unit depend on the measurement and scale of the x-axis.
Example: CALC:DELT:X?

Outputs the absolute x-value of delta marker 1.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / Marker 4"
See "X-value"


CALCulate<n>:DELTamarker<m>:X:RELative?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


CALCulate<n>:DELTamarker<m>:Y?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Individual Marker Settings > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / Marker 4"


General Marker Settings

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > General Marker Settings
General Marker Settings
List of Commands
DISPlay:MTABle


DISPlay:MTABle

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


Marker Search and Positioning Settings

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings
Marker Search and Positioning Settings
List of Commands
CALCulate<n>:MARKer<m>:FUNCtion:CPICh
CALCulate<n>:MARKer<m>:FUNCtion:PCCPch
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:FUNCtion:CPICh
CALCulate<n>:DELTamarker<m>:FUNCtion:PCCPch
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:FUNCtion:CPICh

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:FUNCtion:CPICh
CALCulate<n>:MARKer<m>:FUNCtion:CPICh

This command sets the marker to channel 0.

This command is only available in Code Domain Power and Code Domain Error Power evaluations.

Example: | CALC:MARK:FUNC:CPIC
Manual operation: | See "Marker To CPICH"


CALCulate<n>:MARKer<m>:FUNCtion:PCCPch

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:FUNCtion:PCCPch
CALCulate<n>:MARKer<m>:FUNCtion:PCCPch

This command sets the marker to the position of the PCCPCH.

This command is only available in code domain power and code domain error power evaluations.

Example: | CALC:MARK:FUNC:PCCP
Manual operation: | See "Marker To PCCPCH"


CALCulate<n>:MARKer<m>:MAXimum:LEFT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MINimum:LEFT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:FUNCtion:CPICh

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:CPICh
CALCulate<n>:DELTamarker<m>:FUNCtion:CPICh

This command sets the delta marker to channel 0.

This command is only available in Code Domain Power and Code Domain Error Power evaluations.

Example:

CALC:DELT2:FUNC:CPIC


CALCulate<n>:DELTamarker<m>:FUNCtion:PCCPch

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:FUNCtion:PCCPch
CALCulate<n>:DELTamarker<m>:FUNCtion:PCCPch

This command sets the delta marker to the position of the PCCPCH.

This command is only available in code domain power and code domain error power evaluations.

Example:

CALC:DELT2:FUNC:PCCP


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Analysis > Markers > Marker Search and Positioning Settings > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Configuring the Application Data Range (MSRA mode only)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Application Data Range (MSRA mode only)
Configuring the Application Data Range (MSRA mode only)

In MSRA operating mode, only the MSRA Master actually captures data; the MSRA applications define an extract of the captured data for analysis, referred to as the application data.

For the 3GPP FDD BTS application, the application data range is defined by the same commands used to define the signal capture in Signal and Spectrum Analyzer mode (see [SENSe:​]CDPower:​IQLength). Be sure to select the correct measurement channel before executing this command.

In addition, a capture offset can be defined, i.e. an offset from the start of the captured data to the start of the application data for the 3GPP FDD BTS measurement.

The analysis interval used by the individual result displays cannot be edited, but is determined automatically. However, you can query the currently used analysis interval for a specific window.

The analysis line is displayed by default but can be hidden or re-positioned.

Remote commands exclusive to MSRA applications

The following commands are only available for MSRA application channels:

List of Commands
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
INITiate:REFResh
[SENSe:]MSRA:CAPTure:OFFSet


CALCulate:MSRA:ALINe:SHOW

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe:SHOW

This command defines whether or not the analysis line is displayed in all time-based windows in all MSRA applications and the MSRA Master.

Note: even if the analysis line display is off, the indication whether or not the currently defined line position lies within the analysis interval of the active application remains in the window title bars.

Parameters:
<State>
ON | OFF
*RST: ON


CALCulate:MSRA:ALINe[:VALue]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:ALINe[:VALue] <Position>

This command defines the position of the analysis line for all time-based windows in all MSRA applications and the MSRA Master.

Parameters:
<Position>

Position of the analysis line in seconds. The position must lie within the measurement time of the MSRA measurement.

Default unit: s


CALCulate:MSRA:WINDow<n>:IVAL?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Application Data Range (MSRA mode only) > CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:MSRA:WINDow<n>:IVAL?

This command queries the analysis interval for the window specified by the index <n>. This command is only available in application measurement channels, not the MSRA View or MSRA Master.

Return values:
<IntStart>

Start value of the analysis interval in seconds

Default unit: s
<IntStop>

Stop value of the analysis interval in seconds

Usage: Query only


INITiate:REFResh

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Application Data Range (MSRA mode only) > INITiate:REFResh
INITiate:REFResh

This function is only available if the Sequencer is deactivated (SYST:SEQ:OFF) and only for applications in MSRA mode, not the MSRA Master.

The data in the capture buffer is re-evaluated by the currently active application only. The results for any other applications remain unchanged.

Example: | SYST:SEQ:OFF Deactivates the scheduler INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a new data measurement and waits for the end of the sweep. INST:SEL 'IQ ANALYZER' Selects the IQ Analyzer channel. INIT:REFR Refreshes the display for the I/Q Analyzer channel.
Usage: | Event
Manual operation: | See "Refresh"


[SENSe:]MSRA:CAPTure:OFFSet

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Configuring the Application Data Range (MSRA mode only) > [SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet <Offset>

This setting is only available for applications in MSRA mode, not for the MSRA Master. It has a similar effect as the trigger offset in other measurements.

Parameters:
<Offset>

This parameter defines the time offset between the capture buffer start and the start of the extracted application data. The offset must be a positive value, as the application can only analyze data that is contained in the capture buffer.

Range: | 0 to <Record length>
*RST: | 0
Manual operation: See "Capture Offset"


Querying the Status Registers

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Querying the Status Registers
Querying the Status Registers

The following commands are required for the status reporting system specific to the 3GPP FDD applications. In addition, the 3GPP FDD applications also use the standard status registers of the R&S FSW (depending on the measurement type).

For details and a description of the common R&S FSW status registers see "Status Reporting System" .

*RST does not influence the status registers.

The STATus:QUEStionable:DIQ register is described in "STATus:QUEStionable:DIQ Register".

The STATus:QUEStionable:SYNC register contains application-specific information about synchronization errors or errors during pilot symbol detection.

Status error bits in STATus:QUEStionable:SYNC register for 3GPP FDD applications

Bit

Definition

0

Not used.

1

Frame Sync failed

This bit is set when synchronization is not possible within the application.

Possible reasons:

  • Incorrectly set frequency
  • Incorrectly set level
  • Incorrectly set scrambling code
  • Incorrectly set values for Q-INVERT or SIDE BAND INVERT
  • Invalid signal at input
  • Antenna 1 synchronization is not possible (Time Alignment Error measurements, 3GPP FDD BTS only)

2

For Time Alignment Error measurements (3GPP FDD BTS only): bit is set if antenna 2 synchronization is not possible;

Otherwise: not used.

3 to 4

Not used.

5

Incorrect Pilot Symbol

This bit is set when one or more of the received pilot symbols are not equal to the specified pilot symbols of the 3GPP standard.

Possible reasons:

  • Incorrectly sent pilot symbols in the received frame.
  • Low signal to noise ratio (SNR) of the W-CDMA signal.
  • One or more code channels has a significantly lower power level compared to the total power. The incorrect pilots are detected in these channels because of low channel SNR.
  • One or more channels are sent with high power ramping. In slots with low relative power to total power, the pilot symbols might be detected incorrectly (check the signal quality by using the symbol constellation display).

6 to 14

Not used.

15

This bit is always 0.

List of Commands
STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition


STATus:QUEStionable:SYNC[:EVENt]?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC[:EVENt]?
STATus:QUEStionable:SYNC[:EVENt]? <ChannelName>

This command reads out the EVENt section of the status register.

The command also deletes the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:SYNC:CONDition?

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:CONDition? <ChannelName>

This command reads out the CONDition section of the status register.

The command does not delete the contents of the EVENt section.

Query parameters:
<ChannelName> | String containing the name of the channel. The parameter is optional. If you omit it, the command works for the currently active channel.
Usage: | Query only


STATus:QUEStionable:SYNC:ENABle

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:ENABle <BitDefinition>, <ChannelName>

This command controls the ENABle part of a register.

The ENABle part allows true conditions in the EVENt part of the status register to be reported in the summary bit. If a bit is 1 in the enable register and its associated event bit transitions to true, a positive transition will occur in the summary bit reported to the next higher level.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:NTRansition

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:NTRansition <BitDefinition>,<ChannelName>

This command controls the Negative TRansition part of a register.

Setting a bit causes a 1 to 0 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


STATus:QUEStionable:SYNC:PTRansition

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Querying the Status Registers > STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC:PTRansition <BitDefinition>,<ChannelName>

These commands control the Positive TRansition part of a register.

Setting a bit causes a 0 to 1 transition in the corresponding bit of the associated register. The transition also writes a 1 into the associated bit of the corresponding EVENt register.

Parameters:
<BitDefinition>
Range: 0 to 65535
<ChannelName>

String containing the name of the channel.

The parameter is optional. If you omit it, the command works for the currently active channel.


Commands for Compatibility

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Commands for Compatibility
Commands for Compatibility

The following commands are provided for compatibility to other signal analyzers only. For new remote control programs use the specified alternative commands.

List of Commands
CALCulate<n>:FEED
[SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:PRESet
[SENSe:]CDPower:UCPich:CODE
[SENSe:]CDPower:UCPich:PATTern
[SENSe:]CDPower:UCPich[:STATe]


CALCulate<n>:FEED

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Commands for Compatibility > CALCulate<n>:FEED
CALCulate<n>:FEED <Evaluation>

This command selects the evaluation method of the measured data that is to be displayed in the specified window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<Evaluation> | Type of evaluation you want to display. See the table below for available parameter values.
Example: | INST:SEL BWCD Activates 3GPP FDD BTS mode. CALC:FEED CDP Selects the display of the code domain power.
<Evaluation> parameter values for 3GPP FDD applications
String Parameter | Enum Parameter | Evaluation
'XTIM:CDP:BSTReam' | BITStream | Bitstream
'XTIM:CDP:COMP:CONStellation' | CCONst | Composite Constellation
'XPOW:CDEPower' | CDEPower | Code Domain Error Power
'XPOW:CDP' 'XPOW:CDP:ABSolute' | CDPower | Code Domain Power (absolute scaling)
'XPOW:CDP:RATio' | CDPower | Code Domain Power (relative scaling) *)
'XTIM:CDP:MACCuracy' | CEVM | Composite EVM
'XTIM:CDP:ERR:CTABle' | CTABle | Channel Table
'XTIMe:CDP:CHIP:EVM' | EVMChip | EVM vs Chip
'XTIM:CDP:FVSLot' | FESLot | Frequency Error vs Slot
'XTIMe:CDP:CHIP:MAGNitude' | MECHip | Magnitude Error vs Chip
'XTIM:CDP:ERR:PCDomain' | PCDerror | Peak Code Domain Error
'XTIM:CDPower:PSVSlot' | PDSLot | Phase Discontinuity vs Slot
'XTIMe:CDPower:CHIP:PHASe' | PECHip | Phase Error vs Chip
'XTIM:CDP:PVSLot' 'XTIM:CDP:PVSLot:ABSolute' | PSLot | Power vs Slot (absolute scaling)
'XTIM:CDP:PVSLot:RATio' | PSLot | Power vs Slot (relative scaling)*)
'XTIM:CDP:PVSYmbol' | PSYMbol | Power vs Symbol
'XTIM:CDP:ERR:SUMMary' | RSUMmary | Result Summary
‘XPOW:CDP:RATio' | SCONst | Symbol Constellation
'XTIM:CDP:SYMB:EVM' | SEVM | Symbol EVM
'XTIMe:CDPower:SYMBol:EVM:MAGNitude' | SMERror | Symbol Magnitude Error
'XTIMe:CDPower:SYMBol:EVM:PHASe' | SPERror | Symbol Phase Error
*) Use [SENS:]CDP:PDIS ABS | REL subsequently to change the scaling


[SENSe:]CDPower:LEVel:ADJust

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Commands for Compatibility > [SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:LEVel:ADJust

This command adjusts the reference level to the measured channel power. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Note that this command is retained for compatibility reasons only. For new R&S FSW programs use [SENSe:​]ADJust:​LEVel.


[SENSe:]CDPower:PRESet

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Commands for Compatibility > [SENSe:]CDPower:PRESet
[SENSe:]CDPower:PRESet

This command resets the 3GPP FDD channel to its predefined settings. Any RF measurement is aborted and the measurement type is reset to Code Domain Analysis.

Note that this command is retained for compatibility reasons only. For new R&S FSW programs use SYSTem:​PRESet:​CHANnel[:​EXECute].

Usage: Event


[SENSe:]CDPower:UCPich:CODE

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Commands for Compatibility > [SENSe:]CDPower:UCPich:CODE
[SENSe:]CDPower:UCPich:CODE <CodeNumber>

This command sets the code number of the user defined CPICH used for signal analysis.

This command only applies to antenna 1.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]CDPower:​UCPich:​ANT<antenna>:​CODE for new remote control programs.

Parameters:
<CodeNumber>
Range: | 0 to 225
*RST: | 0
Example:

SENS:CDP:UCP:CODE 10

Mode: BTS application only


[SENSe:]CDPower:UCPich:PATTern

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Commands for Compatibility > [SENSe:]CDPower:UCPich:PATTern
[SENSe:]CDPower:UCPich:PATTern <Pattern>

This command defines which pattern is used for signal analysis for the user-defined CPICH (see [SENSe:​]CDPower:​UCPich[:​STATe]).

This command only applies to antenna 1.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]CDPower:​UCPich:​ANT<antenna>[:​STATe] for new remote control programs.

Parameters:
<Pattern>
1

fixed usage of "Pattern 1" according to standard

2

fixed usage of "Pattern 2" according to standard

*RST: 2
Example:

SENS:CDP:UCP:PATT 1

Mode: BTS application only


[SENSe:]CDPower:UCPich[:STATe]

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Commands for Compatibility > [SENSe:]CDPower:UCPich[:STATe]
[SENSe:]CDPower:UCPich[:STATe] <State>

Defines whether the common pilot channel (CPICH) is defined by a user-defined position instead of its default position.

If enabled, the user-defined position must be defined using [SENSe:​]CDPower:​UCPich:​CODE.

This command only applies to antenna 1.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]CDPower:​UCPich:​ANT<antenna>:​CODE for new remote control programs.

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

SENS:CDP:UCP ON

Mode: BTS application only


Programming Examples (R&S FSW-K73)

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Programming Examples (R&S FSW-K73)
Programming Examples (R&S FSW-K73)

The following programming examples are based on the measurement examples described in "Measurement Examples" for manual operation. The measurements are performed with an R&S FSW equipped with option R&S FSW-K73. Only the commands required to control the R&S FSW-K73 application are provided, not the signal generator.

The measurements are performed using the following devices and accessories:

  • The R&S FSW with Application Firmware R&S FSW-K73: 3GPP FDD UE user equipment test
  • The Vector Signal Generator R&S SMU with option R&S SMU-B45: digital standard 3GPP (options R&S SMU-B20 and R&S SMU-B11 required)
  • 1 coaxial cable, 50Ω, approx. 1 m, N connector
  • 1 coaxial cable, 50Ω, approx. 1 m, BNC connector
Test setup

  1. Connect the RF output of the R&S SMU to the input of the R&S FSW.

  2. Connect the reference input (REF INPUT) on the rear panel of the R&S FSW to the reference input (REF) on the rear panel of the R&S SMU (coaxial cable with BNC connectors).

  3. Connect the external trigger input on the front panel of the R&S FSW (TRIGGER INPUT) to the external trigger output on the front panel of the R&S SMU (TRIGOUT1 of PAR DATA).

Settings on the R&S SMU
Setting | Value
Preset |
Frequency | 2.1175 GHz
Level | 0 dBm
Digital standard | WCDMA/3GPP
Link direction | UP/REVERSE
Test model | DPCCH_DPDCH960ksps
User equipment | UE 1
Digital standard - State | ON
Scrambling code | 0000

The following measurements are described:

Contents
  • Measurement 1: Measuring the Signal Channel Power
  • Measurement 2: Determining the Spectrum Emission Mask
  • Measurement 3: Measuring the Relative Code Domain Power
  • Measurement 4: Triggered Measurement of Relative Code Domain Power
  • Measurement 5: Measuring the Composite EVM
  • Measurement 6: Determining the Peak Code Domain Error


Measurement 1: Measuring the Signal Channel Power

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Programming Examples (R&S FSW-K73) > Measurement 1: Measuring the Signal Channel Power
Measurement 1: Measuring the Signal Channel Power
*RST
//Reset the instrument
INST:CRE:NEW MWCD,'UEMeasurement'
//Activate a 3GPP FDD UE measurement channel named "UEMeasurement"
DISP:TRAC:Y:SCAL:RLEV 0
//Set the reference level to 0 dBm
FREQ:CENT 2.1175 GHz
//Set the center frequency to 2.1175 GHz
CONF:WCDP:MS:MEAS POW
//Select the power measurement
DISP:TRAC:Y:SCAL:AUTO ONCE
//Optimize the scaling of the y-axis for the current measurement
INIT:CONT OFF
//Stops continuous sweep
SWE:COUN 100
//Sets the number of sweeps to be performed to 100
INIT;*WAI
//Start a new measurement with 100 sweeps and wait for the end
CALC:MARK:FUNC:POW:RES? CPOW
//Retrieves the calculated total power value of the signal channel
//Result: -1.02 [dB]
TRAC:DATA? TRACE1
//Retrieve the trace data of the power measurement
//Result: -1.201362252,-1.173495054,-1.187217355,-1.186594367,-1.171583891,
//-1.188250422,-1.204138160,-1.181404829,-1.186317205,-1.197872400, [...]
Trace results for power measurement
Frequency | Power level
-1.201362252 | -1.173495054
-1.187217355 | -1.186594367
-1.171583891 | -1.188250422
... | ...


Measurement 2: Determining the Spectrum Emission Mask

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Programming Examples (R&S FSW-K73) > Measurement 2: Determining the Spectrum Emission Mask
Measurement 2: Determining the Spectrum Emission Mask
*RST
//Reset the instrument
INST:CRE:NEW MWCD,'UEMeasurement'
//Activate a 3GPP FDD UE measurement channel named "UEMeasurement"
DISP:TRAC:Y:SCAL:RLEV 0
//Set the reference level to 0 dBm
FREQ:CENT 2.1175 GHz
//Set the center frequency to 2.1175 GHz
CONF:WCDP:MS:MEAS ESP
//Select the spectrum emission mask measurement
DISP:TRAC:Y:SCAL:AUTO ONCE
//Optimize the scaling of the y-axis for the current measurement
INIT:CONT OFF
//Stops continuous sweep
SWE:COUN 100
//Sets the number of sweeps to be performed to 100
INIT;*WAI
//Start a new measurement with 100 sweeps and wait for the end
CALC:MARK:FUNC:POW:RES? CPOW
//Retrieves the calculated channel power value of the reference channel
//Result: -36.013 [dBm]
CALC:LIM:FAIL?
//Queries the result of the limit check
//Result: 0 [passed]
TRAC:DATA? LIST
//Retrieves the peak list of the spectrum emission mask measurement
//Result:
//+1.000000000,-1.275000000E+007,-8.500000000E+006,+1.000000000E+006,+2.108782336E+009,
//-8.057177734E+001,-7.882799530E+001,-2.982799530E+001,+0.000000000,+0.000000000,+0.000000000,

//+2.000000000,-8.500000000E+006,-7.500000000E+006,+1.000000000E+006,+2.109000064E+009,
//-8.158547211E+001,-7.984169006E+001,-3.084169006E+001,+0.000000000,+0.000000000,+0.000000000,

//+3.000000000,-7.500000000E+006,-3.500000000E+006,+1.000000000E+006,+2.113987200E+009,
//-4.202708435E+001,-4.028330231E+001,-5.270565033,+0.000000000,+0.000000000,+0.000000000,

 [...]
Trace results for SEM measurement
Range No. | Start freq. [Hz] | Stop freq. [Hz] | RBW [Hz] | Freq. peak power [Hz] | Abs. peak power [dBm] | Rel. peak power [%] | Delta to margin [dB] | Limit check result | - | - | -
1 | +1.000000000 | -1.275000000E+007 | -8.500000000E+006 | +1.000000000E+006 | +2.108782336E+009 | -8.057177734E+001 | -7.882799530E+001 | -2.982799530E+001 | +0.000000000 | +0.000000000 | +0.000000000
2 | +2.000000000 | -8.500000000E+006 | -7.500000000E+006 | +1.000000000E+006 | +2.109000064E+009 | -8.158547211E+001 | -7.984169006E+001 | -3.084169006E+001 | +0.000000000 | +0.000000000 | +0.000000000
3 | +3.000000000 | -7.500000000E+006 | -3.500000000E+006 | +1.000000000E+006 | +2.113987200E+009 | -4.202708435E+001 | -4.028330231E+001 | -5.270565033 | +0.000000000 | +0.000000000 | +0.000000000
... | ... |  |  |  |  |  |  |  |  |  |


Measurement 3: Measuring the Relative Code Domain Power

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Programming Examples (R&S FSW-K73) > Measurement 3: Measuring the Relative Code Domain Power
Measurement 3: Measuring the Relative Code Domain Power
*RST
//Reset the instrument
INST:CRE:NEW MWCD,'UEMeasurement'
//Activate a 3GPP FDD UE measurement channel named "UEMeasurement"
DISP:TRAC:Y:SCAL:RLEV 10
//Set the reference level to 10 dBm
FREQ:CENT 2.1175 GHz
//Set the center frequency to 2.1175 GHz
DISP:TRAC:Y:SCAL:AUTO ONCE
//Optimize the scaling of the y-axis for the current measurement
INIT:CONT OFF
//Stops continuous sweep
SWE:COUN 100
//Set the number of sweeps to be performed to 100
INIT;*WAI
//Start a new measurement with 100 sweeps and wait for the end
CALC:MARK:FUNC:WCDP:MS:RES? CDPR
//Retrieve the relative code domain power
//Result: 0 [dB]
TRAC:DATA? TRACE1
//Retrieve the trace data of the code domain power measurement
//Result: +8.000000000,+0.000000000,-4.319848537,-3.011176586,+0.000000000,
//+2.000000000,+1.000000000,-4.318360806,-3.009688854,+1.000000000,
//+8.000000000,+0.000000000,-7.348078156E+001,-7.217211151E+001,+1.000000000,
// [...]

----------Synchronizing the Reference Frequencies-------------------------

ROSC:SOUR EXT10
//Select the external frequency from the REF INPUT 1..20 MHZ connector as a reference
CALC:MARK:FUNC:WCDP:MS:RES? FERR
//Query the carrier frequency error
//Result: 0.1 [Hz]

---------Behaviour with Incorrect Scrambling Code------------------------

CDP:LCOD:DVAL 0001
//Change the scrambling code on the analyzer to 0001 (default is 0000)
TRAC:DATA? TRACE1
//Retrieve the trace data of the code domain power measurement
//Result: 1.000000000,+8.000000000,+7.700000000E+001,-2.991873932E+001,-2.861357307E+001,
//+0.000000000,+8.000000000,+7.800000000E+001,-2.892916107E+001,-2.762399483E+001,
//+1.000000000,+8.000000000,+7.800000000E+001,-2.856664085E+001,-2.726147461E+001,
// [...]
Trace results for Relative Code Domain Power measurement (correct scrambling code)
Code class | Channel no. | Abs. power level [dBm] | Rel. power level [%] | Timing offset [chips]
+8.000000000 | +0.000000000 | -4.319848537 | -3.011176586 | +0.000000000
+2.000000000 | +1.000000000 | -4.318360806 | -3.009688854 | +1.000000000
+8.000000000 | +0.000000000 | -7.348078156E+001 | -7.217211151E+001 | +1.000000000
... | ... |  |  |
Trace results for Relative Code Domain Power measurement (incorrect scrambling code)
Code class | Channel no. | Abs. power level [dBm] | Rel. power level [%] | Timing offset [chips]
1.000000000 | +8.000000000 | +7.700000000E+001 | -2.991873932E+001 | -2.861357307E+001
+0.000000000 | +8.000000000 | +7.800000000E+001 | -2.892916107E+001 | -2.762399483E+001
+1.000000000 | +8.000000000 | +7.800000000E+001 | -2.856664085E+001 | -2.726147461E+001
... | ... |  |  |


Measurement 4: Triggered Measurement of Relative Code Domain Power

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Programming Examples (R&S FSW-K73) > Measurement 4: Triggered Measurement of Relative Code Domain Power
Measurement 4: Triggered Measurement of Relative Code Domain Power
*RST
//Reset the instrument
INST:CRE:NEW MWCD,'UEMeasurement'
//Activate a 3GPP FDD UE measurement channel named "UEMeasurement"
DISP:TRAC:Y:SCAL:RLEV 10
//Set the reference level to 10 dBm
FREQ:CENT 2.1175 GHz
//Set the center frequency to 2.1175 GHz
CDP:LCOD:DVAL 0000
//Change the scrambling code on the analyzer to 0000
TRIG:SOUR EXT
//Set the trigger source to the external trigger
//(TRIGGER INPUT connector on the front panel)
DISP:TRAC:Y:SCAL:AUTO ONCE
//Optimize the scaling of the y-axis for the current measurement
INIT:CONT OFF
//Stops continuous sweep
SWE:COUN 100
//Set the number of sweeps to be performed to 100
INIT;*WAI
//Start a new measurement with 100 sweeps and wait for the end
CALC:MARK:FUNC:WCDP:MS:RES? TFR
//Retrieve the trigger to frame (the offset between trigger event and
// start of first captured frame)
//Result: 0.00599987013 [ms]

------- Compensating a delay of the trigger event to the first captured frame -------

TRIG:HOLD 100 us
//Change the trigger offset to 100 us (=trigger to frame value)
CALC:MARK:FUNC:WCDP:MS:RES? TFR
//Retrieve the trigger to frame value
//Result: 0.00599987013 [ms]


Measurement 5: Measuring the Composite EVM

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Programming Examples (R&S FSW-K73) > Measurement 5: Measuring the Composite EVM
Measurement 5: Measuring the Composite EVM
*RST
//Reset the instrument
INST:CRE:NEW MWCD,'UEMeasurement'
//Activate a 3GPP FDD UE measurement channel named "UEMeasurement"
DISP:TRAC:Y:SCAL:RLEV 10
//Set the reference level to 10 dBm
FREQ:CENT 2.1175 GHz
//Set the center frequency to 2.1175 GHz
TRIG:SOUR EXT
//Set the trigger source to the external trigger
//(TRIGGER INPUT connector on the front panel)
LAY:REPL '2','XTIM:CDP:MACC'
//Replace the second measurement window (Result Summary) by Composite EVM evaluation
DISP:WIND2:TRAC:Y:SCAL:AUTO ONCE
//Optimize the scaling of the y-axis for the Composite EVM measurement
INIT:CONT OFF
//Stops continuous sweep
SWE:COUN 100
//Set the number of sweeps to be performed to 100
INIT;*WAI
//Start a new measurement with 100 sweeps and wait for the end
TRAC2:DATA? TRACE1
//Retrieve the trace data of the composite EVM measurement
//Result: +0.000000000,+5.876136422E-001,
//+1.000000000,+5.916179419E-001,
//+2.000000000,+5.949081182E-001,
//[...]
Trace results for Composite EVM measurement
(CPICH) Slot number | EVM
0 | +5.876136422E-001
1 | +5.916179419E-001
2 | +5.949081182E-001
... | ...


Measurement 6: Determining the Peak Code Domain Error

3G FDD Measurements (R&S FSW-K72/K73) > Remote Commands for 3GPP FDD Measurements > Programming Examples (R&S FSW-K73) > Measurement 6: Determining the Peak Code Domain Error
Measurement 6: Determining the Peak Code Domain Error
*RST
//Reset the instrument
INST:CRE:NEW MWCD,'UEMeasurement'
//Activate a 3GPP FDD UE measurement channel named "UEMeasurement"
DISP:TRAC:Y:SCAL:RLEV 10
//Set the reference level to 10 dBm
FREQ:CENT 2.1175 GHz
//Set the center frequency to 2.1175 GHz
TRIG:SOUR EXT
//Set the trigger source to the external trigger
//(TRIGGER INPUT connector on the front panel)
LAY:REPL '2','XTIM:CDP:ERR:PCD'
//Replace the second measurement window (Result Summary) by the
//Peak Code Domain Error evaluation
DISP:WIND2:TRAC:Y:SCAL:AUTO ONCE
//Optimize the scaling of the y-axis for the Composite EVM measurement
INIT:CONT OFF
//Stops continuous sweep
SWE:COUN 100
//Set the number of sweeps to be performed to 100
INIT;*WAI
//Start a new measurement with 100 sweeps and wait for the end
TRAC2:DATA? TRACE1
//Retrieve the trace data of the Peak Code Domain Error measurement
//Result: +0.000000000,-6.730751038E+001,
//+1.000000000,-6.687619019E+001,
//+2.000000000,-6.728615570E+001,
// [...]
Trace results for Peak Code Domain Error measurement
Slot number | Peak Error
0 | -6.730751038E+001
1 | -6.687619019E+001
2 | -6.728615570E+001
... | ...


List of Remote Commands (3GPP FDD)

3G FDD Measurements (R&S FSW-K72/K73) > List of Remote Commands (3GPP FDD)
List of Remote Commands (3GPP FDD)
[SENSe:]ADJust:ALL
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]AVERage:COUNt
[SENSe:]CDPower:ANTenna
[SENSe:]CDPower:BASE
[SENSe:]CDPower:CODE
[SENSe:]CDPower:CPB
[SENSe:]CDPower:ETCHips
[SENSe:]CDPower:FILTer[:STATe]
[SENSe:]CDPower:FRAMe[:VALue]
[SENSe:]CDPower:HSDPamode
[SENSe:]CDPower:HSLot
[SENSe:]CDPower:ICTReshold
[SENSe:]CDPower:IQLength
[SENSe:]CDPower:LCODe:DVALue
[SENSe:]CDPower:LCODe:SEARch:LIST?
[SENSe:]CDPower:LCODe:SEARch[:IMMediate]?
[SENSe:]CDPower:LCODe:TYPE
[SENSe:]CDPower:LCODe[:VALue]
[SENSe:]CDPower:LEVel:ADJust
[SENSe:]CDPower:MAPPing
[SENSe:]CDPower:MIMO
[SENSe:]CDPower:NORMalize
[SENSe:]CDPower:PCONtrol
[SENSe:]CDPower:PDIFf
[SENSe:]CDPower:PDISplay
[SENSe:]CDPower:PREFerence
[SENSe:]CDPower:PRESet
[SENSe:]CDPower:QINVert
[SENSe:]CDPower:QPSK
[SENSe:]CDPower:SBANd
[SENSe:]CDPower:SFACtor
[SENSe:]CDPower:SLOT
[SENSe:]CDPower:STYPe
[SENSe:]CDPower:UCPich:ANT<antenna>:CODE
[SENSe:]CDPower:UCPich:ANT<antenna>:PATTern
[SENSe:]CDPower:UCPich:ANT<antenna>[:STATe]
[SENSe:]CDPower:UCPich:CODE
[SENSe:]CDPower:UCPich:PATTern
[SENSe:]CDPower:UCPich[:STATe]
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:OFFSet
[SENSe:]MSRA:CAPTure:OFFSet
[SENSe:]PROBe<ch>:SETup:CMOFfset
[SENSe:]PROBe<p>:ID:PARTnumber?
[SENSe:]PROBe<p>:ID:SRNumber?
[SENSe:]PROBe<p>:SETup:MODE
[SENSe:]PROBe<p>:SETup:NAME?
[SENSe:]PROBe<p>:SETup:STATe?
[SENSe:]PROBe<p>:SETup:TYPE?
[SENSe:]SWEep:COUNt
ABORt
CALCulate:LIMit<k>:FAIL?
CALCulate:MARKer:FUNCtion:POWer<sb>:RESult?
CALCulate:MARKer<m>:FUNCtion:ZOOM
CALCulate:MSRA:ALINe:SHOW
CALCulate:MSRA:ALINe[:VALue]
CALCulate:MSRA:WINDow<n>:IVAL?
CALCulate:STATistics:RESult<t>?
CALCulate<n>:CDPower:Mapping
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:FUNCtion:CPICh
CALCulate<n>:DELTamarker<m>:FUNCtion:PCCPch
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:FEED
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:FUNCtion:CPICh
CALCulate<n>:MARKer<m>:FUNCtion:PCCPch
CALCulate<n>:MARKer<m>:FUNCtion:TAERror:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:WCDPower:MS:RESult?
CALCulate<n>:MARKer<m>:FUNCtion:WCDPower[:BTS]:RESult?
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALibration:AIQ:DCOFfset:I
CALibration:AIQ:DCOFfset:Q
CONFigure:WCDPower:MS:CTABle:CATalog?
CONFigure:WCDPower:MS:CTABle:COMMent
CONFigure:WCDPower:MS:CTABle:COPY
CONFigure:WCDPower:MS:CTABle:DATA
CONFigure:WCDPower:MS:CTABle:DATA:HSDPcch
CONFigure:WCDPower:MS:CTABle:DELete
CONFigure:WCDPower:MS:CTABle:EDATa
CONFigure:WCDPower:MS:CTABle:EDATa:EDPCc
CONFigure:WCDPower:MS:CTABle:NAME
CONFigure:WCDPower:MS:CTABle:SELect
CONFigure:WCDPower:MS:CTABle[:STATe]
CONFigure:WCDPower:MS:MEASurement
CONFigure:WCDPower[:BTS]:ASCale[:STATe]
CONFigure:WCDPower[:BTS]:CTABle:CATalog?
CONFigure:WCDPower[:BTS]:CTABle:COMMent
CONFigure:WCDPower[:BTS]:CTABle:COMPare
CONFigure:WCDPower[:BTS]:CTABle:COPY
CONFigure:WCDPower[:BTS]:CTABle:DATA
CONFigure:WCDPower[:BTS]:CTABle:DELete
CONFigure:WCDPower[:BTS]:CTABle:NAME
CONFigure:WCDPower[:BTS]:CTABle:SELect
CONFigure:WCDPower[:BTS]:CTABle:TOFFset
CONFigure:WCDPower[:BTS]:CTABle[:STATe]
CONFigure:WCDPower[:BTS]:MCARrier:STATe
CONFigure:WCDPower[:BTS]:MEASurement
CONFigure:WCDPower[:BTS]:STD
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:AUTO ONCE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FORMat:DEXPort:DSEParator
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:REFResh
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate:SEQuencer:REFResh[:ALL]
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:CONNector
INPut:COUPling
INPut:DIQ:CDEVice
INPut:DIQ:RANGe:COUPling
INPut:DIQ:RANGe[:UPPer]
INPut:DIQ:RANGe[:UPPer]:AUTO
INPut:DIQ:RANGe[:UPPer]:UNIT
INPut:DIQ:SRATe
INPut:DIQ:SRATe:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:IQ:BALanced[:STATe]
INPut:IQ:FULLscale:AUTO
INPut:IQ:FULLscale[:LEVel]
INPut:IQ:TYPE
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:STORe:FINal
MMEMory:STORe<n>:TRACe
OUTPut:DIQ
OUTPut:DIQ:CDEVice
OUTPut:IF:IFFRequency
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
STATus:QUEStionable:DIQ:CONDition?
STATus:QUEStionable:DIQ:ENABle
STATus:QUEStionable:DIQ:NTRansition
STATus:QUEStionable:DIQ:PTRansition
STATus:QUEStionable:DIQ[:EVENt]?
STATus:QUEStionable:SYNC:CONDition?
STATus:QUEStionable:SYNC:ENABle
STATus:QUEStionable:SYNC:NTRansition
STATus:QUEStionable:SYNC:PTRansition
STATus:QUEStionable:SYNC[:EVENt]?
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe:IQ:APCon:A
TRACe:IQ:APCon:B
TRACe:IQ:APCon:RESult?
TRACe:IQ:APCon[:STATe]
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:BBPower:HOLDoff
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:BBPower
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:VIDeo
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:TIME:RINTerval


Legal Notice

R&S®FSW-K72/K73
3GPP FDD Measurements Options

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.